Welcome to discussions

Quick Suggestions

  • Ubi-Borealis
    Ubisoft Support Staff 2877 posts

    @Edhelvar - That's great to hear! Congratulations for getting platinum as well! 👏

    Official Response
  • Ubi-Borealis
    Ubisoft Support Staff 2877 posts
    Best Answer

    Hello all!

    I have an update to share with you all! A hot-fix has been deployed today which should help you to get past this issue in-game. If, after launching your game and reloading your latest save files, You're are still unable to move the shelves to finish the mystery, then please can you follow these steps:

    • Try to move the shelves
    • Create a manual save
    • Shutdown the game and relaunch it (Desynchronizing, reloading a save, or returning to title screen is not enough)
    • Load the manual save created above

    Eivor should be able to interact with the shelves and then complete the mystery! 😄

    Please note that we are hoping to implement a permanent fix in a later update. At this moment in time, we cannot provide a definite ETA, so please keep an eye out for further news and updates within the forums. In the meantime, we hope that this hot-fix helps you to get past the mystery.

    If the hot-fix does not work for you, please can you update this thread and provide the following information:

    • The platform you use (PC/PS/Xbox)
    • A video that shows you following the above steps, and the issue still persisting

    Thank you!

    Official Response
  • B00MSIE
    329 posts


    It fixed it for me, but I got stuck between the shelves, because I saved while standing in the wrong location (In between the shelves 😊 ) When I loaded the game, all shelves were reset to their default location, with me in between. I just bashed everything away and after that the guy says I saved him, but at a cost and the event ended.

    Many thanks!

  • Ubi-Borealis
    Ubisoft Support Staff 2877 posts

    @B00MSIE - I'm glad to hear you've been able to get through the quest successfully (albeit it at a rather unpleasant cost). Thanks for the update! 😄

    Official Response
  • jonathanpr
    1 posts
    This post is deleted!
  • Gizmo2k
    13 posts

    @ubi-borealis Wow. What a stress

    Did all your steps, WAS ABLE TO FINISH this mystery!!

    No achievement popped! Reperformed the steps again, I have MANY saves to fall back on, didn't pop again. After the third attempt, I travelled to Norway and Finland on the off chance I'd missed something (I hadn't). As soon as I landed in Vinland, it popped!!!!!!!!!!!!!!

    tl:dr; Fast travel to each country, just in case the game needs to 'see' you've completed those areas too?
  • Ubi-Borealis
    Ubisoft Support Staff 2877 posts

    @Gizmo2k - Thanks for sharing your experience with us! I'm glad to hear you've been able to finish this mystery, and been able to successfully unlock the achievement too! Thanks for sharing what helped you to trigger the achievement as well 😊

    Official Response
  • tiaoalvino
    1 posts

    @ubi-borealis problem solved here! thanks

  • Ubi-Borealis
    Ubisoft Support Staff 2877 posts

    @tiaoalvino - That's great to hear! You're welcome 😊

    Official Response
  • guest-8bb2zYQc
    1 posts

    There is a mystery in Lunden called 'Demon Odour at the Tithe'. I ran into this mystery about 2 months ago and before talking to the NPC, I just broke all of the pots and moved the crates to create a path because I thought that's what I needed to do to get to him and talk to him. Come to find out there wasn't anybody in there to talk to. So I looked online and found this is a very common issue. So I have tried the following to complete the mystery: 1. Exit the animus and re-enter to populate the NPC a. This does populate the NPC, but after clearing a path, the NPC does not walk out and just sits in the opening talking to himsel 2. Fast travel to Norway and back, fast travel to another region and back a. This resets the cargo you have to move around; however, they now sit on top of pots and some are unable to move. So, I crushed all the pots and can move all of them to create a path; however the NPC still doesn't come out. Come to find out, the small cargo in the back isn't on the skinny track running along the back side of the building. Instead it sits in the open area adjacent to the skinny track. So, although there is a clear path for the NPC to exit the building, the fact the cargo isn't in the correct place seems to cause the NPC to not exit. 3. Throwing bodies at the cargo to move them across tracks a. This solves the issue for the large cargo located to the left when you walk into the building. Usually this cargo is half on the track and half on the timber that outlines the track. Throwing a body at the cargo moves it into the track allowing you to move it along the track. However, this does not work with the small cargo in the back of the building described in 2a. above. Since the small cargo is completely in another area, throwing a body at it doesn't allow you to push the cargo over onto the track. It simply gets stuck on the timber outlining the skinny track that runs along the back of the building. As many have said in other forums and Reddit (r/assassinscreed), this is the last thing that is keeping me from a Platinum of this game. I have 110+ logged on this game, and even more after going into Rest Mode from AC Valhalla corrupted my PS5 (that's another issue for another day). This bug needs to be fixed for the sake of all those waiting to finish it to be able to Platinum the game. Is there another solution I am not aware of that will allow me to complete this mystery? Below you will find screenshots showing how there is a clear path from the entrance to the NPC, and how the small cargo is in a complete different area than the track, rendering it unable to be pushed onto the track by throwing bodies. In the picture I think you can actually see 4-5 bodies I tried throwing at it.

  • Ubi-Borealis
    Ubisoft Support Staff 2877 posts

    Hello there @guest-8bb2zYQc! Welcome to the forums 🙂

    I apologised for the delayed response. I'm sorry to hear that you've had trouble completing the "Demon Odour at the Tithe" mystery. This issue was marked as resolved in TU 1.1.2. Are you still unable to move the shelves following this update?

    If so, would you be able to send us a video that shows this in-game, so we can pass it along to the development team for a closer look.

    If you're unable to find the NPC as part of this mystery, I would recommend checking out the investigation taking place within this megathread.

    Thanks! 😊

    Official Response

Suggested Topics

Community Details