Welcome to discussions

Quick Suggestions

  • Mataresian
    11 posts

    After a few quests I came back to the place and the guy you had to save stands outside. You can talk to him and it completes the quest.

  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts
    Best Answer

    Hello all!

    I have an update to share with you all! A hot-fix has been deployed today which should help you to get past this issue in-game. If, after launching your game and reloading your latest save files, You're are still unable to move the shelves to finish the mystery, then please can you follow these steps:

    • Try to move the shelves
    • Create a manual save
    • Shutdown the game and relaunch it (Desynchronizing, reloading a save, or returning to title screen is not enough)
    • Load the manual save created above

    Eivor should be able to interact with the shelves and then complete the mystery! 😄

    Please note that we are hoping to implement a permanent fix in a later update. At this moment in time, we cannot provide a definite ETA, so please keep an eye out for further news and updates within the forums. In the meantime, we hope that this hot-fix helps you to get past the mystery.

    If the hot-fix does not work for you, please can you update this thread and provide the following information:

    • The platform you use (PC/PS/Xbox)
    • A video that shows you following the above steps, and the issue still persisting

    Thank you!

    Official Response
  • Damfrallan
    15 posts

    @sharp2spartacus I know it makes no sense What’s so ever.. i will not buy a season pass Until this is fixed, let me know if you found a solution Yeah? Ubisoft you better fix this NOW!

  • Flobberoni
    7 posts

    He's still inside the Warehouse on my end. The problem being: He's not in there if you haven't played through the Lunden Story.

    He spawns afterwards, but the Shelfs remain at the position you left them beforehand, while the Vases do respawn, no matter where the shelfs are.

    So the Shelfs become unmoveable/Stuck, while the Man/NPC still remains inside brabbling stuff ... Would be nice to know if Ubisoft has this Bug on their Radar.

    Enjoying the Game but I'm a completionist. I tend to first complete all Landmarks on a Zone/Map and then finish off the Story.. But some mysterys aren't available until you do the Story.

    Same with


  • Flobberoni
    7 posts

    I would also suggest to Ubisoft that you perhaps make a Fast-Travel full reset on Mysterys - if Coding/Programming allows for that.

    Also perhaps include Notes for Mysterys which are only do-able AFTER each Zone's Main Quest. It's very confusing to people when they reach a Mystery Marker and nothing is there.

    In fact that had me SO confused back in


    So yeah. Couldn't edit my other post so I apologize for the double - posting.

    Hopefully we'll get a Official Response in here. It would ease my Mind ^^

  • Dooxast
    12 posts

    @mataresian doesn't work for me, he simply vanish from warehouse time to time, still impossible to complite

  • csahendriks
    19 posts

    This world event is crazy buggy (like a lot of other world events). It doesn't need the Lunden story to be cleared -- I did it before I even touched the first quest in Lunden -- it's just bugged as heck. When I first got to the event, the guy wasn't even there, but seeing the jars and movable objects made me think the quest might involve getting into the blocked-off area, which I then did, but nothing happened. I saved and loaded (a go-to workaround when things start glitching out), and the guy spawned inside the warehouse and started yelling for help, as he should, except now the jars were spawning under the movable blocks, making them hover above ground and hence un-movable. So I just reloaded an earlier autosave and save-loaded until the warehouse guy spawned properly, then finished the event as intended.

    While Ubi fixes all these bugged/glitched events, they need to give players a way to force-reset these events in case things go south. Fast-travel and save-load doesn't always work.

  • Damfrallan
    15 posts

    Ubisoft please let me/us know as soon there is a solution, i want 100% and im sure as [censored] Not gonna start all over, Not cool! 🤦🏼♂😕

  • FrostyWaby
    1 posts

    When I first attempted to move the jars and the crates there was no one spawned in the back so I figured that it was mission/timeline locked and I moved on. After I was down with Lunden I came back and the guy was spawned but the second crate block had spawned on top of the jars. I removed the jars and destroyed the jars under the crates, but the crates are now bugged and will not move from the area.


  • Flobberoni
    7 posts

    @csahendriks Oh really? I thought, figuring how it was in


    that perhaps the Event is bound to another Map "Phase", so to say, being bound to the Story so to say.

    Well yeah. Ubisoft must include a force Reset for those events, or even better, the Force Reset & a Message popping up in case a Mystery/World Event is bound to the completion of the Zone's Story.

    That'd be more logic imo.

    So yeah, I guess we just have to collect more people that experience the same issue and perhaps get a proper response from Ubisoft while they add it to the "To Fix" list.^^

    I just really want The Map Completion of lunden on 100% to get that proper "Work's Done" feeling regarding that lil' zone xD

  • SF_Valour
    2 posts

    There is a world event in lunden which is near shore you need to make way through changing the places of the long boxes. You can pull or push the objects but one of the boxes spawned top of vases becasue of it I can't replace it. I broke the vases and tried to replace the box but it can't be replace. I fast traveled then comeback here to reset it but the situation continues. Here are some screenshots of it;
    https://prnt.sc/vk97mr I can't change the place of it stuck.

  • Rothbart96
    4 posts

    I have unblocked the road but the NPC is standing still and I cannot complete the quest. I don't know whether to repeat the Lunden thread or wait for a patch to fix it if it fixes it.

  • Damfrallan
    15 posts

    @rothbart96 you are not alone friend! How do you reset lunden, if that’s even possible?

  • Rothbart96
    4 posts

    I have save, before I started the Lunden thread but I have an annotation map with opal location. Map show that opal i still there but i take this last time, bugs bugs evrywhere.

  • Damfrallan
    15 posts

    @rothbart96 I see, Yeah i should have saved as well but lets be honest, you don’t expect a bug like this.. its pretty normal to do side quest/exploring before doing main quest.. I Hope there will be a patch really soon. I want that 100% trophy, still a long way to go but still

  • Meneh
    15 posts

    Have opened the way fully as can be seen on the screenshot below but the man won't walk out. Comparing mine with some videos on youtube it looks like my boxes are slightly in the wrong position for some reason.

  • KillerMarceI
    5 posts

    Have the same Problem, i think its because that one of the walls clipped over on the wrong side of the ground barrier, because of the respawned Pots.

  • KillerMarceI
    5 posts

    I had the same issue and solved it by pushing the box in the corner near the other double box then putting 3 bodys around the box sides except the side where it should fall and then fast traveled until the box sit on one of the jars. I destroyed the jars and the crate on the side where the box belongs. At last i destoyed the Jar below the box and the box glitched were ist should be, wich made completed mysterie. I needed to fast travel a few time to make it work, but i hope u can do it the same way.

  • katrassidy
    1 posts

    I have a totally different problem, the guy has always been there and while the moveable objects are respawning in the jars, I can destroy them and theyre in the right spot already. My issue has always been that the object at the front of the warehouse will not move to the side. There was never anything blocking it to begin with. I've tried setting the place in fire, going in a rampage, restarting, fast travelling, etc. I've completed 3 other areas and keep checking back and it hasn't changed. Driving me nuts! One of the paper chases here is also bugged - I can't jump on the statue with the paper in order to collect it (the one in the ruins). This area is wrecking me!

    1 posts

    @threeinonejdd thanks, this actually worked for me as well.

  • Socratic13
    1 posts

    Hi there,

    The one mystery in Lunden when you have to help the guy out of the warehouse is bugged. Either the guy isn’t there, or the objects are stuck to the floor and you can’t slide them (sometimes they spawn on top of the blue pots and even breaking the pots doesn’t do the trick). Can’t seem to get this one completed due to the issue.

Suggested Topics

Community Details