ubisoft discussions

Quick Suggestions

  • Locked Solved [RESOLVED] Unable to move the shelves to free the NPC in "The Demon Odour at the Tithe" | POST HERE

    30 Likes/532 Replies/10206 Views
    4 posts

    I think you dont undesrtand our problem. We unblock way to out but npc still stay and dont out and dont say anything.

  • Flobberoni
    9 posts

    So, any more people experiencing this ?

  • vsgNotice
    2 posts

    @dooxast Have the same issue and no way to work around it.

  • TajikczE
    2 posts

    Yeah, I dont know if someone already posted it here, but my situation is that ive already cleaned the whole path, but the first box was once stuck with jars, i broke them. Then it dropped, but then i couldnt move with it at all, i tried the corpse thing, but it stood still. If you could please fix it, I would be very glad. I think someone posted a video on YouTube. Heres the link:


  • Ubi-Baron
    Ubisoft Support Staff 798 posts

    Hey guys,

    Just to confirm is this "The Demon Odour at the Tithe" Mystery/Quest?

    If so this is something we are aware of and this is currently being looked into.

    Official Response
  • Meneh
    15 posts


    Indeed, this is my impression as well. It also seems like this one can't be fixed with the standard "wait until it resets" like others, even if it does reset, the moveable wall things does not spawn in their original state, and in my game they are spawned even on top of new jars..

  • Manifesto1985
    1 posts

    Same problem.undefined

  • Mr_Mammary
    2 posts

    I'm having this exact problem, although I'm on Xbox Series X. Have you managed a workaround yet?

  • Mr_Mammary
    2 posts

    @whiskerfish I found a partial solution - try throwing a corpse at the sliding objects that aren't moving. Eventually they will slot back into their alleys and you will be able to move them again. The downside, at least in my case, is that the quest giver now won't move or talk to me. He isn't even highlighted as if he is interactive.

  • Rothbart96
    4 posts

    Found the solution to the standing NPC. The small box is on the wrong guide, it is standing on the jugs. Take the dead body, throw it and slide the small box onto the old guide (just like the quest was originally). Then they should be pushed back. The dialogue option will unlock and the NPC will leave. If you dont understand write comment i will help you.

  • Damfrallan
    15 posts

    @rothbart96 what do you mean, small box? It seem like everyone have diffrent type of problems.. crazy and so annoying 😞

  • SpArKeS24
    1 posts

    The pots have glitched underneath a movable barrier so you can’t move it even if the path is clear, also when you eventually do move the barriers and make an Escape path for the stuck Norseman he just doesn’t move please help

  • Luminox94
    4 posts

    @ubi-baron Thanks! Im going crazy not being able to 100% lunden aha

  • TomSon23456
    1 posts

    @dooxast I have literally the same problem. It is impossible to complete this mystery.

  • BLiNNeMaNS
    2 posts

    i've noticed several times the order of respawning objects bugs out puzzles/makes it impossible to enter doors.
    what i mean is the moving objects (sliding doors) seem to be in the same spawngroup as breakables.
    it happened several times they spawn on top of boxes and if you then break the box it's back in place, the "move" handles/interaction still works, as in "you can hold it in place" but the door itself is immovable.

    to reproduce the bug here's an example:

    this also happens on several other areas, but i think this would be the easiest to reproduce for you devs.
    i think splitting the object group/reordering spawn sequence could fix it

    edit: - i'll add a screengrab later, atm i am not able to go ingame

  • Ubi-Baron
    Ubisoft Support Staff 798 posts

    @SpArKeS24 Thank you for reporting this to us, we're sorry to hear you've encountered that.

    We are aware of this issue occurring, and it's been passed on to the AC team to be looked into.

    One thing some users did to get around this is getting a body and throwing it into the movable barrier, this clipping seemed to fix it and allow it to be moved.

    Official Response
  • k3viniz3d
    1 posts

    Hi all,

    I just wanted to add that I also experience problems with this quest. The guy wont move. I broke all the jars, threw bodies at it, but the thin movable part seems to be in the wrong area. Is there any way to reset this?

    If I read this tread, I need to agree with @Damfrallan. It seems like different parts are bugging out for everyone.

    1 posts

    Can confirm @rothbart96 is correct with his logic. (Nice one dude) as for me....after 30mins of getting [censored] off!! I then realised the small box (single movable stone box) near the NPC was on the wrong guide. As the double box was in its area thus not triggering the NPC.

    so... I left the area ran back so the small box was now raised up and jars, jeet’d a body or 6 at it until it was back on the originally track and boom triggered the NPC, quest completed. (Obv’s make sure all other movable box’s are in the correct place).

  • guest-mhyEljSG
    1 posts

    So, having encountered the Sons is Ragnar bug that won’t let me speak to Ubba and refusing to delete my 58H of progress (I did Grantebridgescire first, and a load of farming/mysteries), I’ve gone to Lunden to start the arc there and found a(nother) bug.

    (Spoiler if you care about the mysteries): There’s a bug for one of the mysteries near the Lunden dock where a merchant is stuck in a warehouse behind a load of moveable objects. He wants you to move them to set him free. Problem is I’ve moved them all and the option to speak to him to complete the quest isn’t there. I’ve moved all the crates/lifted all the jars out of the way (so that I can move freely between him and the outside world by walking), reloaded my save, tried destroying all the jars to trigger a response from him (because he tells you not to), I’ve meditated, fast travelled a few times to the nearby docks and then ran back, but nothing. The moveable objects also often respawn back on top of the jars he tells you not to destroy, making them impossible to move unless you do destroy them, which I’m sure will irk people looking to complete the quest without upsetting the npc. One of the crates also doesn’t move at all, but I’m not sure if this was intentional because I couldn’t move it from the get go. Not sure why it would be, though.

    According to some comments, other people on YouTube have apparently found the same issues, and other issues with this quest that aren’t included here because I didn’t see them myself, but may be of use if you’re looking to avoid getting stuck on this like I am.

    Really hoping these bugs get fixed soon. I can’t progress with the story, and now I have a perpetually incomplete mystery on the map.

  • liveatlast91
    4 posts

    ok so i got everything fixed but the first box. its stuck bodies do nothing. and it spawns IN front of the jars. right by the door. its moved just enough i can get over it, but I cant have him walk past it, which I'm assuming is the issue.

Suggested Topics