Welcome to discussions

Quick Suggestions

  • Locked SOLVED [RESOLVED] Unable to move the shelves to free the NPC in "The Demon Odour at the Tithe" | POST HERE

    30 Likes/532 Replies/8894 Views
    2 posts

    hey thanks
    I can back to the challenge later but it was even more glitched out lol
    I had to take a civilian and throw them around to make sure the sliding obstacles were on tracks
    pain in the [censored] but it worked lol

  • kalikowski
    1 posts

    This same bug is happenning to me. They didn't do s* so far. Fix this!

  • TQWorld
    7 posts

    Having the "no NPC spawn" bug as well. I've tried a number of things and no spawn. I guess I'll have to wait until I complete the main questline? Pretty lame that this bug has been going on for so long without a fix.

  • Molemanski
    7 posts

    My NPC is there but the shelves are bugged to the bone. I've made a post with a picture of the situation.


    Under here the picture of my situation also to be found in the post:


    Things I tried:

    • Body throwing
    • Re-entering Animus
    • Setting the whole place on fire out of both desperation and last hope

    Loading an older save is no option for me. I only see "NPC not moving/spawning" as known issues by ubi. Not this mess of moveable shelves so I'm posting here as well to increase awareness. Hoping for a fix (or workaround) soon!

  • FrankieWho
    1 posts

    I have a mystery in Lunden to free a guy it is called the demon odor or something.
    This guy will not follow me because the shelves cannot move. I tried several things and solved 1 thing, but then noticed that one of the shelves spawned on the wrong side so I can never get it back to the right side! After a while another shelve spawned on the wrong side too! I am screwed! This is the only mystery I have to finish before getting 100 percent! Please help me!

  • LimitedHansen
    2 posts
    This post is deleted!
  • LimitedHansen
    2 posts

    So i just did what y'all told above. I meditaded on the spot. No one appears... Quick saved. Closed application and reopens. This random dude just wanders around the corner on the Outside of the building! He be like thanks for saving me, *hic*. Mystery completed. 😂

  • TQWorld
    7 posts

    So, the first time I was there, not knowing what to expect, I cleared everything out...broke all the jars and moved all the blocks. I left and came back a few times (sometimes different play sessions) and no NPC. So today, I went again to see if I could trigger the quest and I didn't hear him calling for help...the guy was sitting on the ground outside, with a text icon above his head. I spoke with him, he thanked me and that finished the quest.

  • Molemanski
    7 posts
    This post is deleted!
  • vKomplex
    3 posts

    Hello Fellow Eivors,

    I have been struggling with this mystery on and off for the past month until last night, when I finally reached a breakthrough and was able to complete the mystery. Just wanted to share my experience, what I've learned, and some tips that can hopefully help you complete it.

    If you attempt this mystery before completing the main story arc in Lunden, I'm pretty certain this mystery will be bugged.

    If the NPC does not spawn for you, simply walk outside the building, save, and load, and he should be there calling for help. Speak to him to trigger the mystery if he spawns, or keep re-loading until he does spawn.

    If you have already moved all of the crates and the NPC is non-responsive and speaking gibberish in a different language, you probably left the area to progress in other aspects of the game. Then when you returned, the crates spawned in non-ideal locations, unmovable, and possibly on top of the vases.

    There are precise locations that the crates need to be moved into in order for the NPC to realize that he has been saved and you can complete the mystery.

    If you've attempted this mystery enough times, you know where the crates are supposed to go, and I'm sure someone has posted screenshots of the correct positions/orientations, so here are some tips to help you get the crates where they need to be:

    • If you know a crate is on the wrong side of the rails/tracks and spawned on the ground, re-load until the crate(s) spawn on top of some vases
    • If you know a crate is on the right side of the rails/tracks and just needs to be slid into position, shoot any vases that are underneath the crate with your bow & arrow and simply Move it into place
    • Crates that spawn on top of vases can be moved little by little using the Move command
      • Move the crate as close as you can to the correct location and throw dead civilian bodies at the crates to give final pushes as needed, and shoot any leftover vases to destroy them
        • It can take up to 20-30 'Moves' in order to move the crate as much as you need to
    • If crates spawn on top of the rails, throw dead bodies at them until they drop back into their correct slide path and can be moved

    I was able to use these techniques in order to force the crates into their proper locations and FINALLY complete this mystery that I have spent way too much time on over the past month. I have seen other methods regarding meditating, exiting/re-entering the animus posted online and have tried both to no success. The tips/tricks above worked for me, and I hope they work for you too.



  • UbiKobold
    Ubisoft Support Staff 725 posts

    Hey there! I hope you all are having a good day. I am very sorry that some of you are still unable to move these crates or talk to the NPC. I do greatly appreciate the workarounds that have been provided, and have forwarded these to the Development team as they continue their investigation. For those new to this Megathread, please check out the detailed workarounds listed throughout the thread. If they do not resolve the issue, please know that the Game team is working hard to resolve this for a future update. Thank you!

    Official Response
  • ReV_H3XIC
    1 posts

    @sky_sailor92 I am having same problem have finished the entire game and this quest is still bugged for me!

  • Kuromi85
    2 posts

    I had to come here to comment on this as one of the funniest and most irritating workarounds to one of the many bugs I’ve encountered in this game.

    Firstly I’d never have worked out the body trick without this forum. Secondly more civilians died than were needed due to one woman screaming constantly at the sight of a murder and generally adding to the already mounting frustration whilst trying to move jars and shelves.
    Let’s just say an arrow to the face silenced her.

    I must admit that probably in part due to prolonged frustration and part due to the amusing nature of the workaround, I laughed until I cried at the visual of repeatedly throwing a dead body at the create to move it.

    “Thank the Gods!”

  • LadyRahl1
    1 posts

    I've been trying to days to finish The Demon Odour at the Tythe and I can't do it. I pulled out the first rock wall that you have to move to get the monk out, but no matter what I do I can't pull it to the right to open the pathway to walk through the opening. In order for me to get back there I have to climb over it and drop down which isn't that big of a deal for me to move the rest of the walls but for him, well he's stuck there until the path is clear. I've gone back to this for several days and even though the rest of the walls and jars reset this one won't. The jars reset behind the wall, but the wall stays in the pulled out position and wont' reset like everything else. I'm not going to be able to 100% the game unless this is fixed and after over 100+ hours I really don't want to restart my entire game. I tried taking a screenshot and attaching it but it won't let me. This is really upsetting that I've spent hours clearing areas only to find I can't do this ONE mission because of a bug. I've physically moved the jars multiple times, broken the jars, everything I can think of and I just can't do it.

    And to top it off I just went back in there and now the other rock walls have spawned on top of the jars and this is just a hot mess and I'm really frustrated.

  • Prangstar
    3 posts

    The Demon Odour at the Tithe lunden mystery does not work for me.

    This is the series of events that led to it:

    1. I entered the warehouse before the final boss mission in Lunden arc and broke the jars and moved the shelves. At the end there was nothing and moved on.

    2. After defeating the boss of the Lunden arc the mystery appeared on the map. So i went to the warehouse.

    3. The jars respawned but the shelves were wher i left them. The character that you need to get out was there and i spoke to him. I removed all the jars but one of the shelves spawned on top of the jars and outside the moving area which led to me being unable to move them to the right position to trigger the guy from leaving.

    3. Because he did not leave i decided to spawn to a viewpoint and then go back to try a different approach. But now the mission character is gone.

    4. Tried different times to spawn back and repeat. Tried moving the shelves back to its original location but nothing works.

    5. Apart from that 1 instance the guy hasn't spawned back in.

    Please fix this issue.

  • SmallestZeus4
    1 posts

    I had a similar issue, a shelf was stuck but the dead body helped with that. Now I've made a clear path and the dude isn't doing anything. Had to break a few to get a shelf off but it was otherwise out if the way already and out of spite I broke their whole stock, idk what to do. I'll come back every time I play to see if it gets helped but its bugged for now ig

  • patrickcarta
    1 posts

    Still can't finish the lunden mystery with the stinking barrels. Om ps5
    Please fix this i want to platinum the game

  • Brooksy_R
    1 posts

    I'm also stuck on this event, the cabinet by the entrance will not move no matter what I try, it's just firmly stuck in place, really frustrating as it the only world event I've been unable to complete

  • GerryWachovsky
    2 posts


    I was wondering if there is a plan to fix the “Demon Odour at The Tithe” world event in Lunden in the next patch? I was hoping it would be fixed in this patch but no dice. The 1x1 box is on the complete wrong side of the track it needs to be on and as a result, cannot be completed.

    Also, a couple other issues...

    1. The exclamation point denoting new quests will not go away in my game, no matter what. Really more of an annoyance than a major issue.
    2. I have a few treasure horde maps that I have used to find the corresponding treasure, yet these, unlike most of the treasure horde maps, are not disappearing after obtaining the treasure. Another annoyance really.

    Thank you.

  • Edhelvar
    3 posts

    Has anyone had this situation? The two shelves near to the guy are stacked one inside of the other... I've tried throwing corpses, meditating, saving and loading next to them, can't seem to be able to separate them... Now with update 1.1.1 they fixed the daughters of lerion bug and so now this is the only thing keeping me from the platinum.


Suggested Topics