Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • ReV_H3XIC
    1 posts

    @sky_sailor92 I am having same problem have finished the entire game and this quest is still bugged for me!

  • Kuromi85
    2 posts

    I had to come here to comment on this as one of the funniest and most irritating workarounds to one of the many bugs I’ve encountered in this game.

    Firstly I’d never have worked out the body trick without this forum. Secondly more civilians died than were needed due to one woman screaming constantly at the sight of a murder and generally adding to the already mounting frustration whilst trying to move jars and shelves.
    Let’s just say an arrow to the face silenced her.

    I must admit that probably in part due to prolonged frustration and part due to the amusing nature of the workaround, I laughed until I cried at the visual of repeatedly throwing a dead body at the create to move it.

    “Thank the Gods!”

  • LadyRahl1
    1 posts

    I've been trying to days to finish The Demon Odour at the Tythe and I can't do it. I pulled out the first rock wall that you have to move to get the monk out, but no matter what I do I can't pull it to the right to open the pathway to walk through the opening. In order for me to get back there I have to climb over it and drop down which isn't that big of a deal for me to move the rest of the walls but for him, well he's stuck there until the path is clear. I've gone back to this for several days and even though the rest of the walls and jars reset this one won't. The jars reset behind the wall, but the wall stays in the pulled out position and wont' reset like everything else. I'm not going to be able to 100% the game unless this is fixed and after over 100+ hours I really don't want to restart my entire game. I tried taking a screenshot and attaching it but it won't let me. This is really upsetting that I've spent hours clearing areas only to find I can't do this ONE mission because of a bug. I've physically moved the jars multiple times, broken the jars, everything I can think of and I just can't do it.

    And to top it off I just went back in there and now the other rock walls have spawned on top of the jars and this is just a hot mess and I'm really frustrated.

  • Prangstar
    3 posts

    The Demon Odour at the Tithe lunden mystery does not work for me.

    This is the series of events that led to it:

    1. I entered the warehouse before the final boss mission in Lunden arc and broke the jars and moved the shelves. At the end there was nothing and moved on.

    2. After defeating the boss of the Lunden arc the mystery appeared on the map. So i went to the warehouse.

    3. The jars respawned but the shelves were wher i left them. The character that you need to get out was there and i spoke to him. I removed all the jars but one of the shelves spawned on top of the jars and outside the moving area which led to me being unable to move them to the right position to trigger the guy from leaving.

    3. Because he did not leave i decided to spawn to a viewpoint and then go back to try a different approach. But now the mission character is gone.

    4. Tried different times to spawn back and repeat. Tried moving the shelves back to its original location but nothing works.

    5. Apart from that 1 instance the guy hasn't spawned back in.

    Please fix this issue.

  • SmallestZeus4
    1 posts

    I had a similar issue, a shelf was stuck but the dead body helped with that. Now I've made a clear path and the dude isn't doing anything. Had to break a few to get a shelf off but it was otherwise out if the way already and out of spite I broke their whole stock, idk what to do. I'll come back every time I play to see if it gets helped but its bugged for now ig

  • patrickcarta
    1 posts

    Still can't finish the lunden mystery with the stinking barrels. Om ps5
    Please fix this i want to platinum the game

  • Brooksy_R
    1 posts

    I'm also stuck on this event, the cabinet by the entrance will not move no matter what I try, it's just firmly stuck in place, really frustrating as it the only world event I've been unable to complete

  • GerryWachovsky
    2 posts

    Hi,

    I was wondering if there is a plan to fix the “Demon Odour at The Tithe” world event in Lunden in the next patch? I was hoping it would be fixed in this patch but no dice. The 1x1 box is on the complete wrong side of the track it needs to be on and as a result, cannot be completed.

    Also, a couple other issues...

    1. The exclamation point denoting new quests will not go away in my game, no matter what. Really more of an annoyance than a major issue.
    2. I have a few treasure horde maps that I have used to find the corresponding treasure, yet these, unlike most of the treasure horde maps, are not disappearing after obtaining the treasure. Another annoyance really.


    Thank you.

  • Edhelvar
    3 posts

    Has anyone had this situation? The two shelves near to the guy are stacked one inside of the other... I've tried throwing corpses, meditating, saving and loading next to them, can't seem to be able to separate them... Now with update 1.1.1 they fixed the daughters of lerion bug and so now this is the only thing keeping me from the platinum.

    undefined

  • jadefairall
    2 posts

    I had the same problem and tried the body throwing trick. That helped get 3 shelves unstuck however the large shelf closest to the NPC is stuck inside the barrel wall. I’ve tried throwing bodies at it but it’s inside the wall. This is the last thing I need to 100%. Does anyone have a workaround and please Ubisoft fix this!

  • Prangstar
    3 posts

    I fixed it by throwing bodies at the shelves to put them back in their original position. Then to get the npc to spawn i exited the animus and then entered again the guy was there.

  • carnun
    1 posts

    This is still an issue for me as well (PS5).

    I can break all the jars. I can throw a body at the shelves to move them. And the NPC is there, he just will not move at all.

    I've shifted the shelves every which way. Set fire to the "oil". Put the shelves back, closed game, re-opened game, and repeated it all again to no avail.

    Regardless of what I do, the NPC just sits there and does the creepy whispering.

  • wripdscorpio3
    2 posts

    In Lunden, there's a secondary mission world event tha requieres me to move some blue jars and some obstacles in order to free a man. My problem is that i need to Move obstacles but the obstacles do not move they're stuck, so i cant finish the event and lunden is still not complete. I can't do anything and its the only event left for me to Solve in all the game. Please help

    spoiler

    Spoiler Text

    spoiler

  • Biggity08
    1 posts

    I've had this problem from the start. I went to the mission prior to completing the Lunden mission arc. There was no man spawned to rescue but I thought it was a puzzle. So I moved all the jars and moveable blocks and opened a path and nothing. I googled it and found that a man was suppose to spawn there stuck. Left, completed the Lunden mission arc and then he was magically there. However, now the moveable blockades spawn on TOP of the jars of goo. If I break the jars the moveable blockage lands out of the ground barriers and cannot be moved. So I cannot move the blockades and cannot complete the quest. It is the one thing left on the map (other than fish disappearing, which is another well known bug) that I have to do.

  • AtlasRM
    1 posts

    One of the mysteries in Lunden involves clearing a path of slideable crates and pickable jars (that smell bad) to allow a trapped civilian to leave the building. This quest is bugged for me and a lot of other players. There is a small workaround that involves throwing a dead body to allow the crates to move but that still doesn't fix the problem for me. The NPC is just standing there muttering nonsense with no interactions and no recognition of the clear path out. I was hoping that it would be addressed in patch 1.1.1 since the bug has been around since the start of the game. It is one of the last things that I need to do to 100% the game and I don't want to have to start over and lose my 138 hours of progress.

    I am playing on a PS4 Pro.

  • kreutzgang
    635 posts

    @atlasrm every single world event in Lunden was bugged for me, as in didn't trigger at all. In that specific one, the guy isn't even there.

  • guest-jjgxZy6x
    1 posts

    This is still an issue, and so much of an issue that I stopped playing the game. I'm completely unmotivated now, so please fix this bug in the next patch. So many others are having this frustrating and unnecessary bug.

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts

    Hello everyone,

    I'm pleased to say that I come bearing news about this issue with moving the shelving in the "Demon Odour at the Tithe" World Event! 🙂

    The developers have advised that a fix for the issues with moving the jars/shelving has now been found, and will be deployed in an upcoming patch. There isn't a confirmed date for the specific patch yet, nor full details of its contents, but I'll keep you all informed as more details become available.

    Thank you to everyone who took the time to submit information, images, videos and/or save files to us for us to investigate; all of this was integral to finding a fix, and is much appreciated. 🙂 Please let me know if you have any questions, or any concerns.

    Official Response
  • Abaddon.89
    1 posts

    Hi, I have problem with ministry bug/gklitch in Lunden (Temple of Sulis Minerva part).. It's warehouse ministry, where need to move 3 srone walls, and free man who is inside.. The problem is that I can move only first wall, and second one is stuck on jars, what is needed to move away, but I tried to break the jar, and still can't move the stone wall.. I can record a short video if you need to see what is issue.. Thanks in advance for help.. Kind regards..

  • PG-Iceman
    16 posts

    This is one of the most anyoing bugs in the game at the moment. I have tried everything and now found a workarround to the issue. Here is a little map that shows the final position of the boxes.

    It is essential that they remain in their original rails and end up in their true final positions.

    The area marked with a red X is a room where boxes can end up, if they do you are screwed and have to use quick saves and reloads to try to move them back into their original rails. You can do so via luck and throwing bodies at the boxes when they hover on vases. It may be challenging if they are on a wrong rail.

    In general use the quicksave and load function to get the boxes set anew.

    • Use bodies, arrows to move the boxes in their right rail.
    • Make sure the rails are not stuck by objects (vases or small crates)
    • Push the boxes into the positions mentioned in the image


    If the guy has not spawned for you do one of this:

    • Quicksave and reload
    • Leave animus and come back


    Tell me if this worked for you!

    undefined

Suggested Topics

Community Details

27
Online
129.7k
Users
22.4k
Topics
116.3k
Posts