ubisoft discussions

Quick Suggestions

  • vladis1980
    4 posts

    @steewydub and your answer helps us....how???

    One month after release you still can't fix a game breaking bug??? Yet you expect us to pay for your games?

    Funny fact is that this bug is a result of your poor management, since the QC team is the one from Bucharest. Funnier is that I know one or two guys that worked on this project. And I also know their wages, your employment conditions, your working conditions.

    Fix this quest through a hotfix ffs! We can't finish the game! Can you comprehend this??? The game that you released as a working product! I am expecting this guy to wake up faster than you!


  • dwaelim
    5 posts

    Same thing happened for me, my game is broken unless I load a save from about 15 hours back. I was really hoping to have this game finished by the time Cyberpunk released but looks like they've know about this bug for a while now and haven't done anything for it.

  • UbiExcellent
    756 posts

    Hello all! I appreciate everyone posting about this issue here and have notified our teams as such. Currently, this issue is still being looked into. If those of you on the PC or PS4 are able to submit your save files to us via a support ticket, please do that, then share your case numbers with me here. I'll be glad to get those added to our on-going report about this issue to aid the investigation.

  • shanemcdermott
    8 posts

    @steewydub 1. No i did not see any error messages, in my experience, all i know is that my saves were all corrupted around that time.

    2. No I do not believe that I experienced a crash or freeze during Of Blood and Bonds, but it is very possible. I do not remember as this has been a problem for so long and hasnt been fixed.

    3.No I am not utilizing the cross-platform progression feature.

  • SteewyDub
    29 posts

    @vladis1980 Dude, i am not with Ubisoft. I just bought a game, ran to a bug and browsed a forum. lol
    That is how i found that the issue was reported earlier under different thread, and someone from support wanted to know those answers.

    Please read carefully before launching all out on someone. 🍺

  • SteewyDub
    29 posts

    @shanemcdermott Hi, the issue was reported under different thread. I just wanted You guys to be aware as well that they are asking these questions.

  • SteewyDub
    29 posts

    So I found a manual save that was made 20 hours prior to this bug with settlement on level 4, replayed entire Eurvicsire quest. Earlier save was created when I started Jorvik quest.

    I did everything as before, and the quest was successful. I was able to speak with Randvi and finish "Of Blood and Bonds" quest.
    The settlement was almost immediately upgraded to level 5, with the blue line as it was when on level 4. (I am not sure if there is a limit or false positive placed in code for settlement, as it is showing that game thinks You finished it when all Order members are killed)

    After this quest, You get another one for Eurvicsire.

    I know that this is not a workaround, I did this for testing purpose only. Hopefully this helps someone else with less hours in and a working save, at least to finish the main story .

  • SakKing33BPT
    1 posts

    Finished all the regions in England, and Eurvicscire is completed, but when I went back to the Alliance Map it wasn’t completed
    Anybody else dealing with this and know of a solution?

  • AzazelUnchain3d
    2 posts

    Same exact scenario for me. After completing Of Blood and Bone (i think i saved and might have logged off), this quest never started. I'm stuck with 105 hours into this save, and the closest save I've got is at 65 hours.....not going back and replaying 65 hours worth of game, and cant progress further. Ubisoft orginally told me to reset my graphics settings (lol), and then told me it was reported and they were looking at it.

  • kayani.amin2012
    1 posts

    Hi, all first of i must say how dissapoited iam in this game i litreally paid £90 for this game and its full of bugs. Game keeps closing down every hour or 2 with an error message and you have to reatart the game. Second issue is i have completed everything but theres bug with the alliance map where i cant report to randvi and progress to next mission. If you guys are charging people £60 70 90 that game shouldnt come with so many bugs and crashes. Thats rediculous. Im being honest till ubisoft doesnt step up their game. I will no longer purchase anymore games created by you guys.

  • Jocsan_18
    4 posts

    i have the same issue. PC btw.

  • Jocsan_18
    4 posts

    @guest-2wt9bncq i have the same issue in pc.

  • Skipants17
    2 posts

    Having the same issue, made a ticket with a save game


    Not entirely sure if it worked -- it said the file type of the file was unsupported but still let me submit.

    To answer the other questions:

    1) No error messages or codes
    2) No crashes or freezes
    3) No cross-platform enabled. Playing on PC via Epic

  • BurkeThe3
    4 posts

    So it's already December 8th and I just hit the same bug! They seriously need to fix it soon!

  • Petteflet88
    346 posts
  • ThePantryMaster
    8 posts

    @donvir Honors Hubris bug (gamebreaking) was reported nearly a month ago and still no fix. I've done everything else in the game that you can do up til this point, 84% completion, can't continue. I really want to finish this game and it's taking ages for this to be sorted.

  • Cicciogunmad20
    2 posts

    hi everyone ,
    I already compleated all alliance's quest , but when I come back to randvi , on the map Eurvicscire isn't conquered even though I've already completed the quest.
    help me

  • KashimaKusanagi
    23 posts

    I recently completed the alliance quest of blood and bonds. After killing Farravid and receiving the bracelet from Halfdan I never received a prompt to return to Randvi and update the region as complete. The quest shows up in my completed quest logs but I can't get the game to actually progress forward as if I completed my objective. Rolling back to previous saves does not work nor did abandoning the region and committing to another alliance.

  • Suden_83
    1 posts

    We are a lot in this case obviously. I found a video on youtube from someone who is waiting since November 17th. I think there are waiting for a correction made by magic

  • KashimaKusanagi
    23 posts

    I just encountered this bug yesterday and I have more than 100 hours. I did some raids and collected a bunch of armor pieces before making my way back to Randvi. I really don't want to lose all the progress I made after killing Farravid.

Suggested Topics