Welcome to discussions

Quick Suggestions

  • SpicyDuckSoup
    12 posts

    @lokyeung30 Yep I haven't even tried playing since I posted. Been playing Warzone and Cyberpunk 2077 waiting for Ubi to fix this stupid issue

  • Ubi-Borealis
    Ubisoft Support Staff 2837 posts
    Best Answer

    Hello all!

    I apologise for the delayed update. Following TU 1.1.2, this issue wherein players were unable to "Report on Eurvicscire" has been marked as resolved by the development team. I will now be marking this topic as "Resolved," though we will keep the thread open in case there are new reports of this happening post-TU 1.1.2.

    If you are still unable to proceed with the Eurvicscire arc as "Reporting on Eurvicscire" does not pop up following the completion of "Of Blood and Bonds," please don't hesitate to update this thread. If possible, please can you also include a video that shows you have completed "Of Blood and Bonds," but that "Reporting on Eurvicscire" has not been added to your quest log.

    @ScetticoScet - Hey there! It sounds like you're encountering a different issue to the one being discussed in this topic. If you haven't already, could you please open a new thread about this? Please include a video that demonstrates Eivor being unable to use any weapons, or fight at all, whilst in the Great Hall or in the other locations you have provided. We can then pass this along to the development team for a closer look.

    @PoetSean - Thank you for taking the time to share you feedback with us. Please note that we're unable to offer a live service via the forums, and it can take our player support team some time to respond within a thread when contact volumes are high. I'm sorry if any disappointment has been caused by this.

    As this thread is about "Reporting on Eurvicscire" not appearing in the quest log following the completion of "Of Blood and Bonds," we ask players who are encountering different issue within the region to open new threads, or to find any similar ones within the megathread list. That way, we can keep the investigations separate and avoid any miscommunication or loss of information. It also prevents threads from going off-topic, which is part of the forum rules.

    @vamacisaac - I'm sorry to hear you've had trouble with "Of Blood and Bonds." If you're still having trouble completing this quest, would you be able to open up a new thread so we can keep these investigations separate. If you can include a video that shows you're unable to complete the fight, please also include this within your thread.

    Thanks all! 😊

    Official Response
  • tytjetullat
    2 posts

    Have the same issue playing on google Stadia.

  • jaimejk91
    1 posts

    @evilqueencin
    [censored]! something happens to me recently.

    I had the same bug, and I came back to york, where de mission take place. I started killing civilans and suddenly [censored] FARAVID APPEAR OUT OF NOWHERE (he was in the hall behind the throne) and he starts atacking me. He fighted like a demon (i am level 400 and he beat my [censored] 4 times) When I finally finish him, he suddenly appears like a hurted ally, so I revived him, and he atacks me again.

    [censored]???

  • sipi.18
    1 posts

    I have the same issue.

  • MsMmm00
    2 posts

    There is a bug in Eurvicsire preventing me from completing the quest “of blood and bonds” where the task written is “witness Halfdan’s coronation, the ceremony will start when Halfdan is present”, specifically in the spot near the Royal Hall where i am supposed to meet both Faravid and Halfdan. 
    When i reach the bottom of the wall to climb i overhear them talking, and by the time i reach up, Faravid would be walking away, and Halfdan is on the floor as what looks like a dead body, his dog standing beside him, and the Quest blue logo highlighted on him, i can’t get him to get up or do anything at all it seems stuck and not moving.

    I go into the hall, faravid is there and i initiate a conversation with him. 
    I reloaded game, restarted console, i went and completed some other regions and came back, it is still stuck on this Halfdan’s “dead body” on the floor in the location outside of the Royal Hall.

  • Fredhead1968
    3 posts

    @armour_g Exactly same here on PS4. They say they know about it but so frustrating. 155 hours in and Power 400. Running out of things to do.

  • shkim1978
    1 posts

    I have the same issue on ps5, will not let me complete Eurvicscire and progress in the game. It's very frustrating as I have completed almost everything else.

  • cosminbenny
    3 posts

    I have the same issue. Eurvicscire is shown not complete on the alliance map and I can't continue the game!

  • guest-70anp9yZ
    6 posts

    So i just finished Grantebridgescire, Ledecestrescire and Lunden, all on 100%. Im 104lvl and now i can only pick Jorvik (190lvl). Why cant i pick East Anglia or Oxenefordscire? Is my save bugged guys?

  • I_BiG_AiDaN_I
    6 posts

    Same thing but with the East Anglia region. Reported it a couple weeks ago but heard nothing back. Carried on playing the game but some of the other regions aren't available for me to pledge to so now I'm stuck..

  • RHAKNAM78
    3 posts

    Man, i have the same bug now on Ps5. Cant believe the first thread i find is 3weeks old and still no fix.
    And I'm not going back 20hours.
    First time i liked an AC in a long time and now 100hours in, this comes up.

  • guest-Kfhcr80F
    3 posts

    The game doesn't let me progress to report on eurvicscire. It still shows Faravid alive at the great hall in Jorvik, and if you fight him, he just drops like a downed ally. It doesn't mention anything on this glitch in the patch notes for 1.0.4, and there's no way in hell I'm restarting after 130+ hours into the game

  • Niels_DD
    3 posts

    I have the same problem with this quest but then on PC.

  • Niels_DD
    3 posts

    When I completed the "Of blood and bonds" quest by defeating faravid it doesn't allow me to go and report back to randvi.
    He still shows as alive in the back of the longhouse in Jorvik and if you fight him again and defeat him it just shows him as an fallen ally.
    It give you the option to revive him.
    I'm not going back to another save game seeing as I have completed multiple other quests since then and don't want to start again.

  • guest-Kfhcr80F
    3 posts

    @niels_dd Yeah, after reading other threads, it seems that this is a problem across all platforms. And not a new one at that

  • Squirrow1203
    2 posts

    I’m experiencing the same issue since yesterday after completing the mission killing Faravid.

    I'm playing on PS4 and have always been a AC fan since it was established in 2012 and I never had much problem before except now. I never had to complain about issue but this time is a constant thing. Currently, I’m at level 260. If this doesn’t fix soon, you will lose a lot fan.


  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hey there! This is an issue our teams are aware of guest-Kfhcr80F, but I'm afraid it has been difficult for our teams to reproduce. If either of you are able to include a video of this error, or upload your save files to a support ticket then share your case numbers here, that would be extremely helpful to have on hand while our teams continue to look into this issue.

    Official Response
  • ihatemilkduds
    8 posts

    Ok, it's been almost a month now. This issue is obviously a problem for a lot of us, and I'm still not seeing it on the Megathread as a known issue. I understand what a nightmare bugs can be, and how fixing one can just create others. But I think we all feel supremely ignored.

    I thought, for sure, there'd be a fix by now. Even just resetting the mission would be awesome. It wasn't hard and I wouldn't mind redoing it. At the time of discovering this bug, I was already 120-some hours in. My closest save before the Eurvicscire arc was 60 hours previously. So I opted to wait it out and busy myself with all the extras. Guess that was a mistake because now I'm almost 180 hours invested, 400 level, cleared the map - even the hundreds of little treasure chests, completed all other arcs except for Hamtuncscire which won't even highlight, wiped out the order -even the zealots - except for The Father, and OMG-kill-me on all those cairns and anomalies....and I can't even continue the actual story.

    I'm livid.

  • KashimaKusanagi
    23 posts

    @ihatemilkduds Yeah, it really makes me angry that with an update supposedly slated later on this week, this issue still hasn't made its way to a megathread. It kind of makes me feel like either it is low on the priority list or not there at all. I'm extra salty because I really did not like Valhalla; at first, I had to force myself to play before the game really clicked, and I legitimately enjoyed the experience, and then right as I approached winter break, I can't even play the game anymore because of a game-breaking bug.

  • MadBerserker52
    2 posts

    @niels_dd Im having the same issue my friend and Idk what to do about it

Suggested Topics

Community Details

57
Online
139.8k
Users
24.6k
Topics
127.5k
Posts