ubisoft discussions


  • locked topic_solved [RESOLVED] Completion of "Of Blood and Bonds" does not register; "Reporting on Eurvicscire" not received | POST HERE

    1 likes/552 replies/24994 views
    ubisoft:x-posts, 15

    Sorry to hear about y'all having the same problem. I haven't play the game since I made this post cause I don't see the point of continuing, 22 days later I'm still waiting for them to solve it, hope Ubisoft can fix it soon.

  • Andybirds98
    ubisoft:x-posts, 3

    I completed the Jorvik mission and I chose to side with halfdan ragnarsson and killed faravid, it didn’t come up with speak to randvi when completed so I played on thinking I needed to do some side missions but still nothing. I then went back to Jorvik to see if it glitched and faravid (who should be dead) is there and notices me like an enemy, I can fight him but he won’t die, I’ve tried everything but nothing works, I can progress with the game

  • Armour_G
    ubisoft:x-posts, 5

    Same here I completed the "of blood and bonds" quest, killed Faravid, attended the ceremony and returned to Randvi, where she gave me the same quest.
    Map now shows one completed and one pledged quest for eurvicscire on the map side by side...Map is completed but cant move on.
    I returned to the Royal Hall in Jorvik and Faravid is still there even though he was previously killed but if i fight him again i can "kill" him over and over again, but at the point of death he shows the "Revive" icon above him and he restores to full health. I can "kill" him over and over but always he revives.
    This appears to be what is holding up my progress in the game.  Xbox One

  • Skipants17
    ubisoft:x-posts, 2

    Here's my guess -- I found a save before my soft lock and was able to complete the Blood and Bonds and talk to Randvi. When I completed the quest I noticed there's a delay between the quest completion and the new quest to talk to Randvi. I'm guessing that in my soft lock save, it's after Blood and Bonds completion but before the quest to Randvi updates. I have a save there to try out a different dialog option.When I reloaded that save, then Blood and Bonds was complete but it did not start the quest to talk to Randvi.

    This could also explain others are getting soft locks with other story quests and not just Blood and Bonds.

  • Moxxy99
    ubisoft:x-posts, 1

    I’m playing on ps4 and the quest „of bloods and bonds“ with halfdan and faravid doesn’t complete even though I finished everything. I decided to fight faravid and he is somehow alive again and if I attack him he is fighting me like in the boss fight but he just doesn’t die. Instead I can revive him and have to fight him again and again. I also can’t report to randvi. I can’t continue the story like this!!! I tried to save the game game and load again but nothing helps. Unfortunately I don’t have an old save game they’re all in this quest. This is a real game breaker...

  • SpicyDuckSoup
    ubisoft:x-posts, 12

    @lokyeung30 Yep I haven't even tried playing since I posted. Been playing Warzone and Cyberpunk 2077 waiting for Ubi to fix this stupid issue

  • tytjetullat
    ubisoft:x-posts, 2

    Have the same issue playing on google Stadia.

  • jaimejk91
    ubisoft:x-posts, 1

    [censored]! something happens to me recently.

    I had the same bug, and I came back to york, where de mission take place. I started killing civilans and suddenly [censored] FARAVID APPEAR OUT OF NOWHERE (he was in the hall behind the throne) and he starts atacking me. He fighted like a demon (i am level 400 and he beat my [censored] 4 times) When I finally finish him, he suddenly appears like a hurted ally, so I revived him, and he atacks me again.


  • sipi.18
    ubisoft:x-posts, 1

    I have the same issue.

  • MsMmm00
    ubisoft:x-posts, 2

    There is a bug in Eurvicsire preventing me from completing the quest “of blood and bonds” where the task written is “witness Halfdan’s coronation, the ceremony will start when Halfdan is present”, specifically in the spot near the Royal Hall where i am supposed to meet both Faravid and Halfdan. 
    When i reach the bottom of the wall to climb i overhear them talking, and by the time i reach up, Faravid would be walking away, and Halfdan is on the floor as what looks like a dead body, his dog standing beside him, and the Quest blue logo highlighted on him, i can’t get him to get up or do anything at all it seems stuck and not moving.

    I go into the hall, faravid is there and i initiate a conversation with him. 
    I reloaded game, restarted console, i went and completed some other regions and came back, it is still stuck on this Halfdan’s “dead body” on the floor in the location outside of the Royal Hall.

  • Fredhead1968
    ubisoft:x-posts, 3

    @armour_g Exactly same here on PS4. They say they know about it but so frustrating. 155 hours in and Power 400. Running out of things to do.

  • shkim1978
    ubisoft:x-posts, 1

    I have the same issue on ps5, will not let me complete Eurvicscire and progress in the game. It's very frustrating as I have completed almost everything else.

  • heimdaloz
    ubisoft:x-posts, 6

    After I was killed on the second arm of the Eurviscire story line, the story markers disappears. I went back to Randvi and she gave me another story line, I can't seem to get back to Eurviscire, to complete it. No alliance is shown but not quests are shown either. I can't complete the game.

  • cosminbenny
    ubisoft:x-posts, 3

    I have the same issue. Eurvicscire is shown not complete on the alliance map and I can't continue the game!

  • guest-70anp9yZ
    ubisoft:x-posts, 6

    So i just finished Grantebridgescire, Ledecestrescire and Lunden, all on 100%. Im 104lvl and now i can only pick Jorvik (190lvl). Why cant i pick East Anglia or Oxenefordscire? Is my save bugged guys?

  • I_BiG_AiDaN_I
    ubisoft:x-posts, 6

    Same thing but with the East Anglia region. Reported it a couple weeks ago but heard nothing back. Carried on playing the game but some of the other regions aren't available for me to pledge to so now I'm stuck..

    ubisoft:x-posts, 3

    Man, i have the same bug now on Ps5. Cant believe the first thread i find is 3weeks old and still no fix.
    And I'm not going back 20hours.
    First time i liked an AC in a long time and now 100hours in, this comes up.

  • guest-Kfhcr80F
    ubisoft:x-posts, 3

    The game doesn't let me progress to report on eurvicscire. It still shows Faravid alive at the great hall in Jorvik, and if you fight him, he just drops like a downed ally. It doesn't mention anything on this glitch in the patch notes for 1.0.4, and there's no way in hell I'm restarting after 130+ hours into the game

  • Niels_DD
    ubisoft:x-posts, 3

    I have the same problem with this quest but then on PC.

  • Niels_DD
    ubisoft:x-posts, 3

    When I completed the "Of blood and bonds" quest by defeating faravid it doesn't allow me to go and report back to randvi.
    He still shows as alive in the back of the longhouse in Jorvik and if you fight him again and defeat him it just shows him as an fallen ally.
    It give you the option to revive him.
    I'm not going back to another save game seeing as I have completed multiple other quests since then and don't want to start again.

Suggested Topics