Welcome to discussions

Quick Suggestions

  • guest-70anp9yZ
    6 posts

    So i just finished Grantebridgescire, Ledecestrescire and Lunden, all on 100%. Im 104lvl and now i can only pick Jorvik (190lvl). Why cant i pick East Anglia or Oxenefordscire? Is my save bugged guys?

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts
    Best Answer

    Hello there!

    As we have had no further reports of this issue persisting in-game following the release of TU 1.1.2, we will now be locking this thread.

    If you encounter any further trouble when trying to report on Eurvicscire, please don't hesitate to open up a new thread so we can take a closer look. When opening a new thread, please include as much information about the issue you're encountering as possible. Any images or videos that demonstrate the issue in-game are also helpful for further investigation.

    Thanks! 😊

    Official Response
  • I_BiG_AiDaN_I
    6 posts

    Same thing but with the East Anglia region. Reported it a couple weeks ago but heard nothing back. Carried on playing the game but some of the other regions aren't available for me to pledge to so now I'm stuck..

  • RHAKNAM78
    3 posts

    Man, i have the same bug now on Ps5. Cant believe the first thread i find is 3weeks old and still no fix.
    And I'm not going back 20hours.
    First time i liked an AC in a long time and now 100hours in, this comes up.

  • guest-Kfhcr80F
    3 posts

    The game doesn't let me progress to report on eurvicscire. It still shows Faravid alive at the great hall in Jorvik, and if you fight him, he just drops like a downed ally. It doesn't mention anything on this glitch in the patch notes for 1.0.4, and there's no way in hell I'm restarting after 130+ hours into the game

  • Niels_DD
    3 posts

    I have the same problem with this quest but then on PC.

  • Niels_DD
    3 posts

    When I completed the "Of blood and bonds" quest by defeating faravid it doesn't allow me to go and report back to randvi.
    He still shows as alive in the back of the longhouse in Jorvik and if you fight him again and defeat him it just shows him as an fallen ally.
    It give you the option to revive him.
    I'm not going back to another save game seeing as I have completed multiple other quests since then and don't want to start again.

  • guest-Kfhcr80F
    3 posts

    @niels_dd Yeah, after reading other threads, it seems that this is a problem across all platforms. And not a new one at that

  • Squirrow1203
    2 posts

    I’m experiencing the same issue since yesterday after completing the mission killing Faravid.

    I'm playing on PS4 and have always been a AC fan since it was established in 2012 and I never had much problem before except now. I never had to complain about issue but this time is a constant thing. Currently, I’m at level 260. If this doesn’t fix soon, you will lose a lot fan.


  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hey there! This is an issue our teams are aware of guest-Kfhcr80F, but I'm afraid it has been difficult for our teams to reproduce. If either of you are able to include a video of this error, or upload your save files to a support ticket then share your case numbers here, that would be extremely helpful to have on hand while our teams continue to look into this issue.

    Official Response
  • ihatemilkduds
    8 posts

    Ok, it's been almost a month now. This issue is obviously a problem for a lot of us, and I'm still not seeing it on the Megathread as a known issue. I understand what a nightmare bugs can be, and how fixing one can just create others. But I think we all feel supremely ignored.

    I thought, for sure, there'd be a fix by now. Even just resetting the mission would be awesome. It wasn't hard and I wouldn't mind redoing it. At the time of discovering this bug, I was already 120-some hours in. My closest save before the Eurvicscire arc was 60 hours previously. So I opted to wait it out and busy myself with all the extras. Guess that was a mistake because now I'm almost 180 hours invested, 400 level, cleared the map - even the hundreds of little treasure chests, completed all other arcs except for Hamtuncscire which won't even highlight, wiped out the order -even the zealots - except for The Father, and OMG-kill-me on all those cairns and anomalies....and I can't even continue the actual story.

    I'm livid.

  • KashimaKusanagi
    23 posts

    @ihatemilkduds Yeah, it really makes me angry that with an update supposedly slated later on this week, this issue still hasn't made its way to a megathread. It kind of makes me feel like either it is low on the priority list or not there at all. I'm extra salty because I really did not like Valhalla; at first, I had to force myself to play before the game really clicked, and I legitimately enjoyed the experience, and then right as I approached winter break, I can't even play the game anymore because of a game-breaking bug.

  • MadBerserker52
    2 posts

    @niels_dd Im having the same issue my friend and Idk what to do about it

  • nidge262009
    1 posts

    I've put 118 hours into this game I've done all the alliance map mission's but of blood and bond won't let me report back to randvi and now I can't continue with the game . its coming up as completed on the completed quest section but its still on the alliance map but nothing happens when I select it

  • cosminbenny
    3 posts

    Same probleme here on PC! This is not normal, I paid 60 euros for this game!!!

  • LimpingMouse
    1 posts

    Just to raise it I'm also having this issue and I can't progress in the story, and I don't see a fix for it in the Patch notes for 1.1.0 Title update.

  • spiritwolf1
    2 posts

    @fredhead1968 same here... might have to switch to cyberpunk until they fix the issues

  • Smedo13
    2 posts

    Don't see a fix for this in the 1.1.0 release notes 😞

  • Pack35pp
    2 posts

    Grantebridgescire is the issue I’m having can’t even talk to the Druid hopefully they fix it soon

  • Erklebrand
    4 posts

    I'm having the same issue on Xbox Series X. Surely I dont have to roll back to an earlier save? I'm 64 hours in and I completed the Eurvicscire missions but didn't get the return to Randvi, I probably did that about 10 or 15 hours back. I've completed all regions available to me, my settlement is stuck at 5 and I've completed all upgrades assuming I cannot get to level 6 until you fix this.

    The solution cannot be rolling back and having to repeat, get it sorted Ubisoft or point me to where I can get a full refund. I'm totally disheartened by seeing how old this thread is.

    Yours,

    A very unhappy customer.

  • Pack35pp
    2 posts

    Grantebridgescire can not talk to the Druid to finish

Suggested Topics

Community Details

165
Online
193.7k
Users
32.7k
Topics
163.7k
Posts