Welcome to discussions

Quick Suggestions

  • Locked SOLVED [RESOLVED] Completion of "Of Blood and Bonds" does not register; "Reporting on Eurvicscire" not received | POST HERE

    1 Likes/552 Replies/23605 Views
    3 posts

    @niels_dd Yeah, after reading other threads, it seems that this is a problem across all platforms. And not a new one at that

  • Squirrow1203
    2 posts

    I’m experiencing the same issue since yesterday after completing the mission killing Faravid.

    I'm playing on PS4 and have always been a AC fan since it was established in 2012 and I never had much problem before except now. I never had to complain about issue but this time is a constant thing. Currently, I’m at level 260. If this doesn’t fix soon, you will lose a lot fan.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hey there! This is an issue our teams are aware of guest-Kfhcr80F, but I'm afraid it has been difficult for our teams to reproduce. If either of you are able to include a video of this error, or upload your save files to a support ticket then share your case numbers here, that would be extremely helpful to have on hand while our teams continue to look into this issue.

    Official Response
  • ihatemilkduds
    8 posts

    Ok, it's been almost a month now. This issue is obviously a problem for a lot of us, and I'm still not seeing it on the Megathread as a known issue. I understand what a nightmare bugs can be, and how fixing one can just create others. But I think we all feel supremely ignored.

    I thought, for sure, there'd be a fix by now. Even just resetting the mission would be awesome. It wasn't hard and I wouldn't mind redoing it. At the time of discovering this bug, I was already 120-some hours in. My closest save before the Eurvicscire arc was 60 hours previously. So I opted to wait it out and busy myself with all the extras. Guess that was a mistake because now I'm almost 180 hours invested, 400 level, cleared the map - even the hundreds of little treasure chests, completed all other arcs except for Hamtuncscire which won't even highlight, wiped out the order -even the zealots - except for The Father, and OMG-kill-me on all those cairns and anomalies....and I can't even continue the actual story.

    I'm livid.

  • KashimaKusanagi
    23 posts

    @ihatemilkduds Yeah, it really makes me angry that with an update supposedly slated later on this week, this issue still hasn't made its way to a megathread. It kind of makes me feel like either it is low on the priority list or not there at all. I'm extra salty because I really did not like Valhalla; at first, I had to force myself to play before the game really clicked, and I legitimately enjoyed the experience, and then right as I approached winter break, I can't even play the game anymore because of a game-breaking bug.

  • MadBerserker52
    2 posts

    @niels_dd Im having the same issue my friend and Idk what to do about it

  • nidge262009
    1 posts

    I've put 118 hours into this game I've done all the alliance map mission's but of blood and bond won't let me report back to randvi and now I can't continue with the game . its coming up as completed on the completed quest section but its still on the alliance map but nothing happens when I select it

  • cosminbenny
    3 posts

    Same probleme here on PC! This is not normal, I paid 60 euros for this game!!!

  • LimpingMouse
    1 posts

    Just to raise it I'm also having this issue and I can't progress in the story, and I don't see a fix for it in the Patch notes for 1.1.0 Title update.

  • spiritwolf1
    2 posts

    @fredhead1968 same here... might have to switch to cyberpunk until they fix the issues

  • Smedo13
    2 posts

    Don't see a fix for this in the 1.1.0 release notes 😞

  • Pack35pp
    2 posts

    Grantebridgescire is the issue I’m having can’t even talk to the Druid hopefully they fix it soon

  • Erklebrand
    4 posts

    I'm having the same issue on Xbox Series X. Surely I dont have to roll back to an earlier save? I'm 64 hours in and I completed the Eurvicscire missions but didn't get the return to Randvi, I probably did that about 10 or 15 hours back. I've completed all regions available to me, my settlement is stuck at 5 and I've completed all upgrades assuming I cannot get to level 6 until you fix this.

    The solution cannot be rolling back and having to repeat, get it sorted Ubisoft or point me to where I can get a full refund. I'm totally disheartened by seeing how old this thread is.


    A very unhappy customer.

  • Pack35pp
    2 posts

    Grantebridgescire can not talk to the Druid to finish

  • BLACKSoutALLday
    14 posts

    So you are releasing a patch and a freaking DLC this week. You got to be absolutely [censored] kidding me with this. Nothing in the notes even mentions fixing this, yet you want us to play a DLC when the base game is beyond broken. Someone respond to my post for the love of god with an update. You just sitting here silently is a slap in the face to every single player having this issue

  • BLACKSoutALLday
    14 posts

    @ihatemilkduds I don't see anything about this in the new patch notes being fixed. Haven't played in 10 days cause of this horse [censored], and I'm not losing 30 hours cause of a [censored] glitch. Worse is that these Dev's seem to be clueless and don't even respond on the official ubisoft website

  • Squirrow1203
    2 posts

    Since we all are getting fed up with no responses and left in the cold on this thread and no updates announced at all. Let’s email Julien Laferriere directly guys/gals. She’s the lead producer for AC Valhalla and many other AC games. Her direct email is julien.laferriere@ubisoft.com or ashraf.ismail@ubisoft.com (creative director)

    Im sure if we all email her, she will get it and will have to make this a priority.

  • SpicyDuckSoup
    12 posts

    @spiritwolf1 That's exactly what I did mate. Still bugs in that game but at least I can get through the story mode.

  • Donvir
    8 posts

    Well, this is how you make sure legions of loyal customers dont buy your crappy game next time.

    Horrible company trying to cash in as much as possible with out fixing a bug thats literally stopping people from finishing the game.

  • lokyeung30
    15 posts

    Hey y'all, sorry to hear about the new patch hasn't fixed this giant bug. I was looking forward for them to fix it in this patch but apparently not. I'm at a stage that I'm furious and disappointed, but also don't really give a [censored] about the game anymore cause I haven't played the game since I made this post. Truely hopes they fix this in the next patch or I'm gonna lose my [censored].

    To the Ubisoft team, if you see this, would you please fix this already.

Suggested Topics