Welcome to discussions

Quick Suggestions

  • Rydha92
    1 posts

    The bug is still there. The latest update didnt fix it. What a letdown. Been waiting for the next update for weeks. I cant progress the storyline and I have completed all the other quests as well. 👎👎

  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts
    Best Answer

    Hello all!

    I apologise for the delayed update. Following TU 1.1.2, this issue wherein players were unable to "Report on Eurvicscire" has been marked as resolved by the development team. I will now be marking this topic as "Resolved," though we will keep the thread open in case there are new reports of this happening post-TU 1.1.2.

    If you are still unable to proceed with the Eurvicscire arc as "Reporting on Eurvicscire" does not pop up following the completion of "Of Blood and Bonds," please don't hesitate to update this thread. If possible, please can you also include a video that shows you have completed "Of Blood and Bonds," but that "Reporting on Eurvicscire" has not been added to your quest log.

    @ScetticoScet - Hey there! It sounds like you're encountering a different issue to the one being discussed in this topic. If you haven't already, could you please open a new thread about this? Please include a video that demonstrates Eivor being unable to use any weapons, or fight at all, whilst in the Great Hall or in the other locations you have provided. We can then pass this along to the development team for a closer look.

    @PoetSean - Thank you for taking the time to share you feedback with us. Please note that we're unable to offer a live service via the forums, and it can take our player support team some time to respond within a thread when contact volumes are high. I'm sorry if any disappointment has been caused by this.

    As this thread is about "Reporting on Eurvicscire" not appearing in the quest log following the completion of "Of Blood and Bonds," we ask players who are encountering different issue within the region to open new threads, or to find any similar ones within the megathread list. That way, we can keep the investigations separate and avoid any miscommunication or loss of information. It also prevents threads from going off-topic, which is part of the forum rules.

    @vamacisaac - I'm sorry to hear you've had trouble with "Of Blood and Bonds." If you're still having trouble completing this quest, would you be able to open up a new thread so we can keep these investigations separate. If you can include a video that shows you're unable to complete the fight, please also include this within your thread.

    Thanks all! 😊

    Official Response
  • kaasislekker
    6 posts

    @ubiexcellent Can confirm that this issue still is NOT fixed on Playstation 4 (and probably other platforms as well), even after the latest update of december 15th. Please Ubi, bring out a real fix soon.

  • RHAKNAM78
    3 posts

    How do we get a refund?

  • KashimaKusanagi
    23 posts

    Report and save file submitted case number 13595047.

  • Sir_Billy_Wizz
    2 posts

    Same issue.. I am at a loss for words.. will be demanding a refund soon.. no answer as to a fix.. and head in the sand it appears from an issue that a very high percentage of people are having.. time to spam the social media pages I think

  • gabz0793
    2 posts

    I am really disappointed that they didn’t fix the issue. I am almost done with everything else in England. I guess I’ll have to go back to Norway and finish the map there, I’ve been neglecting it.

  • shanemcdermott
    8 posts

    @rhaknam78 yeah, i have officially given up. I would like a refund now like cd projekt red is doing

  • icrushcommies
    1 posts

    This is unacceptable. Been a gamer since Atari, and have NEVER encountered a bug that just totally shuts the game down for me. I now have an incredibly expensive coaster. Ubi- stop making focusing on making Vikings woke gay non-binaries and get back to making games that work!!

  • RHAKNAM78
    3 posts

    @shanemcdermott
    Same. I paid 100€ for this sh..

  • SpicyDuckSoup
    12 posts

    @ubikobold How is there still not a mention of this on the Megathread? Another patch has come and gone and we're left in the dark not knowing if our issue is even being worked on. We physically cannot continue the game and it's getting ridiculous.

  • BLACKSoutALLday
    14 posts

    @spicyducksoup Not only will they not respond, you also have no way of getting a refund. Wish in one hand and $hit in the other. See which one fills up quicker. That's basically what they are saying are our choice at this point

  • Helias1994
    2 posts

    [censored] YOU FOR STILL NOT FIXING THIS UBISOFT IVE BEEN WAITING OVER A MONTH FOR YOU TO FIX THIS GAME BREAKING GLITCH. ME SND MANY OTHERS PAID FULL [censored] PRICE FOR A GAME WE CANT EVEN FINISH [censored] YOU. Seriously though i would take a [censored] refund at this point yall are so [censored]. Cant even reply to us or anything. OH HEY LOOK AT ALL THIS CHRISTMAS STUFF WERE GIVING YOU. TOO BAD SOME OF US CANT EVEN PLAY.

  • walt0023
    2 posts
    • Case #13596133

    if anyone from ubisoft cares. this is extremely frustrating

  • Ryanbollin
    4 posts

    At what point does this warrant us requesting a refund? Are they allowed to sell a game with this many issues? I cant complete the game and there is no fix to allow me to.

  • M4tthi4sss101
    1 posts

    This is insane... to pay so much for a game and not even get to finish it. Been waiting for over a month now for ubisoft to get it fixed, what are they even doing releasing dlc’s when the main game is broken for so many of us. Can we get a refund or some sort of compensation already or idk a respons of some sort?

  • scraby_
    1 posts

    I’m just replying to this post to get into the statistics of people having this issue. I was ok ignoring all other bugs but you kind of force my hand here whit this one.

  • cuteboy666
    1 posts

    Ok they could at least be straight with us and say they can't fix it or it's going to take a long [censored] time. At this point I just want to know so I can either load an earlier save or just stop playing.


  • Ryanrules7
    1 posts

    unbelievable that this many players are still experiencing this exact same issue, and still no word on if there’s even a possible fix. i was really enjoying the story up until i couldn’t progress past eurvicshire. it’s a damn shame i won’t be able to finish it... going back nearly 60 game hours to a previous save is a depressing, and demoralizing thought, so i don’t think i can bring myself to spend all that time replaying the game. frustrating.

  • AllianceStuck
    156 posts

    @blacksoutallday do a charge back with your credit card company

  • captaln_america
    2 posts

    I after finishing the quest and getting the bracelet I was told to talk to Ranvi, at the same time I was also told to talk to her about going to Wincestre. I was never given the chance to turn in the quest. My auto saves were 3 days ago and I have no more areas to pledge to or missions to do. "Of Blood and Bonds" comes up as a near by quest that I can track, but I cannot track it because it is appearing under my completed tab. Other than not being able to proceed at all with the store I do truly love this game. You guys really out did yourselves, thank you for all of the incredible work you do and hours of entertainment.

Suggested Topics

Community Details

101
Online
139.3k
Users
24.5k
Topics
126.8k
Posts