ubisoft discussions

Quick Suggestions

  • Ryanbollin
    4 posts

    At what point does this warrant us requesting a refund? Are they allowed to sell a game with this many issues? I cant complete the game and there is no fix to allow me to.

  • M4tthi4sss101
    1 posts

    This is insane... to pay so much for a game and not even get to finish it. Been waiting for over a month now for ubisoft to get it fixed, what are they even doing releasing dlc’s when the main game is broken for so many of us. Can we get a refund or some sort of compensation already or idk a respons of some sort?

  • scraby_
    1 posts

    I’m just replying to this post to get into the statistics of people having this issue. I was ok ignoring all other bugs but you kind of force my hand here whit this one.

  • cuteboy666
    1 posts

    Ok they could at least be straight with us and say they can't fix it or it's going to take a long [censored] time. At this point I just want to know so I can either load an earlier save or just stop playing.

  • Ryanrules7
    1 posts

    unbelievable that this many players are still experiencing this exact same issue, and still no word on if there’s even a possible fix. i was really enjoying the story up until i couldn’t progress past eurvicshire. it’s a damn shame i won’t be able to finish it... going back nearly 60 game hours to a previous save is a depressing, and demoralizing thought, so i don’t think i can bring myself to spend all that time replaying the game. frustrating.

  • AllianceStuck
    156 posts

    @blacksoutallday do a charge back with your credit card company

  • captaln_america
    2 posts

    I after finishing the quest and getting the bracelet I was told to talk to Ranvi, at the same time I was also told to talk to her about going to Wincestre. I was never given the chance to turn in the quest. My auto saves were 3 days ago and I have no more areas to pledge to or missions to do. "Of Blood and Bonds" comes up as a near by quest that I can track, but I cannot track it because it is appearing under my completed tab. Other than not being able to proceed at all with the store I do truly love this game. You guys really out did yourselves, thank you for all of the incredible work you do and hours of entertainment.

  • ProU95
    10 posts

    This is ridiculous!

    ive got the same glitch, I noticed straight away that I didn’t get the quest so I reloaded save and tried both options but still happened so I kept going farming stuff. Right now I’m 90hs deep, 390 power and going back to it is not an option.

    Thankfully for me this only happened 4 days ago so I’m not yet on I want to kill someone but the fact that they’ve uploaded a patch with the yule festival and it’s not fixed yet is pi$$ taking stuff.

    On top of that.. if you go east of the settlement you can where the event is gonna happen, if you go to the middle of it you can hear the voices of the festival going on. [censored]! Don’t even want a refund but next Ubisoft game that comes out I simply won’t buy... bunch of thief’s this guys

  • demagorgon81
    1 posts

    Wasted so many hours(143+) in game and still dont see any progress. Cant finish main plot coz you didnt fix it over one month after relase date. You didnt provide to us complete product so pls start thinking about refund ours money.

  • Erklebrand
    4 posts

    The contempt being shown for their customers by Ubisoft is really poor here. What is happening with this issue? When was the last official update on this thread? How many people are working on resolving this? It is not too much to expect a regular update given the severity of this bug. The silence is pretty damning here.

    In the absence of any update, I am left thinking either they cannot fix this bug or they've decided its not worth their effort and to hell with the players affected.

  • bsfmtl123
    4 posts

    @youregrill I am facing the same problem and I am almost 80 hours into the game. Have you found any way to resolve this issue?

  • Reddino_senpai
    2 posts

    please fix this problem

  • iHawkEye_
    1 posts

    @ubiexcellent The problem is not fixed for me after 1.1.0 update...

  • sirezraferguson
    3 posts

    On ac valhalla i’ve got all the alainces exept from eurviscire wich i completed bij keeping the friend of halfdan alive, but when i go back to ranvi to report on it i can only ask her to show the alaince map and i do not get the alaince there and the sword keeps beining on there so i cant complete eurviscire and i cant continue the storyline because of that.

    what can i do to fix this?

  • BLACKSoutALLday
    14 posts

    Hey all after berating Ubisoft on twitter since this issue started, and sharing this link the official Ubisoft support responded. Here's the super heartfelt update, with tons of info.


    I am sorry to hear that you are encountering issues with the Alliance Map. The team is aware of this issue and are investigating.

    Apologies for any inconvenience caused.

    Absolute horse [censored]

  • Perstudie
    1 posts
    Same situation here. Halfdan just lying there on the wall with the questmarker active. To go back to a previously saved game before this quest might help but havent tryed that yet though.

  • yellowkey1
    1 posts

    Still broken! I have officially given up on Ubisoft. I will never buy another one of their games.

  • ovidiubulgaru22
    1 posts

    Come on ubisoft, just fix it! I can’t play the game anymore

  • WillnLiam
    1 posts

    I'm experiencing the same thing. I guess I can't play the game at all at this point since that's all that's left. I guess go fishing? Fml.

  • Donvir
    8 posts


    At least with Cyberpunk and CDPR you actually know that they will fix it. This horrible company would rather ignore and move on.

Suggested Topics