Welcome to discussions

Quick Suggestions

  • bsfmtl123
    4 posts

    @youregrill I am facing the same problem and I am almost 80 hours into the game. Have you found any way to resolve this issue?

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello there!

    As we have had no further reports of this issue persisting in-game following the release of TU 1.1.2, we will now be locking this thread.

    If you encounter any further trouble when trying to report on Eurvicscire, please don't hesitate to open up a new thread so we can take a closer look. When opening a new thread, please include as much information about the issue you're encountering as possible. Any images or videos that demonstrate the issue in-game are also helpful for further investigation.

    Thanks! 😊

    Official Response
  • Reddino_senpai
    2 posts

    please fix this problem

  • iHawkEye_
    1 posts

    @ubiexcellent The problem is not fixed for me after 1.1.0 update...

  • sirezraferguson
    3 posts

    On ac valhalla i’ve got all the alainces exept from eurviscire wich i completed bij keeping the friend of halfdan alive, but when i go back to ranvi to report on it i can only ask her to show the alaince map and i do not get the alaince there and the sword keeps beining on there so i cant complete eurviscire and i cant continue the storyline because of that.

    what can i do to fix this?



  • BLACKSoutALLday
    14 posts

    Hey all after berating Ubisoft on twitter since this issue started, and sharing this link the official Ubisoft support responded. Here's the super heartfelt update, with tons of info.

    Hey,

    I am sorry to hear that you are encountering issues with the Alliance Map. The team is aware of this issue and are investigating.

    Apologies for any inconvenience caused.


    Absolute horse [censored]

  • Perstudie
    1 posts
    Same situation here. Halfdan just lying there on the wall with the questmarker active. To go back to a previously saved game before this quest might help but havent tryed that yet though.


  • yellowkey1
    1 posts

    Still broken! I have officially given up on Ubisoft. I will never buy another one of their games.

  • ovidiubulgaru22
    1 posts

    Come on ubisoft, just fix it! I can’t play the game anymore

  • WillnLiam
    1 posts

    I'm experiencing the same thing. I guess I can't play the game at all at this point since that's all that's left. I guess go fishing? Fml.

  • Donvir
    8 posts

    @shanemcdermott

    At least with Cyberpunk and CDPR you actually know that they will fix it. This horrible company would rather ignore and move on.

  • Henkwolters
    2 posts

    I've completed all the quests. killed whatever I can. collected everything availeble on the map..... but the game does not let me finish!
    Hamtunscire still remains closed, I can not pledge myself there.

    I just read that this is a bug? already going on since the release? And I've spend at least 6 hours A DAY playing this game since the release, to be stuck by this bug? and to see that since the release nothing has been realy done to fix this?
    And no I have ALL the save games. but no matter WHICH one I take from them all, none of them allow me to pledge to Hamtunscire.

    So please Ubisoft. What to do? this is a little bit "unprofessional" to release a game in the world as bugged like this? neah, a not-done.

  • EvilQueenCin
    6 posts

    Two updates in, still the same horrible [censored] game breaking bug....
    I haven't played the game since November 29th now because I can't progress at all past Euriviscire.
    The new update made the formerly completed quest active again but without adding it to the quest list and without any quest markers or tasks.
    I've tried everything.
    No fix.
    I also don't have a save that I can go back to to try again.
    Hate this. It's unbelievable that they're not working harder on this and fixing it.
    I love the stories of ubisoft games but won't buy any of them at release again since doing that is equal to throwing a load of cash into a trash can.

  • EvilQueenCin
    6 posts

    Still no fix almost a month later and two patches in. Well thanks for nothing...

  • Mass-974
    2 posts

    Same here ...

  • guest-qEnfXYmi
    1 posts

    Please please for the love of god fix it

  • AzazelUnchain3d
    2 posts

    Still Broke, still showing Eurviscire as not completed, still no quest "Reporting on Eurviscire", and nothing more I can do. I would love to complete this game one day.......... here's hoping.

  • IamGhost_00
    1 posts

    @azazelunchain3d Same problem. But I have found that Faravid is still alive in Jorvik. I tried to kill him, useless.

  • guest-P1SeQyeH
    1 posts

    My situation, two other accounts on PS4 - My account - everything works fine, on my son account - problem exists :(. I made this mission few hours after him. We had a little mindf*ck :/.

  • ZanTheRed
    3 posts

    @iamghost_00 me too

  • Chefdaddymark
    5 posts

    Still no fix even after updating the game. Any chance of a refund ubisoft?

Suggested Topics

Community Details

89
Online
192.9k
Users
32.5k
Topics
162.8k
Posts