Welcome to discussions

Quick Suggestions

  • Mass-974
    2 posts

    Same here ...

  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts
    Best Answer

    Hello all!

    I apologise for the delayed update. Following TU 1.1.2, this issue wherein players were unable to "Report on Eurvicscire" has been marked as resolved by the development team. I will now be marking this topic as "Resolved," though we will keep the thread open in case there are new reports of this happening post-TU 1.1.2.

    If you are still unable to proceed with the Eurvicscire arc as "Reporting on Eurvicscire" does not pop up following the completion of "Of Blood and Bonds," please don't hesitate to update this thread. If possible, please can you also include a video that shows you have completed "Of Blood and Bonds," but that "Reporting on Eurvicscire" has not been added to your quest log.

    @ScetticoScet - Hey there! It sounds like you're encountering a different issue to the one being discussed in this topic. If you haven't already, could you please open a new thread about this? Please include a video that demonstrates Eivor being unable to use any weapons, or fight at all, whilst in the Great Hall or in the other locations you have provided. We can then pass this along to the development team for a closer look.

    @PoetSean - Thank you for taking the time to share you feedback with us. Please note that we're unable to offer a live service via the forums, and it can take our player support team some time to respond within a thread when contact volumes are high. I'm sorry if any disappointment has been caused by this.

    As this thread is about "Reporting on Eurvicscire" not appearing in the quest log following the completion of "Of Blood and Bonds," we ask players who are encountering different issue within the region to open new threads, or to find any similar ones within the megathread list. That way, we can keep the investigations separate and avoid any miscommunication or loss of information. It also prevents threads from going off-topic, which is part of the forum rules.

    @vamacisaac - I'm sorry to hear you've had trouble with "Of Blood and Bonds." If you're still having trouble completing this quest, would you be able to open up a new thread so we can keep these investigations separate. If you can include a video that shows you're unable to complete the fight, please also include this within your thread.

    Thanks all! 😊

    Official Response
  • guest-qEnfXYmi
    1 posts

    Please please for the love of god fix it

  • AzazelUnchain3d
    2 posts

    Still Broke, still showing Eurviscire as not completed, still no quest "Reporting on Eurviscire", and nothing more I can do. I would love to complete this game one day.......... here's hoping.

  • IamGhost_00
    1 posts

    @azazelunchain3d Same problem. But I have found that Faravid is still alive in Jorvik. I tried to kill him, useless.

  • guest-P1SeQyeH
    1 posts

    My situation, two other accounts on PS4 - My account - everything works fine, on my son account - problem exists :(. I made this mission few hours after him. We had a little mindf*ck :/.

  • ZanTheRed
    3 posts

    @iamghost_00 me too

  • Chefdaddymark
    5 posts

    Still no fix even after updating the game. Any chance of a refund ubisoft?

  • Chefdaddymark
    5 posts

    Time for a refund ubisoft? If there's no upcoming information about this bug, is it time we start sending the game back, demanding a refund?

  • ZackSpahr
    2 posts

    Hello Ubisoft, after completing the entire eurvicshire quest line with halfdan, I did not get an option to talk to randvi, and I have since completed every other territory possible and it still wants me to pledge to eurvicshire. Once I do, I have no quest marker and no quest shows up in my log. I really don’t want to go back 30 hours of gameplay to fix this, so please help me out. BTW halfdan is just sitting in Jorvik as the jarl and I have no option to talk to him.

  • iBankstro
    7 posts

    @spicyducksoup the yule festival bugs made it to the megathread before any of this. It feels like the whole alliance map is bugged. If this doesn't happened to you im East Anglia itll just happen down the line.

    Btw can't complete East Anglia, same exact problem. The Randvi part doesn't pop up.
    No crashes, no freezing, no error codes

  • ZanTheRed
    3 posts


     Dear ZanTheRed,

     Thanks for contacting Ubisoft Support, I apologize for the delay in responding.

     Sorry you've encountered this unfortunate inconvenience in Assassin's Creed Valhalla, I inform you that we have already received reports of players unable to complete the Eurvicscire region due to not viewing the final mission. The development team has been made aware of this issue and is currently investigating it.

    Finally an answer

  • QuickGaming_
    8 posts

    [censored] this game, I had first a bug with the mission bleeding the leech. had to wait over a month for ubisoft to finally fix that bug so i could progress the main story. now, 3 days later i am once again stuck on a [censored] main mission making it impossible to advance. For real ubisoft, did u even test the game or did u just [censored] this game out and released it without checking for a single bug. this is the worst expreience i have ever gotten with a game and a company!
    I demand that ubisoft actually gives a proper answer asap, as a customer who has paid over 60 dollars for a game we have the right to know what is going on with all the bugs and ubisoft not fixing them

  • RichOilSheik
    7 posts

    I think the most upsetting thing here is that it’s not even acknowledged in the mega thread. This isn’t a small issue. It essentially makes the game worthless. I feel like I went to a 200 hour movie only for the projector to break at the 180 hour mark.

    Then to have extra content released is insult to injury. Oh, and by the way, that extra content is all broken as well.

    Pop a Ritalin and focus, Ubisoft. Let’s get the game fixed before releasing other broken content. This is the most disappointing game purchase I e made in 40 years.

  • LastAnxiety
    2 posts

    I'm having a problem I have completed the sayings of halfden arc but it won't let me speak to randvi and the alliance map still says its in progress not sure what to do please help as I cannot continue the game

  • LastAnxiety
    2 posts

    I'm having this issue now aswell I'm gutted as the next closest save is 37 hours ago I can't do that. I have played all of the assassins creed games and never had an issue like this please do something about this. PLEEEEEAAAAASSSSSSE FIX THIS

  • Raven7277
    2 posts

    This is literal trash. Why would I EVER give ubisoft another dollar? I'm not even as far in as some of the others. I spent 80 hours and can't complete this game. You've known for a month! FIX THIS. UNACCEPTABLE.

  • RayMcGirk100
    19 posts

    It looks like Patch 1.10 did not fix this. I'm glad they got out the seasonal content though. /s

  • danthesmith
    2 posts

    Replying solely so Ubi will see that I'm another one with the same issue. Not raging, just dissapointed.

  • Niels_DD
    3 posts

    I have the same issue with the of blood and bonds quest. It doesn't allow me to report back to Randvi.
    I've spent a 104 hrs on the game and I've completed all other territory pledges.
    But now I'm stuck pledged to Eurvicscire and nothing I do changes this.
    The new patch didn't solve this either, so please help!

  • Ubi-Orion
    Ubisoft Support Staff 161 posts

    Hey there folks.

    Many thanks for your reports on this issue so far and to those of you who submitted cases and save files as well.

    I can confirm that a fix is planned with a future update. Please keep an eye on the forums for info on this. Thanks!

    Official Response

Suggested Topics

Community Details

24
Online
138.8k
Users
24.3k
Topics
125.8k
Posts