ubisoft discussions

Quick Suggestions

  • JustNiels043
    2 posts

    @Ubi-Orion
    Is there any idea of when this bug will be fixed? Am still waiting..

  • JustNiels043
    2 posts

    @Ubi-Orion how will u keep us updated on this issue? Will we get an e-mail?

  • zheega
    24 posts

    Same problem here. Can't interact with the alliance map, can't progress in the game. Stuck.

  • RankPup8
    2 posts

    Well, I decided to give a shot to returning to an old save file before the Eurviscire quest, unfortunately it meant going all the way back to before I even did Jorvik. On the way I made sure to create a save right before every quest, just to be sure. I just finished the Euriviscire storyline and this time I actually got the Report quest. So... make a save before every mission would be my recommendation. I shouldn't have had to do that, though, but just in case anyone wants the advice here it is.

  • RayMcGirk100
    19 posts

    I've been waiting since almost release for this to be fixed. I reported it right away so they've known about it for a while. I guess they just put it on the looooong list of bugs to fix. I wouldn't be surprised if they don't fix it with the next patch.

  • BLACKSoutALLday
    14 posts

    baahahahahaahahahaahahaha I've been posting here for almost a month and they still haven't fixed [censored]. I haven't played the game since December 3rd because I literally can't progress the story. [censored] pathetic

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hello everyone. At this time, we do not have a specific date we can share regarding a fix. However, mirroring what my colleague Ubi-Orion said, as soon as a date has been provided, we will share it with everyone on the News and Announcements page, both on the forums and on the game's official website.

    Official Response
  • H2kjay
    2 posts

    @spicyducksoup im also having the same problem. All ubisoft has told me is that the development team has been working on a solution for this specific issue.

  • Raven7277
    2 posts

    @ubiexcellent tbh at this point I am not sure I have any interest in finishing the game or purchasing future ones. What a disappointment that you can't fix a game. There is no reason this should take this long. Don't release games when they aren't ready.

  • Agoldz
    6 posts

    @ubiexcellent this is ridiculous. At least prove to us it is getting worked on. I mean apparently it’s been a problem since the beginning and last patch did nothing. At this point you gotta give us reason to believe it’s getting fixed to keep people playing

  • Karloz1995
    268 posts

    @spicyducksoup thats why i havent played the game until new updates.... i take a rest from it, very dissapointed in ac valhalla

  • KashimaKusanagi
    23 posts

    The sad part is this issue still isn't listed anywhere. For all the problems with Cyberpunk 2077, at the very least, you could finish the game. I managed to beat it on a base Ps4, and while it wasn't a great experience, it was still one I was allowed to finish from the moment I purchased it. I preordered AC Valhalla paid extra money for the deluxe edition, and even bought some stuff from the Ubisoft store just to get to a point where I can't even play the game anymore. I reported my issue and sent in a save file over a month ago, and as I comb the forums, I find people have been experiencing this bug since October. It's really disheartening that the concept of triple a title really doesn't mean anything anymore.

  • gabz0793
    2 posts

    i loaded a previous save. I did the whole Halfdan quest again and it worked and I was able to talk to Radvi after the quest. But I did lose 30 hours of gameplay.

  • JO_7_U
    6 posts

    after the mission (of blood and bonds) halfdan kill faravid ,
    that the end of the story about jorvik ,
    then back to report randvi mission will come up ......
    but the mission don't come up in my mission list ......
    it just blind in there ,
    is anyone have the same problem as me ?

  • JO_7_U
    6 posts

    and then because of the problem i can't go on to the next mission ,
    so this problem need update to fix or some other way to fix ?

  • zheega
    24 posts

    I stopped playing a day after release because of all the bugs. I started playing again with patch 1.1.0 and I still got a bug that completely kills the game. Amazing.

  • andrewwang916
    4 posts

    @ubiexcellent ubisoft should fix this and release a hotfix, so we can proceed with the game. Else we buy a game ,then we can't finish the game, [censored]?

  • RichOilSheik
    7 posts

    Just got an auto generated email from Ubisoft letting me know that I haven’t completed the game yet and there’s more for me to discover.

    I’d actually love to continue but unfortunately Ubisoft has only had 2 months to fix this game breaking glitch. You can’t expect miracles. Everyone knows that when a game has a game breaking glitch the dev team can only work so fast. At this point, I’m expecting to see a new pandemic released before a patch is.

    But, hey. Appreciate the email letting me know there’s still more game left to be played. At some point.

  • KashimaKusanagi
    23 posts

    Looking at all the bugs on the list as of today blood and bonds still isn’t listed. However, looking at all of the quests that are broken I’m starting to wonder how did anyone ever manage to beat this game?

  • guest-EaeN9YOK
    1 posts

    I am currently in the same situation on PS4 however, I have no missions to do but I have not been able to pledge to any of these places: East Anglia, Essex, Cent, Suthsex, Lincolnscire, Eurvicscire, Glowecestrescire, or Hamtunscire. Waiting for a mission to pop up with Fluke and Warden of Law left (can’t because of the bishop in Lincoln). Stuck and waiting on something to update so I can finish. Currently at power 250 +80 played.

Suggested Topics