Welcome to discussions

Quick Suggestions

  • KashimaKusanagi
    23 posts

    Looking at all the bugs on the list as of today blood and bonds still isn’t listed. However, looking at all of the quests that are broken I’m starting to wonder how did anyone ever manage to beat this game?

  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts
    Best Answer

    Hello all!

    I apologise for the delayed update. Following TU 1.1.2, this issue wherein players were unable to "Report on Eurvicscire" has been marked as resolved by the development team. I will now be marking this topic as "Resolved," though we will keep the thread open in case there are new reports of this happening post-TU 1.1.2.

    If you are still unable to proceed with the Eurvicscire arc as "Reporting on Eurvicscire" does not pop up following the completion of "Of Blood and Bonds," please don't hesitate to update this thread. If possible, please can you also include a video that shows you have completed "Of Blood and Bonds," but that "Reporting on Eurvicscire" has not been added to your quest log.

    @ScetticoScet - Hey there! It sounds like you're encountering a different issue to the one being discussed in this topic. If you haven't already, could you please open a new thread about this? Please include a video that demonstrates Eivor being unable to use any weapons, or fight at all, whilst in the Great Hall or in the other locations you have provided. We can then pass this along to the development team for a closer look.

    @PoetSean - Thank you for taking the time to share you feedback with us. Please note that we're unable to offer a live service via the forums, and it can take our player support team some time to respond within a thread when contact volumes are high. I'm sorry if any disappointment has been caused by this.

    As this thread is about "Reporting on Eurvicscire" not appearing in the quest log following the completion of "Of Blood and Bonds," we ask players who are encountering different issue within the region to open new threads, or to find any similar ones within the megathread list. That way, we can keep the investigations separate and avoid any miscommunication or loss of information. It also prevents threads from going off-topic, which is part of the forum rules.

    @vamacisaac - I'm sorry to hear you've had trouble with "Of Blood and Bonds." If you're still having trouble completing this quest, would you be able to open up a new thread so we can keep these investigations separate. If you can include a video that shows you're unable to complete the fight, please also include this within your thread.

    Thanks all! 😊

    Official Response
  • guest-EaeN9YOK
    1 posts

    I am currently in the same situation on PS4 however, I have no missions to do but I have not been able to pledge to any of these places: East Anglia, Essex, Cent, Suthsex, Lincolnscire, Eurvicscire, Glowecestrescire, or Hamtunscire. Waiting for a mission to pop up with Fluke and Warden of Law left (can’t because of the bishop in Lincoln). Stuck and waiting on something to update so I can finish. Currently at power 250 +80 played.

  • RabidRhino241
    7 posts

    How do we go about getting a refund? Tired of waiting for a fix that may never come. Flow of the game has been completely ruined for me. Not interested in continuing anymore. Shame, because I've bought every AC game, and it's one of the few franchise's I've always preordered.

  • ProU95
    10 posts

    There’s some people saying they loaded a save from before the quest and did again, then worked.

    I did the same just after I got the bug, once where I started mid quest and just had to choose if I wanted to kill or not. The second one right at the end of the previous quest. Tried both options but nothing.. always had the same bug... Now I’m 20h past that point and stopped playing it cause I’ve got nothing else to do!

    Ubisoft, fixed this bugs for all regions already... 100£ and I can’t finish the game, don’t want a refund but some sort of compensation should be given to us

  • shanemcdermott
    8 posts

    @prou95 See, and thats what im scared of, losing 40 hours of gameplay and getting back to the same quest and still having the bug. I know I would be insanely [censored] if I replayed all of it up until blood and bonds and still got the bug.

  • guest-mvu9oDP9
    2 posts

    Same issues for me. Stuck on not being able to finish the game because of the alliance map glitch. Finished all territories possible. Killed all order members but the Father. Completed both Asgard and the other location. Killed all legendary animals. Upgraded everything I could in my settlement but can’t get it to level 6. So frustrating! 140 hours in at this point. Was around 120 when I first discovered the glitch but my last save was 40 hours back at 80.

    literally have nothing else to do so I went back to my save at 80 hours to try and replay up to the point that broke the game...only to realize that my most recent saves got written over by the autosaves. Last manual save was at 130. I’m done with the game at this point. Just want to be able to complete it but not worth the time to do all that stuff over again to possibly not even have it work. Please fix this garbage!

  • SniperWorm_xbox
    2 posts

    @jaimejk91 - Same thing happened to me, I thought Faravid may have become a God and is now immortal

    undefined

  • anicita
    1 posts

    Same issue here please fix asap

  • TOREPORTBUGS
    1 posts

    Yeah, just got it a while ago, so many glitches. I have one more allience region and I can't even start it, meanwhile I finished all raids and I don't have enough materials to finish my settlement. Crazy.

  • Gar_The_Breaker
    8 posts

    12/31/2020 STILL BROKEN ARE YOU KIDDING ME? Also happy New Years Eve!

  • ToxicSoulRe2021
    1 posts

    So I was wondering if anyone has ran into this issue. I play on xbox, wondering if its happening to you PS players as well. My game has glitched out on the mission of blood and bonds. I have completed everything but Eurvicire which I just started but when I go to track the quest it doesn't show up on the map, nor the quest log. I even went to the location its supposed to start at and there's nothing there. I cant progress in the game what so ever. I have 150+ hours in this game and I would really love to not restart. Has anyone found a way around this?

  • Gar_The_Breaker
    8 posts

    1/1/2021 STILL BROKEN. I have 151 hours in the game and 90% complete don't do this to me Ubisoft I want to see this damn game to the end.

  • KurtBoyer
    2 posts

    I can't progress on this alliance either. I actually killed him once and got the alliance arm band but then.. I wanted to see what happened if I let him live and that is where it went wrong. I reloaded and killed him and walked him out of the city and he ditched then went back to halfdan and nothing happened. He just stared at me..... I can't make progress NOR load a previous save because I went on and played a LOT more of the game and found out only later that on the PS4 I only get a handful of manual save slots. All this time I thought I had a tons of saved manual game files =*( Great GAME@!@@@ 10/10 but now I can't go forward and I can't go back. =-(

  • GRnLNTRN42
    2 posts

    Im having the exact same problem.... Im been playing the game since day one and now i cant finish the story. And every update makes the game even worse

  • rankinsect
    52 posts

    Definitely seems bugged - Of Blood and Bonds isn't the first Eurvicscire quest, it's the last one, so you shouldn't even see it in your log if you were just starting the arc.

    The first quest should be War in the North.

  • veckar
    2 posts

    My girlfriend and I are gonna join the crowd of displeased players, as we can’t pledge to Hamtunscire either! HOW hasn’t this been fixed? I used 100$ On this game, and can’t finish it. You haven’t given any proof that you’re actually working on it either. Are we just supposed to trust you when nothing is happening?

    I’m gonna ask for a refund too. This is embarrassing! We loved this game, even with ALL the bugs, crashes and so on. Though there are A LOT! And we were looking forward to finishing this, like we have Odyssey and Origins. If this isn’t gonna be fixed soon, I’m sad to say that this will be that last game I buy from you.

  • UltraHazard001
    1 posts

    @baconviking do you know of any fix there working on for this?

  • Tammieboy
    2 posts

    I had this, loading a previous save just before the crowning did the trick.

  • sailunatv
    1 posts

    I have the same problem and i have contacted the support , they dont even know the names of the quests to help. This is so bad.

  • ryan.clarke
    2 posts

    Ran into the same issue. Kind of thought it was weird, at the time, that I couldn't start the East Anglia alliance quests, after completing Ledecestrescire and Grantebridgescire, before being sent to Lunden. I continued on, thinking "it's just how it goes I guess", and completed the Lunden quests. I am now being sent to Vinland, which is many levels above my current. So I decided to stop playing, something didn't add up, and I found this post. Glad I'm not the only one having the issue and hopefully they get a fix, where I don't have to restart, pushed out soon.

Suggested Topics

Community Details

58
Online
139.0k
Users
24.4k
Topics
126.2k
Posts