Welcome to discussions

Quick Suggestions

  • Aloha_Snackbarz
    6 posts

    @gannik14 Also just tried to take Faravid out of Jorvik and kill him to see if that might trigger something. No dice.

  • Ubi-Borealis
    Ubisoft Support Staff 2877 posts
    Best Answer

    Hello all!

    I apologise for the delayed update. Following TU 1.1.2, this issue wherein players were unable to "Report on Eurvicscire" has been marked as resolved by the development team. I will now be marking this topic as "Resolved," though we will keep the thread open in case there are new reports of this happening post-TU 1.1.2.

    If you are still unable to proceed with the Eurvicscire arc as "Reporting on Eurvicscire" does not pop up following the completion of "Of Blood and Bonds," please don't hesitate to update this thread. If possible, please can you also include a video that shows you have completed "Of Blood and Bonds," but that "Reporting on Eurvicscire" has not been added to your quest log.

    @ScetticoScet - Hey there! It sounds like you're encountering a different issue to the one being discussed in this topic. If you haven't already, could you please open a new thread about this? Please include a video that demonstrates Eivor being unable to use any weapons, or fight at all, whilst in the Great Hall or in the other locations you have provided. We can then pass this along to the development team for a closer look.

    @PoetSean - Thank you for taking the time to share you feedback with us. Please note that we're unable to offer a live service via the forums, and it can take our player support team some time to respond within a thread when contact volumes are high. I'm sorry if any disappointment has been caused by this.

    As this thread is about "Reporting on Eurvicscire" not appearing in the quest log following the completion of "Of Blood and Bonds," we ask players who are encountering different issue within the region to open new threads, or to find any similar ones within the megathread list. That way, we can keep the investigations separate and avoid any miscommunication or loss of information. It also prevents threads from going off-topic, which is part of the forum rules.

    @vamacisaac - I'm sorry to hear you've had trouble with "Of Blood and Bonds." If you're still having trouble completing this quest, would you be able to open up a new thread so we can keep these investigations separate. If you can include a video that shows you're unable to complete the fight, please also include this within your thread.

    Thanks all! 😊

    Official Response
  • nouvfrosch
    2 posts

    I have the same. Managed to finish the last fight, all the way till the end, but never get the Report to Randvi. and when I travel to Raventhorpe, the Eoferwic area is now listed available still to be pledged. Choosing it would trigger the start of the Quest, but with no text or anything about the quest (prob because the quest is already completed).

    Also the game crashed to desktop right at the moment I fast traveled to Raventhorpe after finishing it. And when I reload a save just right after the last fight, as mentioned, the quest is gone and on the alliance map, Eoferwic still registered as available area to pledge, despite I already revealed and complete the entire quest line.

  • lightseylion
    3 posts

    @lokyeung30 i have the same problem on Xbox not being able to complete the Grantebridgescire region. I got the achievement for completing the arc but not able to complete it on the alliance map

  • cr4ssc4su4lty
    1 posts

    @host47 Same problem here. Help!

  • DJCinos
    1 posts

    @host47 Exact same problem here, and the last save I have prior to the bug is from 10 hours ago. Ubisoft please, we need answers.

  • SpicyDuckSoup
    12 posts

    I have had the same issue for about 5 days now. I have finished everything else in the game that I can up until this point and I don't know what else to do.

  • ubuu78
    1 posts

    I’m at 106 hours of gameplay after finishing of blood and bonds I didn’t get the quest to go see randvi to confirm the completion of the pledge my main story progress is halted completely ...no way I’m starting over and I only use the 1 manual save slot so can’t just load an earlier save

  • TryptamineLSD
    1 posts

    Same issue here, is a game breaking bug... Get your things in order ubisoft...
    Don't release new packs until people can actually play your game

  • Bockara
    13 posts

    Good news everyone, Patch 1.0.4 will be live tomorrow. Hopefully this patch will fix the issue.

  • Bockara
    13 posts

    @bockara Seems like the pictures didn't work, Patch will be 4.3GB released 1pm CET / 7AM EDT / 4am PDT / 11pm AEDT.

    • Addressed various issues with quests or world events that prevented players from completeing them.
  • EvilQueenCin
    6 posts

    I have had some minor issues but also two game-breaking ones. The worst issue I've had so far and still have, is that the quest "Of Blood and Bonds" won't properly complete. I finished it and it moved to completed quests but the area pledge won't fulfill and the message about going and reporting to Randvi doesn't appear. So far I haven't found a workaround to this bug. Can't finish the Halfdan quests. Tried both ending options but neither did the trick of finishing the area.
    Another bug I've encountered is in Tarben, the baker's quest. He won't come to the market and instead suddenly keeps following me around everywhere else and getting himself killed frequently.
    I hope there will be a patch soon because overall I really like Valhalla and I can't wait to be able to progress in the main story.
    I also have the known problem with some saves being corrupt, nothing major so far thankfully.
    I play on the Xbox One, hardcopy.

  • Gannik14
    3 posts
    It seems that in 7 days ubisoft did not fix this bug due to which it is impossible to move on

  • xThomsky4996x
    3 posts

    @gannik14 Updated it and it's still broken for me. Sorry guys!

  • Bockara
    13 posts

    @xthomsky4996x Yeah same here, and their support page is down so you can't even ask them about it...

  • SeyrenGuile
    1 posts

    I have the same problem in the PC.

  • Bockara
    13 posts

    undefined This is the response from the support, guess we'll have to wait a while longer...

  • YourEGrill
    1 posts

    I'm unable to continue in the main story anymore due to game breaking bug. 73% of the way at the very end of the 'Blood and bonds' quest. When choosing to take Halfdan's side and watching him to proceed in killing Faravid the quest never completed. After the cut screen their was no prompt or quest to return to Randvi. At first i was unware so i've progressed further into the game so i cannot reload a previous save. Unable to do anything on Alliance map as its the only one. 48 hours of gameplay stopped fun 🙂

  • jstyoon961
    5 posts

    @youregrill i'm experiencing the same bug for me in the suthsexe region the main quest just stopped. It disappeared suddenly. Finished every other region on Alliance map except the suthsexe region. Huge disappointment to the game.

  • dinasty01
    4 posts

    I have the same problem, this game is the biggest joke since unity. Probably even worse.

  • Aloha_Snackbarz
    6 posts

    @bockara same here. At what point do I get to ask for my money back? This is absurd.

Suggested Topics

Community Details