Welcome to discussions

Quick Suggestions

  • IceBergh32
    1 posts

    I’m definitely not going to go back 40 hours of game play to back track a bug that YOU (Ubisoft) haven’t fixed in over a month! You’re about to have what happened to Cyberpunk 2077 to you guys if you don’t give an update or something out. I payed over $100 for the pre-order and I get this crap? Unacceptable.
    👎

  • Ubi-Borealis
    Ubisoft Support Staff 2828 posts
    Best Answer

    Hello all!

    I apologise for the delayed update. Following TU 1.1.2, this issue wherein players were unable to "Report on Eurvicscire" has been marked as resolved by the development team. I will now be marking this topic as "Resolved," though we will keep the thread open in case there are new reports of this happening post-TU 1.1.2.

    If you are still unable to proceed with the Eurvicscire arc as "Reporting on Eurvicscire" does not pop up following the completion of "Of Blood and Bonds," please don't hesitate to update this thread. If possible, please can you also include a video that shows you have completed "Of Blood and Bonds," but that "Reporting on Eurvicscire" has not been added to your quest log.

    @ScetticoScet - Hey there! It sounds like you're encountering a different issue to the one being discussed in this topic. If you haven't already, could you please open a new thread about this? Please include a video that demonstrates Eivor being unable to use any weapons, or fight at all, whilst in the Great Hall or in the other locations you have provided. We can then pass this along to the development team for a closer look.

    @PoetSean - Thank you for taking the time to share you feedback with us. Please note that we're unable to offer a live service via the forums, and it can take our player support team some time to respond within a thread when contact volumes are high. I'm sorry if any disappointment has been caused by this.

    As this thread is about "Reporting on Eurvicscire" not appearing in the quest log following the completion of "Of Blood and Bonds," we ask players who are encountering different issue within the region to open new threads, or to find any similar ones within the megathread list. That way, we can keep the investigations separate and avoid any miscommunication or loss of information. It also prevents threads from going off-topic, which is part of the forum rules.

    @vamacisaac - I'm sorry to hear you've had trouble with "Of Blood and Bonds." If you're still having trouble completing this quest, would you be able to open up a new thread so we can keep these investigations separate. If you can include a video that shows you're unable to complete the fight, please also include this within your thread.

    Thanks all! 😊

    Official Response
  • dwaelim
    5 posts

    How has a gamebreaking bug just been ignored for months now? This isn't some minor little bug, it's literally "You Shall Not Pass Play" after the 100+ hr mark. I spent a month on Cyberpunk dealing with its bugs, now thinking surely I could go back and finish Valhalla now, but joke's on me.

  • dwaelim
    5 posts

    @ubiexcellent Slated to be addressed with no timetable nearly two months after it was found is not good enough for a bug that stops players from being able to complete your product. I enjoy the AC games, but now they'll be games I buy used a year after release, hopefully they'll be playable at that point.

  • dwest738
    6 posts

    Holy smokes I dodged this bug! I fought Faravid and finished the quest. Was told to go back to Randvi (same speech Eivor always says to himself). Got to Ravenshire, upgraded a building, went to Randvi and... nothing. I was so confused. There were no quests in my quest list for Eurvicscire and the knife was still on the board for that area. I reloaded a save (I think it was the "exclusive quest" save) and redid the fight and everything worked fine. I figured it was just a glitch, but now I've stumbled on this forum and see so many people's pain. 😞

  • ihatemilkduds
    8 posts

    @dwest738 Is Eurvicscire showing as completed on your map with your workaround?

    My issue is a little different from a lot of what I'm seeing in this thread. I got the Report Back prompt and spoke to Randvi about the mission. She switched out the knife for the raven, but when the scene ended, the knife was (and is) still there and the Eurvicscire region still says Committed. I travel there and...nothing.

  • dwest738
    6 posts

    @ihatemilkduds Yeah, mine completed fine and I got the follow-up quest to go back and see Halfdan. I would keep trying to reload different autosaves or that exclusive autosave if you still can. I wonder if everyone who ran into this problem did what I did. I fought Faravid. Saved the game before going back to Randvi. Reloaded a previous autosave because I just wanted to see what the other outcome was (this was a difficult choice to make, after all). After escorting Faravid out I said to myself, yeah I'll stick with my first choice. I reloaded that save and went back to Randvi and the problem was there. I say this because I feel like saving and loading in this manner causes problems...but who knows.

  • ihatemilkduds
    8 posts

    @dwest738 I think I'm too far gone to have any worthwhile saves without having to start over. I gave up, hoping there'd be a fix by now. But the list of problems is so long.... and I've done every single little thing that can be done on the map except for the Hamtuncscire arc which doesn't show as eligible. Everything is cleared, the other maps are cleared and finished. Even the dinky treasure chests scattered everywhere

    I think I need to put it in a closet for awhile and come back in a few months to start from scratch, haha. Thanks for the suggestion. Might need to employ it when I try again.

  • sigvield
    1 posts

    I have the same problem, the quest is completed but I can't report to Randvi.

  • BrenCS99
    3 posts

    Got this issue too, absolutely appalling customer service. Before I found the forum, I tried contacting ubisoft support on the website and twitter and still have no response over 10 days later, and now I see the issue has been present FOR 2 MONTHS, they literally don't care at all, and that shows as they think it's just an "inconvenience". It's a game breaking bug ruining so many people's experience on the game, and since the awful reaction from the company and devs to fix it I've stopped all my friends buying the game and recommended they get another game for the 2 month lockdown were all in. Dissapointed to say the least. Fix it

  • Gar_The_Breaker
    8 posts

    This problem has kept me from beating the game since Nov.22. Can we please have a date on a hot fix or patch?

  • RichOilSheik
    7 posts

    I’m not asking for a refund as I want to finish the game. But I can assure you I’ll never buy a game from Ubisoft early again. I’ll wait a couple months to catch it on the bargain bin after several patches have come out.

  • keegaroo
    7 posts

    Looks like this is a duplicate of this issue: https://discussions.ubisoft.com/topic/83549/unable-to-progress-makes-me-go-back-to-eurvicscire/97?lang=en-US

    Strange that there are two massive issue threads on this topic and no mention of it on the megathread.

    @Ubi-Orion Can you contact the team in charge of the megathread to get this on there to give all of these customers peace of mind? Also, how can we request compensation for this? We've all been unable to play a game we purchased for almost 2 months. Personally, I don't want a refund because I'd very much like to see the end of this game, but I'd like to know how I can request compensation for having purchased a complete game but not being able to complete it for an unreasonable amount of time. Many customers buy these games with the expectation of beating them alongside friends/family or quickly to avoid spoilers and you've broken a sort of unspoken contract that a player will be capable of completing the game on purchase.

  • keegaroo
    7 posts

    To make matters worse, it looks like this is a duplicate of this thread: https://discussions.ubisoft.com/topic/82558/alliance-map-issue-game-breaking-bug/225?lang=en-US

    So that's two massive bug threads about the same issue with a lot of furious customers and almost 2 months with no resolution despite other patches to the game or mention of it on the megathread.

    @UbiExcellent What can we do to request compensation for this? Many customers buy these games with the expectation of beating them alongside friends/family or quickly to avoid spoilers and you've broken a sort of unspoken contract that a player will be capable of completing the game on purchase. I'd like to finish the game once it's fixed, but also be recouped for being sold something at full price that I still can't use. It would be a small gesture for Ubisoft that would bring better word-of-mouth to Ubisoft Support.

  • profits23
    1 posts

    Ive been lurking this thread hoping they state a patch is coming to fix this. My last save game is nearly 20 hours before the Eurvicsire arc, I absolutely refuse to go back and do everything because Ubisoft cannot get their [censored] together. This issue should have been addressed in a hot fix, there should never have been the need for a thread like this, or for a glitch like this to exist in the first place. I did not play the last two AC games, but Valhalla I bought because it looked good, and it was fun until this point. Now I dont even want to progress any more in the story since there is no guarnatee Ubisoft will ever fix this. Absolutely unacceptable, you have lost a customer in me and many others I am sure as well. Please fix this issue ASAP so we can finish the game we paid in full for.

    @UbiExcellent
    @Ubi-Orion

  • KashimaKusanagi
    23 posts

    I feel like at this point; there are two simple solutions to all these game-breaking bugs. There should be an option to mark a quest as complete and mark a region as successfully pledged. The quest completion allows people to move past instances of a single quest being bugged and marking region complete fixes situations where an entire region can't be completed for one reason or another. At this point, I'm ready to just head to youtube to watch scenarios where I couldn't actually play through a mission, but I'd like to be able to play the game again.

  • UbiKobold
    Ubisoft Support Staff 541 posts

    Good day! Thank you all for your updates and clarifications! Our teams are hoping to deploy a fix for this issue in a future patch. Please keep an eye out for any patches or updates to the game!

    Official Response
  • Sebbie09
    2 posts

    @ubiexcellent i should say im astounded at the awful customer service from Ubisoft but I'm not. I should be saying what a great game this is despite multiple bugs but seeing as it's literally impossible to complete in it's current state, I'm not. But tbh having lurked on this thread for a while now, the thing that hurts/angers me the most is that Ubisoft simply don't care. They've got our money. The deal is done as far as they're concerned. Yet, as someone else pointed out, if it were concerning microtransactions they would be all over it. Utterly disappointing. Ubisoft have gotten off lightly over this game after CDPR have taken all the heat for cyberpunk.

  • ProU95
    10 posts

    How can we actually do some sort of legal action on Ubisoft? Surely this is in one way or another illegal... selling a game that’s BROKEN and doing nothing about it. Paid full ultimate price and this is what we get...

    As I said in the other thread... this is most likely my last Ubisoft purchase (thank god I didn’t buy any in game items before this encounter) including the cancellation of the very awaited (for me anyways) Prince of Persia as it will probably be as broken.
    How disappointing.

  • Rodouglas94
    2 posts

    So guys I finally gave up at 125 hours and accepted with a broken heart that I was going to
    have to replay from before eurvicscire, I loaded my 65 hour save to start again, my only available previous save. 4 regions lost, 80 hours lost, mysteries and bosses lost. It took a lot of willpower and I deleted the newer save to motivate myself.

    I love this game And all of the AC games before it so I didn’t mind even though it was frustrating, I had to finish this game.

    in the back of my mind I didn’t and still don’t think that a patch can fix this bug without ultimately players having to load an earlier and probably substantially earlier save, to reset the quest either way, so I did it, I Bought time for a fix by completing all the mysteries again and getting everything except Eurvicscire done, I then couldn’t resist Even with no fix to try again and this time I chose to save Faravid and the quest worked and I reported back to randvi and it’s made my 202 I was squealing.

    so for anyone dubious, replaying that way does fix it. Dunno if that helps UBI but it’s saving Halfdan that knacks the quest line I think.

    If you want to see the end of this game, load your old save. If not I’d just trade it in and buy it cheap Again in a years time when your interest is back.

    This being said, I’m quite amused at the fact that I’ve weathered this storm donning my glued on irremovable feathery Mari-Lwyd cape that’s been clinging to my back since Glowestecire. Honestly after the eurvicscire glitch I’m quite fond of the thing 😂

  • PoetSean
    8 posts

    I started the Eurvicscire arc and after speaking to halfdan who tells me to investigate what's going on, the quest completely disappeared. Nothing I have tried can make it come back. Loading a previous save does nothing. This is my last pledge on the map. So frustrating that so many are experiencing this and nothing has been done to resolve it. This is on the PS4.

Suggested Topics

Community Details

93
Online
139.5k
Users
24.5k
Topics
127.1k
Posts