Welcome to discussions

Quick Suggestions

  • BittingJawz
    1 posts

    Does anyone know how to get past the of blood and bonds glitch? I can’t progress in the game at all until it says I complete it.

  • Ubi-Borealis
    Ubisoft Support Staff 2837 posts
    Best Answer

    Hello all!

    I apologise for the delayed update. Following TU 1.1.2, this issue wherein players were unable to "Report on Eurvicscire" has been marked as resolved by the development team. I will now be marking this topic as "Resolved," though we will keep the thread open in case there are new reports of this happening post-TU 1.1.2.

    If you are still unable to proceed with the Eurvicscire arc as "Reporting on Eurvicscire" does not pop up following the completion of "Of Blood and Bonds," please don't hesitate to update this thread. If possible, please can you also include a video that shows you have completed "Of Blood and Bonds," but that "Reporting on Eurvicscire" has not been added to your quest log.

    @ScetticoScet - Hey there! It sounds like you're encountering a different issue to the one being discussed in this topic. If you haven't already, could you please open a new thread about this? Please include a video that demonstrates Eivor being unable to use any weapons, or fight at all, whilst in the Great Hall or in the other locations you have provided. We can then pass this along to the development team for a closer look.

    @PoetSean - Thank you for taking the time to share you feedback with us. Please note that we're unable to offer a live service via the forums, and it can take our player support team some time to respond within a thread when contact volumes are high. I'm sorry if any disappointment has been caused by this.

    As this thread is about "Reporting on Eurvicscire" not appearing in the quest log following the completion of "Of Blood and Bonds," we ask players who are encountering different issue within the region to open new threads, or to find any similar ones within the megathread list. That way, we can keep the investigations separate and avoid any miscommunication or loss of information. It also prevents threads from going off-topic, which is part of the forum rules.

    @vamacisaac - I'm sorry to hear you've had trouble with "Of Blood and Bonds." If you're still having trouble completing this quest, would you be able to open up a new thread so we can keep these investigations separate. If you can include a video that shows you're unable to complete the fight, please also include this within your thread.

    Thanks all! 😊

    Official Response
  • ryandus
    1 posts

    @evilqueencin Mines doing the same thing, didn't catch the issue until 30 hours later and got Excaliber and all other quests. Ubisoft says it's a known issue and they're working on it. Lovely...

  • KashimaKusanagi
    23 posts

    @ryandus Working on it so much it still hasn't made the mega thread.

  • UbiKoality
    Community Manager 440 posts

    @kashimakusanagi Hey there! I apologize for any inconvenience or frustration that may have been caused by this bug in Assassin's Creed Valhalla. What is your case reference number? Also, are you able to grab videos of this error? I would be more than happy to ensure that it has been reported!

    Official Response
  • Randy_Marsh010
    1 posts

    @ubiexcellent This is by far the biggest game breaking bug I've ever had on one of your games, it's hard to imagine what bugs are taking priority.

    Also your "assurances" are pretty worthless at this point, no offense.

  • KashimaKusanagi
    23 posts

    @ubikoality Report and save file submitted case number 13595047. This is from another thread that is located here. Alliance map issue, game-breaking bug | Ubisoft Forums I submitted that save the file back in November. I don't have any video, but the bug is pretty simple I filled Faravid, and the quest was marked as complete, but it never told me to report back to Randvi. I can talk to her, and the game doesn't register that she should be acknowledging that I've completed the region.

  • Bread2019
    4 posts

    Going back on when this may be patched, the most probable reason this isn’t mentioned official as being worked on by Ubisoft is that this bug requires more work than others to fix. Obviously Ubisoft is a business and they have many bugs in this game and the only way they really are going to look good is by fixing easier bugs such as not having max arrows rather than fixing harder bugs so the press and others can just say “well they are fixing the bugs”. Straight up the sword of ancaster bug happened to me and all I had to was restart the game. However with this bug, since I have no older save, I can’t fix it unless I start a new game which is pointless. Along with that the representatives of Ubisoft keep reminding us that even if your bug isn’t stated in the known bugs it doesn’t mean that it isn’t being fixed, so what confirmation do we even have that it is. Looking at how these are being patched we might not even have fix for this until the first dlc. That means we get 2 free dlcs, a paid one, and then we get the fix for a bug that has been there since the beginning of the game. It’s like trying to complete a maze blindfolded with one leg, what’s even the point of doing it in the first place.

  • Smedo13
    2 posts

    Omg, they seem to have fixed it in the 1.1.1 patch!

    Addressed an issue in Of Blood and Bonds where the players couldn't complete the quest or couldn't report back to Randvi.
  • RichOilSheik
    7 posts

    @UbiExcellent

    So is the patch tomorrow going to fix this issue?

  • iBankstro
    7 posts

    @smedo13 They better have fixed all the alliance map [censored]. I cant complete wedding bells because main and tale wont pop up

  • Bread2019
    4 posts

    @richoilsheik
    Hopefully

  • ProU95
    10 posts

    They do apparently mention that Of blood and bonds glitch where the reporting to Ranvid quest won’t pop up it’s fixed. It’s unbelievable!

  • QuickGaming_
    8 posts
    This post is deleted!
  • TonyCee91
    1 posts

    lools like they have finally fixed it only took them 2 months, just going to install the update and hopefully be able to complete the game

  • Keyobard
    1 posts

    @lokyeung30

    Did this ever get fixed?

  • ProU95
    10 posts

    Hallelujah!

    Playing on Xbox SX and finally fixed after updating! Just logged in with Eivor saying his typical phrase!

    Well done Ubisoft! Two months later but you’ve managed, thanks!

  • tytjetullat
    2 posts

    It is finally working! Suddenly got a message to report to Randvi after patch 1.1 🙂

  • SMouco
    1 posts

    Hello;
    Until I get to the quest, "of Blood and Bonds" I had none of the reported problems with the exception of the arrows.
    Now I have done every quest possible, Asgar, Jotunheim, Vinland, all mystical animals, excalibur, every alliance possible,... and now this guy, king Halfland doesn't go yo is coronation... just keep facing belly down in the wall...
    It really is frustrating, I can't finish the quest or restart the quest.
    I hame more then 184 hours of game played, 403 ability points and 43 of mastery... and I can get past this!
    I have traveld to Norway, vinland, changed character, exited animus, but notting is working. Done anything I can remember, but nothing worked!
    Anyone with the same problem in this quest?
    How to restart or reespaw to the boss fight, like it says on the notes of the patch 1.1.1
    Thank every one in advance.

  • Gar_The_Breaker
    8 posts

    YOU FIXED IT YOU ACTUALLY FIXED IT !!!!!!

  • Agoldz
    6 posts

    @gar_the_breaker actually no way

Suggested Topics

Community Details

132
Online
139.7k
Users
24.6k
Topics
127.4k
Posts