Welcome to discussions

Quick Suggestions

  • iBankstro
    7 posts

    @smedo13 They better have fixed all the alliance map [censored]. I cant complete wedding bells because main and tale wont pop up

  • Ubi-Borealis
    Ubisoft Support Staff 2825 posts
    Best Answer

    Hello all!

    I apologise for the delayed update. Following TU 1.1.2, this issue wherein players were unable to "Report on Eurvicscire" has been marked as resolved by the development team. I will now be marking this topic as "Resolved," though we will keep the thread open in case there are new reports of this happening post-TU 1.1.2.

    If you are still unable to proceed with the Eurvicscire arc as "Reporting on Eurvicscire" does not pop up following the completion of "Of Blood and Bonds," please don't hesitate to update this thread. If possible, please can you also include a video that shows you have completed "Of Blood and Bonds," but that "Reporting on Eurvicscire" has not been added to your quest log.

    @ScetticoScet - Hey there! It sounds like you're encountering a different issue to the one being discussed in this topic. If you haven't already, could you please open a new thread about this? Please include a video that demonstrates Eivor being unable to use any weapons, or fight at all, whilst in the Great Hall or in the other locations you have provided. We can then pass this along to the development team for a closer look.

    @PoetSean - Thank you for taking the time to share you feedback with us. Please note that we're unable to offer a live service via the forums, and it can take our player support team some time to respond within a thread when contact volumes are high. I'm sorry if any disappointment has been caused by this.

    As this thread is about "Reporting on Eurvicscire" not appearing in the quest log following the completion of "Of Blood and Bonds," we ask players who are encountering different issue within the region to open new threads, or to find any similar ones within the megathread list. That way, we can keep the investigations separate and avoid any miscommunication or loss of information. It also prevents threads from going off-topic, which is part of the forum rules.

    @vamacisaac - I'm sorry to hear you've had trouble with "Of Blood and Bonds." If you're still having trouble completing this quest, would you be able to open up a new thread so we can keep these investigations separate. If you can include a video that shows you're unable to complete the fight, please also include this within your thread.

    Thanks all! 😊

    Official Response
  • Bread2019
    4 posts

    @richoilsheik
    Hopefully

  • ProU95
    10 posts

    They do apparently mention that Of blood and bonds glitch where the reporting to Ranvid quest won’t pop up it’s fixed. It’s unbelievable!

  • QuickGaming_
    8 posts
    This post is deleted!
  • TonyCee91
    1 posts

    lools like they have finally fixed it only took them 2 months, just going to install the update and hopefully be able to complete the game

  • Keyobard
    1 posts

    @lokyeung30

    Did this ever get fixed?

  • ProU95
    10 posts

    Hallelujah!

    Playing on Xbox SX and finally fixed after updating! Just logged in with Eivor saying his typical phrase!

    Well done Ubisoft! Two months later but you’ve managed, thanks!

  • tytjetullat
    2 posts

    It is finally working! Suddenly got a message to report to Randvi after patch 1.1 🙂

  • SMouco
    1 posts

    Hello;
    Until I get to the quest, "of Blood and Bonds" I had none of the reported problems with the exception of the arrows.
    Now I have done every quest possible, Asgar, Jotunheim, Vinland, all mystical animals, excalibur, every alliance possible,... and now this guy, king Halfland doesn't go yo is coronation... just keep facing belly down in the wall...
    It really is frustrating, I can't finish the quest or restart the quest.
    I hame more then 184 hours of game played, 403 ability points and 43 of mastery... and I can get past this!
    I have traveld to Norway, vinland, changed character, exited animus, but notting is working. Done anything I can remember, but nothing worked!
    Anyone with the same problem in this quest?
    How to restart or reespaw to the boss fight, like it says on the notes of the patch 1.1.1
    Thank every one in advance.

  • Gar_The_Breaker
    8 posts

    YOU FIXED IT YOU ACTUALLY FIXED IT !!!!!!

  • Agoldz
    6 posts

    @gar_the_breaker actually no way

  • PoetSean
    8 posts

    Not for me. I still have no objectives showing for Eurvicscire despite being pledged to it.

  • Agoldz
    6 posts

    @poetsean update the game

  • Agoldz
    6 posts

    I JUST PLEDGED EURVISCIRE OMG THE DAY HAS FINALLY COME

  • PoetSean
    8 posts

    @agoldz I did. Still no quests. Maybe because I was already pledged?

  • RayMcGirk100
    19 posts

    Can confirm this has been fixed for me. Reporting on Eurvicscire now appears when I log in and I can report back to Randvi.

  • BrenCS99
    3 posts

    THANK YOUUUU @UbiExcellent
    SO HAPPY, appreciate you interacting and assuring us!!!

  • guest-mvu9oDP9
    2 posts

    Mine is fixed also allowing me to advance in the game...but my settlement didn’t seem to upgrade. I’m maxed out on all buildings and I’m a hair under the full bar to reach level 6.

    I did lose 8-9 hours of killing the Order members since I tried to go back to an older save not knowing the most current cloud save would get written over. But at least I can finish the game now. Please let me know if you can fix the settlement issue. Thanks!

  • svenkornie77
    4 posts

    Working, finally!

  • PoetSean
    8 posts

    It's the 'honour has two edges' quest that's not appearing for me. I'm on the PS4.

Suggested Topics

Community Details

90
Online
139.5k
Users
24.5k
Topics
127.0k
Posts