Welcome to discussions

Quick Suggestions

  • Donvir
    8 posts

    Money back time.

    Companies that make broken games do not deserve to get paid.

    Thank God I live in Europe and they have to give me my money back if the game is not working.

    Last time I pre-order anything from Ubisoft.

    4.5gigs and still not fixed? yikes. But hey, the game shop works fine im told, good think they knew where their priorities were.

  • Ubi-Borealis
    Ubisoft Support Staff 2929 posts
    Best Answer

    Hello all!

    I apologise for the delayed update. Following TU 1.1.2, this issue wherein players were unable to "Report on Eurvicscire" has been marked as resolved by the development team. I will now be marking this topic as "Resolved," though we will keep the thread open in case there are new reports of this happening post-TU 1.1.2.

    If you are still unable to proceed with the Eurvicscire arc as "Reporting on Eurvicscire" does not pop up following the completion of "Of Blood and Bonds," please don't hesitate to update this thread. If possible, please can you also include a video that shows you have completed "Of Blood and Bonds," but that "Reporting on Eurvicscire" has not been added to your quest log.

    @ScetticoScet - Hey there! It sounds like you're encountering a different issue to the one being discussed in this topic. If you haven't already, could you please open a new thread about this? Please include a video that demonstrates Eivor being unable to use any weapons, or fight at all, whilst in the Great Hall or in the other locations you have provided. We can then pass this along to the development team for a closer look.

    @PoetSean - Thank you for taking the time to share you feedback with us. Please note that we're unable to offer a live service via the forums, and it can take our player support team some time to respond within a thread when contact volumes are high. I'm sorry if any disappointment has been caused by this.

    As this thread is about "Reporting on Eurvicscire" not appearing in the quest log following the completion of "Of Blood and Bonds," we ask players who are encountering different issue within the region to open new threads, or to find any similar ones within the megathread list. That way, we can keep the investigations separate and avoid any miscommunication or loss of information. It also prevents threads from going off-topic, which is part of the forum rules.

    @vamacisaac - I'm sorry to hear you've had trouble with "Of Blood and Bonds." If you're still having trouble completing this quest, would you be able to open up a new thread so we can keep these investigations separate. If you can include a video that shows you're unable to complete the fight, please also include this within your thread.

    Thanks all! 😊

    Official Response
  • Aloha_Snackbarz
    6 posts

    So, it is actually *fixed, I just had to find a save 20+ hours back before the quest started and redo it.

  • zephrylus
    3 posts

    130 hours of gameplay and I'm hard stuck here. Map is basically complete and THIS is where it stops me. I'm glad they're "aware" of the bug at least.

  • Drmanboydog
    3 posts

    @host47 Another victim of this. I also can't seem to begin the Glowecestrescire arc. Feels like they might be related somehow.

  • USSR_JamBloB
    2 posts

    @aloha_snackbarz this worked for me aswell.

  • Theraggeddidler
    1 posts

    I've got the exact same issue, guess I'll play the game next year. Hopefully fixed then

  • Funky.Player
    3 posts

    Same here, not fixed in 1.0.4. Most recent save before that is 40 hours old already, yeah, not doing that. This can NOT be hard to fix, they can just see if you finished the "Of blood and bonds" quest and then when you activate the region again on the map you should immediately get "report to randvi". How difficult can this be?

  • Donvir
    8 posts

    @aloha_snackbarz This is sadly not an option for people that had this quest done 50+ hrs ago. I was collecting everything, exploring and doing all sorts of stuff.

  • Aloha_Snackbarz
    6 posts

    @donvir yep. I just got lucky that I found a save...

  • SpicyDuckSoup
    12 posts

    @aloha_snackbarz Yeah I would love to go back but I've done so much more since that point that it would be a waste of time. Just wish ubi would fix these issues as I can't progress any further with the game

  • RabidRhino241
    7 posts

    I'm having exactly the same issue... any chance of a fix? Have really enjoyed the game up until now, would like to progress

  • lokyeung30
    15 posts

    @amralkhatib I'm updating the game to 1.04 right now, I'm not sure yet.

  • lokyeung30
    15 posts

    @aloha_snackbarz Yea I never tried that so I can't say much, but looks like a big bug

  • lokyeung30
    15 posts

    @donvir Yea exactly man I'm 60 hours in, I guess the old saving tricks works if you spotted the issue and deal with it right away, but that doesn't change the fact that it is a big game braking bug that Ubisoft needs to pay attention too, cause even tho it's a great game, I'm sure we all are disappointed.

  • lokyeung30
    15 posts

    @zephrylus Honestly I really hope they do, I haven't seen a "official account" of the tech people commenting on this like they would but someone did say they got in touch with the officials so we'll see, they need to fix this asap and god knows how long til the next update patch.

  • lokyeung30
    15 posts

    @funky-player I mean coding is pretty difficult but I do hope they can fix this asap.

  • SnowBlind180
    1 posts

    faravid at the end of the quest died and I got the ring but the quest won’t complete and the boss keeps respawning and won’t die

  • Ryanbollin
    4 posts

    @evilqueencin

    I just had this issue today on pc. Recent patch i guess didnt fix it. I took to google to see if any one
    else had this issue. I figured i would comment i hopes it gets fixed. Im going to continue on with the game.

  • RuinedMango
    1 posts

    Same thing happened to me, also when I built buildings it didn't actually build them and took my supplies.

  • DruzeKus
    3 posts

    Hello,

    I have just finished the Wincestre pledge (and have only Hamtunscire left). So I returned to Randvi, completed the quest and looked at the alliance map again. The only region I could chose was Eurvicsire. She gave the same speech as the first time, but this time there was no quest started.
    I have killed all the order members; located gathered all the codex pages; solved all mysteries, found all wealth and artefacts (except Hamtunscire). So there is nothing more I can do in the game to proceed.

    I believe I kinda know where the bug arose. I talked with Randvi to pledge Jorvik. After that I spoke with Hytham who told me I should go to speak with Randvi about Jorvik. But I didn't do that because I already did. Finishing Jorvik was fine (I remember talking to her about what I've done), but when I finished Eurvicsctre, I don't remember that she mentioned anything about what has happened, but gave me the option to pledge Wincestre anyways.

    Is there a way to fix this save? I have 114h on it.

    Best Regards, Kus

Suggested Topics

Community Details

46
Online
143.5k
Users
25.4k
Topics
132.0k
Posts