Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • lokyeung30
    15 posts

    @donvir Yea exactly man I'm 60 hours in, I guess the old saving tricks works if you spotted the issue and deal with it right away, but that doesn't change the fact that it is a big game braking bug that Ubisoft needs to pay attention too, cause even tho it's a great game, I'm sure we all are disappointed.

  • Ubi-Borealis
    Ubisoft Support Staff 1316 posts
    Best Answer

    Hello all!

    I apologise for the delayed update. Following TU 1.1.2, this issue wherein players were unable to "Report on Eurvicscire" has been marked as resolved by the development team. I will now be marking this topic as "Resolved," though we will keep the thread open in case there are new reports of this happening post-TU 1.1.2.

    If you are still unable to proceed with the Eurvicscire arc as "Reporting on Eurvicscire" does not pop up following the completion of "Of Blood and Bonds," please don't hesitate to update this thread. If possible, please can you also include a video that shows you have completed "Of Blood and Bonds," but that "Reporting on Eurvicscire" has not been added to your quest log.

    @ScetticoScet - Hey there! It sounds like you're encountering a different issue to the one being discussed in this topic. If you haven't already, could you please open a new thread about this? Please include a video that demonstrates Eivor being unable to use any weapons, or fight at all, whilst in the Great Hall or in the other locations you have provided. We can then pass this along to the development team for a closer look.

    @PoetSean - Thank you for taking the time to share you feedback with us. Please note that we're unable to offer a live service via the forums, and it can take our player support team some time to respond within a thread when contact volumes are high. I'm sorry if any disappointment has been caused by this.

    As this thread is about "Reporting on Eurvicscire" not appearing in the quest log following the completion of "Of Blood and Bonds," we ask players who are encountering different issue within the region to open new threads, or to find any similar ones within the megathread list. That way, we can keep the investigations separate and avoid any miscommunication or loss of information. It also prevents threads from going off-topic, which is part of the forum rules.

    @vamacisaac - I'm sorry to hear you've had trouble with "Of Blood and Bonds." If you're still having trouble completing this quest, would you be able to open up a new thread so we can keep these investigations separate. If you can include a video that shows you're unable to complete the fight, please also include this within your thread.

    Thanks all! 😊

    Official Response
  • lokyeung30
    15 posts

    @zephrylus Honestly I really hope they do, I haven't seen a "official account" of the tech people commenting on this like they would but someone did say they got in touch with the officials so we'll see, they need to fix this asap and god knows how long til the next update patch.

  • lokyeung30
    15 posts

    @funky-player I mean coding is pretty difficult but I do hope they can fix this asap.

  • SnowBlind180
    1 posts

    faravid at the end of the quest died and I got the ring but the quest won’t complete and the boss keeps respawning and won’t die

  • Ryanbollin
    4 posts

    @evilqueencin

    I just had this issue today on pc. Recent patch i guess didnt fix it. I took to google to see if any one
    else had this issue. I figured i would comment i hopes it gets fixed. Im going to continue on with the game.

  • Signup518
    2 posts

    Has anyone heard an update to this? I've having the same issue. Entire map is complete except Eurvicscire.

  • Ryanbollin
    4 posts

    I have the issue on pc. This is rediculous. You would think they would fix it. Cant complete the story. Poor work on ubisofts end.

  • Drmanboydog
    3 posts

    @drmanboydog disregard the Glow-schire part of that. It was a little buggy, but worked. BUT still not able to finish Euvicscire arc. I thought maybe I needed to hunt down more members of the order to trigger something. I've turned in 25 medallions, aside from the father and a dozen zelots, only 3 higher ranked order members remain. I've tried exiting the simulation, changing genders, actual trouble shooting by deleting temp files and startup programs. nothing.

  • Bockara
    13 posts

    @signup518 Still nothing, probably won't be resolved until next patch... I guess we'll have to wait 1-2 weeks

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @host47 I greatly appreciate you all adding to this thread, and want to apologize for the inconvenience caused by this bug. I've brought this error to our team's attention and hope we can address the issue in more detail soon. In the meantime, please feel free to post videos showing this error occurring to aid in our investigation.

    Official Response
  • RayMcGirk100
    19 posts

    @bockara Same situation here. I sent a bug report to Ubisoft but they're beating around the bush telling me I'm playing the game wrong, lol. I completed "Of Blood and Bonds" but "Reporting on Eurvicscire" never started, so I can't report back to Randvi and finish the zone.

  • riverslq
    2 posts

    @ubiexcellent I'm stuck as well.
    And i can't even lose hours of progress even if I wanted to before this bug happened because of the arbitrary limit on save games on the pc version.

    can't pick hamtunscire.
    everything else is done.

    https://imgur.com/a/TLSbkmE

  • guest-HvaxrTSJ
    1 posts

    This happened to me too. I had already completed the questline, but then got it again for some reason, and there are no checkpoints/quests listed and halfdan won't talk to me.

  • SpicyDuckSoup
    12 posts

    @ubiexcellent There isn't really much to show. When selecting to kill Faravid and completing that, you have a conversation with Halfdan and are not greeted with the usual "Report to Randvi" quest ending. Faravid can still be found in the Royal Hall in Jorvik and attacked to the point where he is downed but it asks you to revive him and he begins fighting you. I wish I had chosen to let the poor man live as it would've saved his life and my gaming experience.

  • mrggamer50
    1 posts

    The mission completed but it didn't lock in as complete so it shows me tracking it still and shows faravid still alive and me fighting him when I chose to kill him.

  • jensime
    21 posts

    Also having this issue

  • guest-k4U1AtCF
    1 posts

    @host47 I am having this exact same problem! I finished all of the quests in the Eurvicscire story arc, but I can not report the progress to Randvi!

    This is a game killing bug! Please help Ubisoft!

  • EvilQueenCin
    6 posts

    Still no fix for this and it won't even be added to the bug megathread. I can't do anything else in the game now, completed my last area but Euriviscire still won't work...

  • AcientofChaos
    1 posts

    I'm having the same issue I can't finish eurvicscire and its really irritating me please fix this soon

  • Chefdaddymark
    5 posts

    EXACTLY the same problem here!!

Suggested topics

Community details

8
Online
123.3k
Users
21.2k
Topics
109.3k
Posts