ubisoft discussions

Quick Suggestions

  • cazaresr
    2 posts

    After killing faravid and completing quest, Of blood and bonds. I’m unable to speak with randvi to complete the quest and move on with the storyline.

    This is my last alliance that I need secured. When I go back to Eurvicscire faravid is alive and keeps reviving.

  • UbiExcellent
    756 posts

    @janiya1013 Hi there! Please rest assured that our teams are aware of this issue. If you're able to provide your affected save files, that would be extremely helpful!

  • emrcn92
    2 posts

    The game is not loading on Stadia. When I load my save it gives me a black screen. Please fix this issue. I paid so much money for this game!!! 

  • whosfergus
    1 posts

    Had this bug on day 1 also, pathetic that it's not fixed by now to be honest, there's no way I'm spending another 50 hours doing what I've already done. Never saw why people complained about Ubisoft before... I definitely do now.

  • UbiExcellent
    756 posts

    @emrcn92 Hey there! I'm sorry to hear about this crashing issue you're experiencing via Stadia. Please post about this issue on a relevant thread, or create a new thread if you do not see any similar threads already made. This will help prevent any confusion on this thread. Thank you!

  • kgtice
    1 posts

    I logged in yesterday to find that my play thoroughbred Essex and Euvicscire we no longer in my game. I repleged Essex and completed the arc for a second time. I have now completed Snotinghamscire. Eurvicacire still shows incomplete. I pledge that region and it says I’m in the Blood and Bonds quest. I go to the long house and kill Farvid, but he can’t be killed. Only depleted of health the “I” can revive him!

    ive completed the entire map! I’d like to complete the main story quest!

  • KurtBoyer
    2 posts

    I have NO quests to do now because of a bug. I got the armband after the king killed Faravid with a hammer but I wanted to see the other ending with Faravid leaving so I reloaded a previous game and chose to walk Faravid out of the city. After that the king said to get out of his sight and that was that.. No arm band.. no alliance not moving forward... I decided to do other things in the game but I am not getting down to very little left to do and am stuck now at 150 hours in and no way to complete the game. Please give me a way to bypass this bug and gain the completion of the alliance quest or reset the area somehow.

  • Janiya1013
    28 posts

    @ubiexcellent how do I Provide my save files to yu.

  • Papajaka
    2 posts

    We get that the team is working on it and that we'll have a patch eventually.. but really what a kick in the balls to see the known issues megathreads get updated every few days and never even see a mention of our issue. Like at least for our sake of mind, I'm sure it would help a lot of players in this thread feel more at ease for the issue at hand. Its the very least you guys could do to make us feel like some sort of priority..

  • KuzKaoz
    3 posts

    I’ve ran into an issue with Leofrith on my alliance map as well. He was my next quest and I wanted to power up a bit so I messed around leveling up. Now I went back and he’s there highlighted red where the fight goes down but nothing starts and he just stands there.

  • JO_7_U
    6 posts

    after that i find out Faravid not dead yet ,
    and he stand behind Halfdan that look like he want to find something 😊
    i try kill him again , but don't work ,
    still not pass the mission , but it was funny

  • KashimaKusanagi
    23 posts

    Unfortunately its a bug that a lot of people have encountered. It’s been reported since October and still hasn’t made it to a mega thread yet.

  • warmaarten
    2 posts

    Stopped playing for a month now because of this pls fix this ubisoft 😞

  • BrenCS99
    3 posts

    @UbiExcellent although this is frustrating for everyone, I do appreciate you popping in with the occasional update.

    May I ask though, why hasn't this bug which stops people playing the game (game breaking) been prioritised, over other bugs which are simply an inconvenience?

    I feel that's why so many people are annoyed with the development team.

  • dougherty_13
    1 posts

    I have completed all quest in the eurvicshire arc but when I go to report to ranvi there is no Dialogue and no the “return to randvi” quest does not show up. It is the last arc I need to finish to continue the game so now I can not advance. Also during the legionar statue quest the key on the stool out side the house can not be picked up so I can not finish that quest. Please advice !!

  • Minnesootan
    1 posts

    This damn thing just happened to me. Stupidly, I went to Vinland after noticing the report to Randvi never showed up. After completing vinland I found this thread. Had to re-load a old [censored] save and lost everything I did in vinland. First time around I killed Fareavid. after the reload I spared him. Worked this time.

  • ProU95
    10 posts

    Good new guys! There’s a patch coming up soon enough!

    Bad news guys! There is no mention whatsoever to the issue we’ve got.

    Maybe in another two months we’ll be getting a fix for it but if I’m honest... they’ll probably be fixing the bugs that will pop out with the next update! Big up to Buggysoft.

  • keegaroo
    7 posts

    That is such a salient point. I'd like to know this too @UbiExcellent I'm a developer myself and find it very hard to believe this bug would take this long to resolve, so it's likely it's just not being prioritized. Can we get any information about that?

  • KashimaKusanagi
    23 posts

    It's sad that I had time to submit a request and receive a refund on Cyberpunk before Ubisoft acknowledged this game-breaking bug that's been around since launch

  • BittingJawz
    1 posts

    Does anyone know how to get past the of blood and bonds glitch? I can’t progress in the game at all until it says I complete it.

Suggested Topics