Welcome to discussions

Quick Suggestions

  • Smedo13
    2 posts

    Omg, they seem to have fixed it in the 1.1.1 patch!

    Addressed an issue in Of Blood and Bonds where the players couldn't complete the quest or couldn't report back to Randvi.
  • RichOilSheik
    7 posts

    @UbiExcellent

    So is the patch tomorrow going to fix this issue?

  • iBankstro
    7 posts

    @smedo13 They better have fixed all the alliance map [censored]. I cant complete wedding bells because main and tale wont pop up

  • Bread2019
    4 posts

    @richoilsheik
    Hopefully

  • ProU95
    10 posts

    They do apparently mention that Of blood and bonds glitch where the reporting to Ranvid quest won’t pop up it’s fixed. It’s unbelievable!

  • QuickGaming_
    8 posts
    This post is deleted!
  • TonyCee91
    1 posts

    lools like they have finally fixed it only took them 2 months, just going to install the update and hopefully be able to complete the game

  • Keyobard
    1 posts

    @lokyeung30

    Did this ever get fixed?

  • ProU95
    10 posts

    Hallelujah!

    Playing on Xbox SX and finally fixed after updating! Just logged in with Eivor saying his typical phrase!

    Well done Ubisoft! Two months later but you’ve managed, thanks!

  • tytjetullat
    2 posts

    It is finally working! Suddenly got a message to report to Randvi after patch 1.1 🙂

  • SMouco
    1 posts

    Hello;
    Until I get to the quest, "of Blood and Bonds" I had none of the reported problems with the exception of the arrows.
    Now I have done every quest possible, Asgar, Jotunheim, Vinland, all mystical animals, excalibur, every alliance possible,... and now this guy, king Halfland doesn't go yo is coronation... just keep facing belly down in the wall...
    It really is frustrating, I can't finish the quest or restart the quest.
    I hame more then 184 hours of game played, 403 ability points and 43 of mastery... and I can get past this!
    I have traveld to Norway, vinland, changed character, exited animus, but notting is working. Done anything I can remember, but nothing worked!
    Anyone with the same problem in this quest?
    How to restart or reespaw to the boss fight, like it says on the notes of the patch 1.1.1
    Thank every one in advance.

  • Gar_The_Breaker
    8 posts

    YOU FIXED IT YOU ACTUALLY FIXED IT !!!!!!

  • Agoldz
    6 posts

    @gar_the_breaker actually no way

  • PoetSean
    8 posts

    Not for me. I still have no objectives showing for Eurvicscire despite being pledged to it.

  • Agoldz
    6 posts

    @poetsean update the game

  • Agoldz
    6 posts

    I JUST PLEDGED EURVISCIRE OMG THE DAY HAS FINALLY COME

  • PoetSean
    8 posts

    @agoldz I did. Still no quests. Maybe because I was already pledged?

  • RayMcGirk100
    19 posts

    Can confirm this has been fixed for me. Reporting on Eurvicscire now appears when I log in and I can report back to Randvi.

  • BrenCS99
    3 posts

    THANK YOUUUU @UbiExcellent
    SO HAPPY, appreciate you interacting and assuring us!!!

  • guest-mvu9oDP9
    2 posts

    Mine is fixed also allowing me to advance in the game...but my settlement didn’t seem to upgrade. I’m maxed out on all buildings and I’m a hair under the full bar to reach level 6.

    I did lose 8-9 hours of killing the Order members since I tried to go back to an older save not knowing the most current cloud save would get written over. But at least I can finish the game now. Please let me know if you can fix the settlement issue. Thanks!

Suggested Topics

Community Details

26
Online
138.5k
Users
24.2k
Topics
125.7k
Posts