ubisoft discussions


  • locked topic_solved [RESOLVED] Completion of "Of Blood and Bonds" does not register; "Reporting on Eurvicscire" not received | POST HERE

    1 likes/552 replies/24972 views
    ubisoft:x-posts, 6

    @poetsean update the game

  • Agoldz
    ubisoft:x-posts, 6


  • PoetSean
    ubisoft:x-posts, 8

    @agoldz I did. Still no quests. Maybe because I was already pledged?

  • RayMcGirk100
    ubisoft:x-posts, 19

    Can confirm this has been fixed for me. Reporting on Eurvicscire now appears when I log in and I can report back to Randvi.

  • BrenCS99
    ubisoft:x-posts, 3

    THANK YOUUUU @UbiExcellent
    SO HAPPY, appreciate you interacting and assuring us!!!

  • guest-mvu9oDP9
    ubisoft:x-posts, 2

    Mine is fixed also allowing me to advance in the game...but my settlement didn’t seem to upgrade. I’m maxed out on all buildings and I’m a hair under the full bar to reach level 6.

    I did lose 8-9 hours of killing the Order members since I tried to go back to an older save not knowing the most current cloud save would get written over. But at least I can finish the game now. Please let me know if you can fix the settlement issue. Thanks!

  • svenkornie77
    ubisoft:x-posts, 4

    Working, finally!

  • PoetSean
    ubisoft:x-posts, 8

    It's the 'honour has two edges' quest that's not appearing for me. I'm on the PS4.

  • Chefdaddymark
    ubisoft:x-posts, 5

    So I got to finally pledge to eurvicshire through being able to report back to randvi.

    Then I got to lost glory and the quest disappeared and I'm left stuck again. Its beyond a joke now.

  • ihatemilkduds
    ubisoft:x-posts, 8

    Can confirm the patch worked for me. Before the game even broke for me, I had the prompt and returned to Randvi to report on Eurvicscire. Something a lot of people said they never got. We had a whole conversation about it, but it just never showed as completed and I couldn't continue the story.

    Soon as this patch was installed, the Report prompt reinitialized and it actually took this time. So excited to get back to the main storyline after all those [censored] cairns and glitches.

  • RabidRhino241
    ubisoft:x-posts, 7

    It's still not working for me, I checked again after seeing some people had had a small amount of success. I'm already pledged, and everywhere else is already completed, I'm still not able to progress

  • brooncalza
    ubisoft:x-posts, 1
  • lokyeung30
    ubisoft:x-posts, 15

    Hi everyone,

    So I just downloaded the newest patch and the issue is FINALLY solved!

    Sorry to hear some of you guys still stuck with this problem, hope Ubisoft fix it soon.

    And for those whose able to continue the game again, Have fun!!

  • Ubi-MrM
    Ubisoft Support Staff ubisoft:x-posts, 4117

    Hello everyone,

    Thank you all for your continued reports of this issue with "Of Blood and Bonds" not registering as completed, and of "Reporting on Eurvicscire" not appearing in your quest log correctly as a result. We did implement a fix for this issue in TU 1.1.1, which you can read about in the patch notes below:

    Addressed an issue in Of Blood and Bonds where the players couldn't complete the quest or couldn't report back to Randvi.

    I can see from reading the most recent posts in the thread that this has been a successful fix for several of you, which I'm very pleased to hear. For those of you still impacted by the issue, however, rest assured that I've now passed your usernames to the developers for them to be aware that it is still happening. The investigation was already reopened, so it's something already on the developers' radar.

    If playing on PC or PS4, we would appreciate it if you could send us your save files in a support case to help us investigate the issue further following TU 1.1.1. If you struggle to open a support case, please let me know so that I can open one manually for you. Any additional videos of the issue would also be much appreciated, just in case the issue is presenting itself any differently post-patch.

    Just as a quick FYI as well - a separate megathread for the issue with Halfdan appearing dead in "Of Blood and Bonds" has been created. If your issue is with that, not with the completion of the quest and progression to reporting to Randvi, please post in that megathread instead.

    Finally, I have seen a few players here in this thread and elsewhere mentioning similar issues with other regions (Grantebridgescire; East Anglia) - please post on a separate thread for these and do not derail this thread from its primary topic regarding Eurvicscire. I will be moving all unrelated posts to separate threads shortly, to try and keep the investigations separate.

    @guest-mvu9oDP9 Regarding your issue with the settlement upgrades, have you fully upgraded the Cattle Farm, Fowl Farm and Grain Farm each to Level 3?

    @PoetSean Just to clarify, given that "Of Blood and Bonds" is the penultimate quest in the Eurvicscire arc - is the prior quest "Honor Has Two Edges" just missing from your completed quest log, and that is what you mean? Or are you at the start of the arc? I just want to make sure I understand why you have been replying to this thread if you're not yet at the point of needing to complete "Of Blood and Bonds". 🙂

    Thank you all very much, and have a great evening! 🙂

  • keegaroo
    ubisoft:x-posts, 7

    Considering that it took about 2 months to fix an issue that prevented players from progressing the game, could we receive compensation? Many of the users here bought a game with the expectation of being able to play through it without being completely halted for 2 months by a technical issue. I see this thread was merged with a few others since the latest patch, but my question is in regards to any issues on pledging regions that were brought to attention in November and prevented players from progressing with no workaround.

  • PoetSean
    ubisoft:x-posts, 8

    @ubi-woofer Hi, I'm unable to start honour has two edges. After the conversation with halfdan, I'm not presented with another quest. I only know that honour has two edges is the next quest by googling it.

  • PoetSean
    ubisoft:x-posts, 8

    @ubi-woofer any update on this?

  • Ubi-Borealis
    Ubisoft Support Staff ubisoft:x-posts, 6075

    Hello there!

    @keegaroo - Please note that any compensation to be offered is at the discretion of the Assassin's Creed: Valhalla team, and this is something that the player support team don't have a say in. We apologise for any inconvenience caused by this.

    @PoetSean - I'm sorry to hear that you're encountering this issue. As this is a different quest to "Of Blood and Bonds," I would recommend checking our megathread list to see if a more suitable thread regarding this issue is listed there. If you can't find your issue in the megathread, please can you open a new thread regarding this issue, so we can keep the investigations separate? Thanks!

  • ScetticoScet
    ubisoft:x-posts, 2

    In Of Blood and Bonds I've hit a wall. Upon entering the boundaries of the Great Hall, Eivor loses the ability to use any weapons or to fight at all, for that matter, leaving me wide open during the battle with Faravid. As soon as Eivor steps out of the Royal Hall's boundaries, the weapons can again be used. Within the boundaries, nothing. I've deleted and reinstalled the game. Opened it in the PS4 version. Tried some earlier saves. I'm at a loss as to what else I can do to proceed. Any help is much appreciated.

  • PoetSean
    ubisoft:x-posts, 8

    @ubi-borealis ridiculous that it’s taken all this time for you to tell me to log this somewhere else. Such bad customer service. There are loads of issues with eurvicscire that have been listed on this thread and it feels like nothing is being done.

Suggested Topics