Welcome to discussions

Quick Suggestions

  • Aloha_Snackbarz
    6 posts

    So, it is actually *fixed, I just had to find a save 20+ hours back before the quest started and redo it.

  • zephrylus
    3 posts

    130 hours of gameplay and I'm hard stuck here. Map is basically complete and THIS is where it stops me. I'm glad they're "aware" of the bug at least.

  • Drmanboydog
    3 posts

    @host47 Another victim of this. I also can't seem to begin the Glowecestrescire arc. Feels like they might be related somehow.

  • USSR_JamBloB
    2 posts

    @aloha_snackbarz this worked for me aswell.

  • Theraggeddidler
    1 posts

    I've got the exact same issue, guess I'll play the game next year. Hopefully fixed then

  • Funky.Player
    3 posts

    Same here, not fixed in 1.0.4. Most recent save before that is 40 hours old already, yeah, not doing that. This can NOT be hard to fix, they can just see if you finished the "Of blood and bonds" quest and then when you activate the region again on the map you should immediately get "report to randvi". How difficult can this be?

  • Donvir
    8 posts

    @aloha_snackbarz This is sadly not an option for people that had this quest done 50+ hrs ago. I was collecting everything, exploring and doing all sorts of stuff.

  • Aloha_Snackbarz
    6 posts

    @donvir yep. I just got lucky that I found a save...

  • SpicyDuckSoup
    12 posts

    @aloha_snackbarz Yeah I would love to go back but I've done so much more since that point that it would be a waste of time. Just wish ubi would fix these issues as I can't progress any further with the game

  • RabidRhino241
    7 posts

    I'm having exactly the same issue... any chance of a fix? Have really enjoyed the game up until now, would like to progress

  • lokyeung30
    15 posts

    @amralkhatib I'm updating the game to 1.04 right now, I'm not sure yet.

  • lokyeung30
    15 posts

    @aloha_snackbarz Yea I never tried that so I can't say much, but looks like a big bug

  • lokyeung30
    15 posts

    @donvir Yea exactly man I'm 60 hours in, I guess the old saving tricks works if you spotted the issue and deal with it right away, but that doesn't change the fact that it is a big game braking bug that Ubisoft needs to pay attention too, cause even tho it's a great game, I'm sure we all are disappointed.

  • lokyeung30
    15 posts

    @zephrylus Honestly I really hope they do, I haven't seen a "official account" of the tech people commenting on this like they would but someone did say they got in touch with the officials so we'll see, they need to fix this asap and god knows how long til the next update patch.

  • lokyeung30
    15 posts

    @funky-player I mean coding is pretty difficult but I do hope they can fix this asap.

  • SnowBlind180
    1 posts

    faravid at the end of the quest died and I got the ring but the quest won’t complete and the boss keeps respawning and won’t die

  • Ryanbollin
    4 posts

    @evilqueencin

    I just had this issue today on pc. Recent patch i guess didnt fix it. I took to google to see if any one
    else had this issue. I figured i would comment i hopes it gets fixed. Im going to continue on with the game.

  • RuinedMango
    1 posts

    Same thing happened to me, also when I built buildings it didn't actually build them and took my supplies.

  • DruzeKus
    3 posts

    Hello,

    I have just finished the Wincestre pledge (and have only Hamtunscire left). So I returned to Randvi, completed the quest and looked at the alliance map again. The only region I could chose was Eurvicsire. She gave the same speech as the first time, but this time there was no quest started.
    I have killed all the order members; located gathered all the codex pages; solved all mysteries, found all wealth and artefacts (except Hamtunscire). So there is nothing more I can do in the game to proceed.

    I believe I kinda know where the bug arose. I talked with Randvi to pledge Jorvik. After that I spoke with Hytham who told me I should go to speak with Randvi about Jorvik. But I didn't do that because I already did. Finishing Jorvik was fine (I remember talking to her about what I've done), but when I finished Eurvicsctre, I don't remember that she mentioned anything about what has happened, but gave me the option to pledge Wincestre anyways.

    Is there a way to fix this save? I have 114h on it.

    Best Regards, Kus

  • DruzeKus
    3 posts

    I have also found Faravid in Jorvik's long house (room behind the throne). I can fight him, but when i get him to 0 HP, he doesn't die, but gives me the option to revive him.

    PS: still stuck

Suggested Topics

Community Details

48
Online
138.7k
Users
24.3k
Topics
125.8k
Posts