Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • todkavonic
    1 posts

    @jarheadbuttle Same problem here.

  • Mangled85
    3 posts

    @ubi-spud I thought todays patch would have fixed it. I went back to check today if I could speak to him, and something changed, he now has a dialogue box over his head but once I press the button to speak with him it goes away and nothing happens still. Weird. I'm on PC btw.

  • Marcus_Fialho
    5 posts

    Same thing happening to me on PC. After I defeated him, a option to talk to him pops up, I hit the key and nothing happens, he stays kneeling and does nothing. I restarted my game many times, continued playing other quests and came back, still same issue.
    As follows in the video I made after trying to finish the encounter:

    Hope its fixed in the next patch.

  • videopixels
    6 posts

    Still the same issue even after the update. Sigh.

  • Marcus_Fialho
    5 posts

    @ubiwan With all due respect dude, but even after this has been reported almost a month before this patch, it's still happening. Shows the respect Ubisoft has for its customers. One [censored] month Dude. If a player wants to have a spear in the early game and run into this he (or she) is just [censored].

  • Navino16
    3 posts

    The bug is still there ... Please do something

  • katanakahn
    11 posts

    Defeated Erik, he took a knee and then refused to talk...

    Here is a video of one of my Many trips back to Norway to see if it was resolved:

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts

    Hello everyone,

    Thank you for your continued reports of this issue with speaking to Erik Loyalskull after defeating him in Hildesvini's Crag in Rygiafylke. We're still investigating this at the moment, and the developers now require additional information from you all in order to proceed with identifying the cause of the issue and hopefully implement a fix.

    For those of you on PC and PS4, it would be much appreciated if you could submit a save file to us via a support case or Live Chat. If you're unable to open a case, you're welcome to contact us over social media (Facebook / Twitter) to have a case created for you, or else reply here and I can open one on my side on your account. These save files will enable the developers to explore the issue in greater depth and understand the exact issue being faced by each of you. Additionally, DXDIAG and MSINFO files would be helpful from affected players on PC, so we can investigate the system side of things too and see if there are any common factors.

    Any players on other platforms, additional videos of the issue would be much appreciated for the developers to see how the issue manifests itself. It seems the prompt to speak can either be missing entirely, or that it disappears when you attempt to use it but Erik Loyalskull does not speak - so videos of both instances are greatly useful to look further into both possibilites.

    I fully appreciate that this issue was reported at launch, and that you're all eager for an update - I'll do my best to update this thread as soon as I can when more information comes in from the developers. I've added the thread to our megathread list as well for greater visibility. Thank you for your patience and understanding so far. 🙂

    @chrislcrews Regarding the Fly Agaric challenge you mentioned, have you since been able to complete this correctly? If not, could you please open a separate thread for this issue and include a video showing you completing the challenge and it not progressing correctly? Thanks!

    @Marcus_Fialho @katanakahn Thank you both for being so proactive and providing videos of the issue already; I added these to our report for the developers to refer to.

    Official Response
  • Lwelshy92
    2 posts

    @ubi-woofer I have to same problem on the fly agaric I have seen that a post was created in November regarding this problem and there was only one comment on it ..... I found a work around for Erik loyalskull online that said if once you defeated him you stood in the fire and remained in the fire (keeping an eye on health) untill confirm kill action was present it would let you complete the mysteries .... I have had other problems with mysteries in Norway and created a ticket but nothing had happened with it

  • Ubi-Borealis
    Ubisoft Support Staff 1887 posts

    @Lwelshy92 - Hello there! Thanks for sharing your workaround for Erik Loyalskull. If you are encountering other issues that are different to the one being discussed here, I would recommend that you check out the megathread list to see if it is listed here already. If you cannot find a thread about your issue, please can you open a new thread so we can keep these investigations separate? Thanks!

    Official Response

Suggested Topics

Community Details