Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • HRHSuperCorgi
    2 posts

    I spoke to Rolf the Raider on the platform, but I didn’t follow him to the fighting ring. When I got to the ring he would not speak to me or finish any dialogue. At this point I can do nothing.

    I have restarted the frame, fast traveled elsewhere and came back and it did not reset or continue the quest.

    Quest marker points back to the original position (the platform) where Rolf no longer is.

    Playing on Xbox One, digital copy

  • darkmafia99
    1 posts

    Similar thing has happened to me, with multiple mystery quests. This game is so broken. Out of 6 mystery quests the game completed 3, and the other 3 are now glitched with no amounts of fast travel, console restarts, game restarts. I complete these games fully, area by area, this sucks.

  • natnattttt
    2 posts

    I just had the same thing. Went on my phone for a couple minutes after talking to him on the platform then couldn't find where he went off to (map was pointing back to the platform) so went off to do other stuff. Later I was walking across the area and heard some more of his dialogue so I tried to go in the direction that triggered more dialogue and finally found him, he went off running so I followed him to to the fight ring and then was stuck for what to do (ended up accidentally killing the guy on the chair while I was trying to figure out what to do). Using Odin's vision (or whatever it's called) put a green dot over the guys fighting and another guy, and lit up the guy I followed in blue but there's no interaction popping up to speak to him, not even the little speech bubble comes up. I tried looking into my save files and then I noticed some of the autosave data was saying it was corrupted so I did a new manual save and reloaded the game, this changed the autosave titles back to normal but it did not fix this world event issue. The first interaction I had with him was about 2 hours of gameplay ago so I don't want to go back to that.

    I did have a similar thing happen where in the other world event in Stravanger I messed up the free run and the guy got away from me and I couldn't find him, meditating didn't help, but then about an hour later I was going through the area so I thought I'd check back to where he first was with his chest, and he was back and I managed to finish the event.

    Playing on pc

  • natnattttt
    2 posts
    This post is deleted!
  • D0NT_PANICK
    9 posts

    I’ve done a lot of other stuff in the game. Came to Stravanger and ran into Rolf the Raider. He began walking and talking, but there were other things I planned to do. So I started doing them. Got to the docks and he took off running to the spot where people were cheering a small fight. Now he just stands there. No talk bubble. Nothing. Can’t interact with the players that have teal dots over their heads.
    Starting a new game is not an option nor a fix. This needs to be fixed by the devs.

  • ElKylo
    1 posts

    @ubi-swaggins i am also experiencing this issue

  • guest-2dOeYSWL
    2 posts

    I can’t talk to Rolf after finishing the fight, and can’t progress any furter due to this.

  • guest-2dOeYSWL
    2 posts

    @guest-2doeyswl Raider Recruit mystery, not Raider Receipt

  • Newballs
    5 posts

    I've had this bug out on me tried 4 times and keeps bugging out once I knocked them all out and they just stand there and no speech marks to finish it. I've also bugged on the other side mission near this one where you've got to lure a wolf to this guy, he's now dead and doesn't respawn. Any help would be great!

  • Southern1902
    1 posts

    I have had issues with the Rolf the raider mission. It will start the fight but no matter the outcome I am stuck in limbo where it will not talk to Rolf after the fight, all he does is walk really slow everywhere. I can't even continue anything until I load a previous save. I have tried to fast travel to other places and come back to it, I have tried restarting the Xbox. Is there a fix?

  • KTorrential
    1 posts

    I met Rolf the Raider and followed him to the fight. I cannot interact with him or the three other NPCs to take part in the event. Rolf and another NPC are just standing there, with 2 NPCs fighting.

  • jay2981
    2 posts

    @guest-2doeyswl were you able to find a work-around? Same thing happened to me but on the Xbox.

  • Ubi-Baron
    Ubisoft Support Staff 730 posts

    @guest-2dOeYSWL @jay2981 Thank you for reporting this to us, we have had reports of this occurring.

    Just to confirm, are you able to load a Save from before the Mystery and try again? It will create a Save at the end of a Mystery, so if you are loading the last Save game it may be the one after it believes the Mystery has been completed.

    Official Response
  • jowke44
    1 posts

    Same problem, i can t interact with the NPC anymore because i didn t follow him the first time 😞

    Playing on PC

  • Md_Maynard
    1 posts
    I was able to do the fight but then rolf....

    ....Remember this game is buggy as hell
    Save before start any quest and after, before you fast travel and after etc etc means less repeating [censored] lol.

    Thank you for posting your solution, it worked. Very helpful post, thank you

  • Boomer1250HD
    1 posts

    I have the same issue it’s the last mystery i have to complete.

  • DarthVeyda
    4 posts

    Same thing happens to me even after 1.0.4 and verifying files

  • ItsTheSucc
    1 posts

    Hey, so I have been doing the Raider Recruit mission, follow the guy to the area where he wants me to fight his best three people, and I will win the fight. When I finish the third guy, the man will say "That's enough" then that is it. The game no longer progresses, I'm stuck at walking pace, can't interact, fight, or even pause. My only option is to revert back to my previous save, which doesn't help when the game auto saves during and after the fight so I have to guess which one was before the fight. Please help someone if there is a work around or Ubisoft please patch this because I would like to 100% this.

  • Ubi-Baron
    Ubisoft Support Staff 730 posts

    @itsthesucc Thank you for reporting this to us.

    To help us look into this, would you be able to provide us with a video of this occurring? We can then pass this on to the team to allow them to investigate this.

    Official Response
  • CoolCarsMyDude
    1 posts

    I was experiencing a glitch with the Hunt for Honor world event where Erlend was killed by the wolf and nothing happened. So I installed the update. Erlend was still dead and the World Event was not awarded. I gave up and left. Then started the Raider Recruit event and now it all has stopped working! I was able to fight the 3 guys. Then it won't let me talk to Rolf. Its acting like I'm still in the fight. Except I can't swing. Just walk very slowly. I restarted. Nothing. I walked slowly into the water and drowned myself. It respawned me on the dock and I can't move at all. The world map won't even open. Loading previous saves didn't fix anything.

Suggested topics

Community details

19
Online
123.3k
Users
21.2k
Topics
109.2k
Posts