Welcome to discussions

Quick Suggestions

  • sonofsolidsnake
    2 posts

    I cannot complete the mission as all NPCs were killed by wolves. They respawn in camp dead. I've tried changing gender, meditation reloading save leaving animus. NPCs will spawn in dead behind archery log.
    It's a side objective mystery in snotinghamscire. Where Robin hood runs. Hes in the camp alive. All 4 other NPCs dead on the ground.


  • puttingmeoffand
    1 posts

    @elricmel2 Same issue! Hoping for a fix soon.

  • RenegadeDTAUK
    1 posts

    Have the same issue.

  • nitehawk182
    5 posts

    As I was getting ready to start the Sherwood Forest Archery mystery, the camp was attacked by boars and the NPC that "starts" the quest was accidentally killed...now, I can't get the mystery quest to start...i've restarted the game, left it off for a couple of days, but the character will not respawn

  • nitehawk182
    5 posts

    @pmonkey15 I have the same issue on XboxOne...except it was wild boars

  • crewdy4923
    1 posts

    Platform: Xbox Series X

    I have run in to a problem where this quest is unable to be completed due a dead NPC. I passed by this quest and didn’t interact with it the first time I was in the area and now I am in the process of trying to 100% the game.

    I’ve looked up guides online and the NPC that is supposed to initiate the second part of the quest (shooting the chicken) is dead on the floor.

    I've tried exiting and reloading the game, Force Quitting and even hard-resetting the console but none of these have fixed it.

    I’m 105 hours deep in to the game and the last manual save I have which I think was before I got to this area is around 25-30 hours ago, and most of that is picking up collectibles and finishing mysteries.

    is there anyway to get this quest to reactivate? It’s pretty much the last thing I have to do now and I’ll be very disappointed if this stops me getting the 100% and the achievement.


  • purityistheway
    2 posts

    Big npc was killer early on.I beat the whole game and came back and he is dead and can’t do the quest.The fluffy wolves got him.Too bad I didn’t make a backup file.Those wolves Goteem.

  • jada222
    3 posts

    Wolves killed the npc and now it will not let me complete the story. It is the last one that I need.

  • SirJownsalot
    2 posts

    I can not solve the archery practice (mystery) in snotinghamscire, since the npc that i need to interact with has been killed by wolfes. I was hoping that the recent patches would fix this, but the npc is still dead.

    I mean this mission:



    I finished nearly all of the collectibles and mysteries, so it realy is not that great to be stuck like that.

    I am playing on PS4 Pro.

  • Ubi-Wan
    Ubisoft Support Staff 631 posts

    @sirjownsalot Hey there. Sorry to hear about this! If possible, can you provide us with a clip of your issue occurring? We'd like to have a closer look at things!

    Official Response
  • Ionic93
    1 posts

    Good Men of Sherwood NPCs dead. They got killed by a pack of wolves that spawned near them and I can't complete it to get the platinum.

    I've tried restarting, fast travelling, exiting the animus and changing Eivors gender. No use.

  • jada222
    3 posts

    A wolf ended up killing the npc who started the mission and now I can not complete this mystery. It’s located in snotinghamscire. Also I am too far into the game to even try and go back to before it. I’m trying to get 100% completion but can’t with this. I’ve seen others post about this yet nothing has happened to fix this bug.

  • Shawzyee
    2 posts

    I've had the same problem on the playstation, any news on this getting a fix?

  • SirJownsalot
    2 posts

    @ubiwan Hello, i can try to make a video. For now i've made a screenshot of the youtube video, to specify the dead npc exactly: It's the "anglo saxon woman"

    Since you need her to trigger the whole dialogue, its currently not possible to start the challenge.

    undefined

  • PastorPinda
    2 posts

    @sonofsolidsnake Same here, on ps4.

  • SWIFTLAW
    1 posts

    Same for me on ps4. Fast travel or restart will not respawn npc.

  • Ubi-Orion
    Ubisoft Support Staff 255 posts

    Hey there folks.

    Just to confirm that the issue with this particular quest as the NPC cannot be interacted with is known to the development team and is under active investigation at the moment. Many thanks for your reports on this issue so far.

    Please keep an eye on the forums for updates on this and any other issues.

    Official Response
  • MidnightRaiin
    8 posts

    @ubi-orion 🙌🏻 Thanks for the update on this particular issue. I have been looking around on this forum to see others experiencing the same problem. I would be delighted with a fix, but just knowing the devs have seen the issue in the sea of others is good news for me. 🙂

  • dashadeal1976
    1 posts

    same issue hear its the last world event i have to do to clear the entire map of 100% in every territory and its doing my head in not being able to

Suggested Topics

Community Details

99
Online
193.0k
Users
32.5k
Topics
162.8k
Posts