ubisoft discussions


  • locked topic_solved [RESOLVED] [Xbox] Achievements not unlocking/tracking correctly | POST HERE

    1 likes/454 replies/17384 views
    ubisoft:x-posts, 197

    Hello again everyone!

    I found about 9 of your threads and merged them all together. Let's try to keep everything in 1 thread 🙂


    I've been playing cross play, mainly on PC but then continuing on PS4 in another location.

    The Builder achievement just popped on the PS4 when I got Ravensthorpe to level 3 but nothing else, so clearly don't pop based on your saves.

    Thank you for your feedback! We'll continue to reflect on this system to see how it can be improved.

  • Greenway_Gaming
    ubisoft:x-posts, 3

    @ubi-raziel I seem to notice that when I disconnect from the Ubisoft servers all tracking seems to stop. I have to close the entire game and reload to get it to track again.

  • ThaRealCuber
    ubisoft:x-posts, 9

    @ubi-raziel Just to lt you know how random it is:

    (playing on original xbox one)
    After completing two Cairns in England, I finished my third Cairn in Asgard: no achievment.
    Went back to England, completed another one there and the achievement unlocked.

    Going to England first time, no achievement. Continued a bit and later reloaded an older save. Went to England again and achievement popped.

    It is hard to tell what is going on because it so random. Hopefully people keep reporting their issues so you might be able to close in on the issue.

    You say there where no issues while testing? I find this hard to believe considering the amount of issues are popping up all over the internet.
    Maybe you need to trace back to what is different in testing environment compared to the general public.

  • DrummerJoeBoy
    ubisoft:x-posts, 1


    I’m currently 70-80 hours through the game (I’m enjoying it to say the least), however a number of achievements haven’t popped during my play through (playing on Series X), including the witch Hunter achievement for killing a Sister of Lerion, and a number of story arc region completions.

    Is this something that is known and once patched the achievements will register, or do I need to replay the entire game for these to register?

    I’ve also noticed that sometimes at the end of a story arc, I will be given a ring for the alliance I’ve made, however these aren’t popping up in my inventory (not sure if this is related to the story arc achievements not registering).

    Advise would be greatly appreciated on this.

  • SquiSquiSquidio
    ubisoft:x-posts, 3

    I'm stuck on a few achievements not gaining progress or just not unlocking

    Dreamcatcher - stuck at 80%
    Orlog Champion - progress hasn't gone up on the last two wins
    Home Decor - not unlocking
    A Picture of Grace - not unlocking

  • xPoppu
    ubisoft:x-posts, 12

    Same issue on XBOX SX. Most achievements not unlocked... please fix it for your loyal day one customers. Thanks!

  • RoninRedleg71
    ubisoft:x-posts, 2

    On Xbox 1X multiple achievements aren’t unlocking. They include: It’s Alive!, Tranquility, Equilibrium, Witch Hunter, Builder, Face My Might, and more.

  • zDrUnKeNMoNkEyz
    ubisoft:x-posts, 1

    I have now had a few achievements not pop, in particular Flying Eivor (being thrown 30 meters,) Sea Horse (swimming 3km w/horse,) Not the Norse You're Looking For (pass guards blended w/monks,) and A Picture of Grace (run through and break 30 objects.)

    I absolutely love this game, but am worried that I’m 50+ hours in and the achievements aren’t tracking completely and or not popping at all and I’d have to redo everything all over. I feel the safest route is to stop playing until it’s been fixed, but would prefer not too obviously. Is Ubisoft aware of these issues? I know they’re aware of the “save issue,” but didn’t see much regarding achievements. Over on TrueAchievements.com there are quite a lot us in the community having these exact issues.

    if anyone from the Ubisoft team can reach out with some guidance and or reassurance, I’d sincerely appreciate it!

    Stay safe out there!

  • sn4kee88
    ubisoft:x-posts, 5

    13+ days and not fixed the achievements!
    I don’t get any single achievement on this AAA GAME!

  • InnocentLattice
    ubisoft:x-posts, 2

    Placed all 16 items in my settlement in England and my "Home Decor" Achievement is still locked. Lots of achievements are bugged and don't unlock as intended like "Equine Attack", I had to start a new game to unlock this one as it didn't unlock even after 20+ tries on my main save.

  • Midag0
    ubisoft:x-posts, 9

    Face my might.

    I have 8 abilities equiped and the achievement didn’t unlock.

    Xbox Series X

    tried all possible trouble shooting. Not too keen on starting again.

  • InnocentLattice
    ubisoft:x-posts, 2

    @squisquisquidio Same, Home Decor isn't unlocking for me too. Tried a least 5 times to change all the settlement decor but nothing.

  • vsampedro
    ubisoft:x-posts, 1

    6 hours of play, arrived to England, upgraded two buildings, 0 achievements unlocked, playing Deluxe version on One X, should I start again and risk not triggering them again?

  • LucasKasecker
    ubisoft:x-posts, 1

    A lot of achievements are glitched for me as well. The one for leaving Norway and doing 10 world events are totally broken. Any news?

  • sn4kee88
    ubisoft:x-posts, 5

    They don't know what to do 😁

  • RP123
    ubisoft:x-posts, 3

    I noticed that achievements such as “Rampage” the one for completing your first raid in England and many others through reading forums on Reddit aren’t unlocking. Even ones like “We’re in the end game now” aren’t unlocking.
    Hopefully this will get fixed in a way which means we don’t need to start a new save as getting to power 280 isn’t exactly quick.

  • jlsmith333
    ubisoft:x-posts, 2
  • Killrog01
    ubisoft:x-posts, 15

    @ubi-raziel Thank you for acknowledging the issue.

    Could you also see that the reported issues megathread's list is updated with this problem? As it stands only the PC lack of Ubisoft Connect achievements is quoted. This isn't what most of the complaints here are about, so you should add another entry about this problem.

    Thank you.

  • jobu59
    ubisoft:x-posts, 4

    Hi all. I am playing on an Xbox One X I am have not gotten the it’s alive achievement. I have over 100 hours in the game and most settlement buildings made including the barracks. I’ve created my lieutenant, and have also recruited several other jomsvikings but the achievement never unlocked. One thing to note was that I pretty much took the default jomsviking that was offered and didn’t make any changes except to gear load out. I’ve tried changing his gear every so often to see if the game will see it as “creating” a jomsviking again but no luck.

  • ImaginaryRuins
    ubisoft:x-posts, 418

Suggested Topics