ubisoft discussions

Quick Suggestions

  • HoliestEd
    1 posts

    I have 100 hours in and am level 400 with five or six mastery points. The achievements that should have popped but haven’t are:

    We’re in the end game now
    The enemy of my enemy
    Calling in a favour

    i am played on series x with the base edition.

  • LostSoul301281
    16 posts

    I've not had any issues yet, but there is still the Disorder of the Ancients achievement which isn't unlocking for a lot of people, and TrueAchievements lists it as discontinued.

    I only have six targets left, and I don't want to get to the end only to find this achievement is still broken and won't unlock once the requirements have been met.

    Is there any update on a fix?

  • FirebirdUK3
    11 posts

    Witchhunter achievement hasn't popped for me. I've killed all 3, they've registered in Ubisoft connect

    None of the arc completion achievements have popped for me either. Completed all of them too.

  • ptdheath
    6 posts

    I'm 220 hours, in nearly finished the main story and I have 3 Achievements to unlock 2 being story/completion based, and 1 being the twinkle twinkle achievement I've tried this 5 times now the last time I made sure to save after caching the fireflys, I then did a full shut down of my Series X and then clear the cache by unplugging the power cord. THIS DID NOT WORK!! 🤦♂️ I have now reloaded to before I released the last 2 fireflys. I have also found that after catching one in any particular place they are then no longer available in that location.

    Does anyone know any solutions, or if ubisoft are going to patch this issue?

  • UbiExcellent
    756 posts

    @carlos251962 No worries at all! Thank you so much for clarifying which Xbox console you're on. I'm happy to announce that our teams have found the solution to this issue with the "Disorder of the Ancients" achievement not unlocking, and will add it to a future update. We'll continue to post specifics about this here and on the game's official website, so please stay tuned!

  • Philipteodor
    1 posts

    I am having problems with the last Order of Ancient 'Disorder of the ancients' achievements and it won't unlock. I've now spent 116 hours I'm game, fully completed except this one achievement!! Can someone fix this?

  • GT40i
    21 posts

    Xbox One - To date, everything in game completed and all of the Order killed. This is the only achievement I require. Failed to pop on completion of criteria.

  • AquilaAssassin
    1 posts


    since the launch of the game I have had 2 achievements not complete when finishing the required steps to do so. First is the "Caladfwlch" Achievement that did not complete when I pulled Excalibur from the Stone. Second is the "Full Mastery" Achievement that did not complete even though I am Power 400 and have spent 21 Mastery Points (7 into each Mastery category: Raven Mastery, Wolf Mastery, and Bear Mastery).

    I just read the Title Update 1.1.2 for Valhalla and it doesn't mention either of these. Am I alone here or is this a known Issue? The Full Mastery one is heartbreaking that it bugged out, it took nearly 100 hours of gameplay to reach Power 400 and I would have to completely do that over again on a separate save just for 1 achievement, which sounds dreadful. I am not as worried about the Caladfwlch Achievement because I will be able to get that one when New Game Plus releases on my replay. But the other I cannot because every Mastery Point I activate doesn't complete it.

    Can someone elaborate on this? or fill me in on known issues related to this... Thanks

  • Legogameboy2012
    3 posts

    I have the exact same issue. This is the last secret achievement I have to unlock, but I've met all the requirements for it.

    The only achievement that's bugged for me is Disorder of the Ancients. It's one of the four remaining achievements I have left, but the only one of the four I have met the requirements for. I've had no other issues with achievements however.

  • Legogameboy2012
    3 posts
    This post is deleted!
  • PloughKing.
    5 posts

    @mikeonecl Same here, killed everyone and the achievement didn't pop on Series X

  • jeffertson1987
    11 posts

    Does any one no that the new patch fixt it ?

  • GameOfJawns
    1 posts

    New Patch finally fixed it for me, was able to get the last quest and unlock the last achievement

  • FreakzHS
    13 posts


    I really want to tell you about the "Builder" and "Tranquility" achievements which are still not unlocking for me even if my colony is level 5 and I've already made like 2 or 3 standing stone puzzles.
    I've tried many things to get them unlocked but they didn't work so far.

  • ZEROskater056
    4 posts

    The Hidden Truth did not unlock for me on Xbox Series X. I have every other achievement, so I know I completed it properly since it's required for the Completionist one. I also no longer have a save to reload and try the last one again on.

  • MarekQoops
    14 posts

    Patch 1.1.2 fixed the achievement "Disorder of the Ancient", if you met the requirement before and you log into the game it will unlock automatically. However that was the only achievement that got fixed. "Ultimate Refinement" achievement still not unlocking for me.

  • Rawiri1
    1 posts

    It's Alive! Builder and Face My Might! Achievements are all not unlocking for me on Xbox One X, I have completed the story and every area through over 150+ hours of gameplay. Overdesign II also has not unlocked after many hours of attempts, although I'm aware this achievement is tricky to complete regardless of bugs.

  • xIFoxHound
    49 posts

    Yeah I’ve got:

    full mastery
    overdesign 2
    skaldis hobby
    home sweet home
    flying Eivor
    twinkle twinkle
    godly reward

    im genuinely being serious, in my play through at 125 hours none of these achievements have unlocked or won’t let me unlock them on my play through and I really, really don’t have the time to do another full play through of the game to get these games (don’t even know if I’m guaranteed them anyways if I do another one)

    i’ve been asked by the support team to do something called port forwarding but I cannot because:

    A. I have no idea how to do it
    B. I don’t have a working laptop or pc in my home right now and it obviously doesn’t work through phone
    C. I haven’t had these issues in any other game regarding achievement unlocks...I mean surely Ubisoft connect could be feeding the data through to Xbox to unlock the achievements??? I have no idea how this all works but I cannot complete the achievement list (or rather I can’t commit another 100 +hours potentially just to get them) plus I’m still waiting for the Pig of Prophecy bug to be fixed to earn the completionist all the way achievement but at this point, why even bother with that one when all the others aren’t unlocking!

  • NodeadVicky
    10 posts

    Hello Team,
    First of all thanks to all ACV team for bringing this awesome game into our lives during these tough times. 🤗

    I want to report of the Xbox Achievements which are not getting unlocked even after so many patches (v1.1.2).
    I am playing ACV on my Xbox One X and following achievements are not unlocking:
    > Skadi's Hobby
    > Equine Attack
    > Twinkle Twinkle
    > Pioneer

    For the achievements 1-3 I can understand that i can replay the game with new game (may be i am waiting for New Game+ mode for this).
    If you fix this, that will be highly appreciated. It took a lot of time (200+ hours) to get there where I am and replaying all of that is just too much to ask.

    "Pioneer" is a story based achievement and it should be unlocked as I have "Completionist All the Way!" unlocked.
    How come the latter achievement gets unlocked even if former is not?

    Let me know if there is some fix needed or I can do something to trigger this?
    I have been to "Vinland" in and out so many times, got all the gears, finished it 100% but still no chivo. 😰

    BTW, I am always online while playing games.


  • Pepou-Pilou
    2 posts

    Pioneer still not unlocked 😞
    But the good news is the last update fixed Disorder of the Ancients. So now, Pioneer is the last achievement missing for me.

Suggested Topics