Welcome to discussions

Quick Suggestions

  • sn4kee88
    5 posts

    any response from Ubisoft?!!
    I can’t play this game with out achievements
    😠

  • Ubi-Borealis
    Ubisoft Support Staff 3529 posts
    Best Answer

    Hello there!

    I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein Xbox achievements were not unlocking correctly should be fixed in TU 1.2.1. This update was deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues with Xbox achievements not unlocking following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:
    - You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    - Images/video that show you have met the requirements for the achievement, but it still hasn't unlocked correctly for you in-game.

    Thanks all! 😊

    Official Response
  • Spartan19
    1 posts

    Had the same issue, just after establishing Ravensthorpe and before carrying out the first raid noted that I didn't get an achievement for the anomaly on the hill, then subsequently no achievement for the first raid or creating Jomsviking. Last achievement was the one for leaving Norway. Noted that ubisoft connect recorded the raid being completed. Completing a second raid didn't pop the achievement, nor did it increase the count on ubi connect.

    Just uninstalled and reinstalled the game, luckily had a save from the same point (just before first raid). Recompleted the anomaly, first raid and create Jomsviking, and achievements popped for each. Not looking forward to having to keep close track of every collectible being registered, or having to reinstall regularly, but happy I noticed early and have a work around. Could be a cache issue or something? I died loads but wasn't save scumming or swapping between games too regularly so unsure what the trigger might have been. Purposefully didn't open the xbox guide or ubi connect while getting the 3 missing achievements.

    Interestingly despite uninstalling, the armour etc I had picked for my Jomsviking held between each restart, even after reinstalling.

    For reference, I'm on an xbox one x, and playing from disc (it's the gold edition with season pass installed). Hope this helps someone.

  • ZeroOrDie453
    5 posts

    The Good Saxon achievement - Complete the East Anglia Arc (Secret) for xbox series x is not unlockable for me.

  • ghostwheel_og
    2 posts

    Some Achievements still not unlocking for me. I got 'The Saga Begins' and the 'To England' ones to unlock. but, others including the 'Rampage' achievement have not. I'm playing on the Series X just to clarify.

  • JK_Status
    8 posts

    Fix your damn game, no achievements unlocked still series x.

  • Omega914
    1 posts

    I've played Valhalla for about 18 hours, and I've noticed that some achievements aren't unlocking. I've completed over 20 world events, but the "Everyday Life" achievement is stuck at 30% unlock completion. I had to reload a previous save to unlock certain story achievements that also stuck. Browsing the player support forum and outside sites such as trueachievements, this is a common issue but there is yet to be an official response. Will this issue be fixed in a patch, or will all stuck achievements stay locked permanently?

  • SimoSims
    2 posts

    Before my data corrupted and I had to revert to a previous save 12 hours before, I'm on Settlement level 5 and haven't gotten any achievements for the game, knowing I HAVE completed those achievements in game.

    Please fix this immediately, I've lost 12 hours of game play and now no achievements. 50 quid of my pocket may seem like nothing to you, but it's a lot to me especially for a game that doesn't work.

  • NodeadVicky
    6 posts

    I am playing ACV Ultimate Edition on my Xbox One X.
    I am about to complete Chapter 2 but finding very strange that many of my achievements are still locked.
    To name a few:

    • Twinkle Twinkle (Release one FireFly before "In Dreams" mission)
    • Everyday Life
    • Equine Attack (Done 10+ times on multiple enemies)
    • Skadi's Hobby (Done 10+ times)
    • It's Not a Bug, It's a Feature! (Done 4 of them)
    • Full Mastery


    I am at skill level 130+ (can't remember exact) and have completed "Rygiafylke" and "Asgard" to 100% and no "Everyday Life" achievement.
    Even I am in England still "To England!" achievement does not unlocked.

    Am I missing something?

    Regards,
    NodeadVicky (GT)

  • james885
    10 posts

    @ubi-swaggins I have the same issue, I have been playing Assassin's Creed Valhalla Gold Edition disc on Xbox One for 16+ hours, but I still didn't get "The Saga Begins" achievement, based on the achievement guide, it supposed to be earned after complete the prologue, and I do not get the achievement. It let me feel the game was shipped in bad quality control.

  • ChampBanjo
    3 posts

    Skadis hobby achievement is bugged. I've slid down this mountain 100 times reloaded past saves closed the game entirely, restarted my Xbox and nada. Guess I'll wait for a patch.

  • sn4kee88
    5 posts
  • DrBrazilian
    1 posts

    I have not had some achievements unlock (on Series X) like "Rampage", how will I get it now??

  • ThGhostAssassin
    3 posts

    Same here on Xbox one x. Achievements aren't unlocking and this is getting really irritating especially considering not only is there buggy achievements with Assassin's Creed valhalla but also Watch Dogs legion. Come on Ubisoft you have enough [censored] off people in here already please respond with a timeframe on when a fix is expected. Until then no playing Ubi games.

  • dantewarrior007
    1 posts

    Same issue here on series x. Zero achievement Unlocked even after reaching England. Want my money back

  • PredatorZ98
    1 posts

    Love the game honestly one of my favourite if not my favourite assassins creeds (Ezio and shay are kinda legendary personally) and so far no issues with the game at all other than the achievement/progress tracking issue I’ve noticed a lot of other people suffering with.

    I understand other issues glitches or bugs might take priority right now (missions not loading/working as intended etc) however I my self have a few hours in this game and before I commit to anything more is there a potential update on this situation? Or rather a potential time frame in which we users can expect to see an update on this situation?

    Again I understand that it probably isn’t as priority as other issues just would like to know.

  • loxim
    2 posts

    Can confirm I'm having the same problem. Achievements stopped updated the progress for a few things in the world. Just killed second legendary beast but still stuck at 10%. Destroyed ninth cursed object but stuck at 80% still.

  • OldTiki
    5 posts

    Hi guys, I’ve done some testing over the past couple of days with achievements not unlocking. It would seem that the base game has no issues and it is the DLC being the problem (yet to determine which one is causing the achievements to remain locked).

    however, if you are wanting to unlock the achievements uninstall ALL DLC from your system and (unfortunately) start a new game as your previous save data will have saved it assuming the DLC (and thus the glitch) still being there.

    This unfortunately means you’ll be playing the base version of the game and not the gold or ultimate edition like you (and also I) paid for.

    either this needs to be patched and Ubisoft look into why the DLC does this and soon or I’d like to be reimbursed the difference between the base game cost and the ultimate.

    essentially what’s gone on here is the base game has had no problems with achievements and been green lot for release then the DLC has been added to both the gold and ultimate editions without testing whether or not they affect the overall product.

    I would recommend stricter testing policies with Ubisoft’s products as I’ve scoured the internet and it seems I’m one of the first to actually find the cause and the solution.

  • Lythimer
    4 posts

    @oldtiki I got the base game and I have this issue. 😞

  • OldTiki
    5 posts

    @lythimer

    mmm, well that’s a wrench in the works. My solution works for my ultimate edition. I’ve tried several things to get the achievements to pop:


    resetting personal network and Xbox system to clear cache

    unlinking Ubisoft connect account and re-linking

    uninstalled and reinstalled

    I’m sure you’ll have tried these already but I’m afraid I don’t have the base version of the game.

    Did you download or do you have it on disk?

    I did my trouble shooting by watching the achievements %’s over the past few days and people ARE unlocking them in a consistent fashion so it’s a localised problem and not an all round issue.

    I hate to suggest it (I had 30hrs playtime on mine) but have you completely deleted your save files both on consoles and on the cloud, reinstalled and started anew? Drastic I know but if you’re wanting them to pop it might be the only option before a patch is made.

  • EvieLeaf
    5 posts

    @oldtiki

    I also have the ultimate edition and have tried everything you listed and they're still broken for me.

    I would not recommend this as a solution to anyone, it's false hope more than anything else. The folks over at TrueAchievements have found some things start working for some and don't work for others. You have just been lucky that you found a solution for yourself.

    @Ubi
    I've stopped at 2hours gameplay with extra time for testing and I will not be playing this or Watch Dogs until Ubisoft does something. This is really unfortunate because I really enjoy these franchises and was looking forward to something new to play on the Series X.

    Could we at least get some acknowledgement here that there is an issue and the team is working on it?

    Thanks!

Suggested Topics

Community Details

125
Online
190.9k
Users
31.8k
Topics
160.6k
Posts