Welcome to discussions

Quick Suggestions

  • Lythimer
    4 posts

    @oldtiki I got the base game and I have this issue. 😞

  • Ubi-Borealis
    Ubisoft Support Staff 3561 posts
    Best Answer

    Hello there!

    I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein Xbox achievements were not unlocking correctly should be fixed in TU 1.2.1. This update was deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues with Xbox achievements not unlocking following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:
    - You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    - Images/video that show you have met the requirements for the achievement, but it still hasn't unlocked correctly for you in-game.

    Thanks all! 😊

    Official Response
  • OldTiki
    5 posts

    @lythimer

    mmm, well that’s a wrench in the works. My solution works for my ultimate edition. I’ve tried several things to get the achievements to pop:


    resetting personal network and Xbox system to clear cache

    unlinking Ubisoft connect account and re-linking

    uninstalled and reinstalled

    I’m sure you’ll have tried these already but I’m afraid I don’t have the base version of the game.

    Did you download or do you have it on disk?

    I did my trouble shooting by watching the achievements %’s over the past few days and people ARE unlocking them in a consistent fashion so it’s a localised problem and not an all round issue.

    I hate to suggest it (I had 30hrs playtime on mine) but have you completely deleted your save files both on consoles and on the cloud, reinstalled and started anew? Drastic I know but if you’re wanting them to pop it might be the only option before a patch is made.

  • EvieLeaf
    5 posts

    @oldtiki

    I also have the ultimate edition and have tried everything you listed and they're still broken for me.

    I would not recommend this as a solution to anyone, it's false hope more than anything else. The folks over at TrueAchievements have found some things start working for some and don't work for others. You have just been lucky that you found a solution for yourself.

    @Ubi
    I've stopped at 2hours gameplay with extra time for testing and I will not be playing this or Watch Dogs until Ubisoft does something. This is really unfortunate because I really enjoy these franchises and was looking forward to something new to play on the Series X.

    Could we at least get some acknowledgement here that there is an issue and the team is working on it?

    Thanks!

  • OldTiki
    5 posts

    @evieleaf

    Well I’m sorry for getting your hopes up folks.

    I honestly tried everything since encountering the problem on the 13/11/2020 and my posted solution was the only thing that worked but I guess it’s not a complete solution.

    Out of interest do you have ANY DLC at all installed?

  • EvieLeaf
    5 posts

    @oldtiki

    I had it all installed and none installed. The only time I got an achievement was when I actually had all DLC installed then it suddenly stopped tracking. Uninstalling and reinstalling (without DLC) on a new save has not helped either unfortunately. Just stuck in this achievementless limbo 😞

  • OldTiki
    5 posts

    Strange that it would work for myself and not for you following the same steps with the same edition.

    it’s all the same data mass produced so it must be a localised issue on your end. I’m at a loss of what to suggest if none of my advice has helped. It could just be that waiting on a patch is your best bet.

    I’m sorry nothing I suggested has worked for you, I stopped playing the game when I found out achievements weren’t working until I could find a fix.

  • ThGhostAssassin
    3 posts

    I'm having issues with a couple achievements not unlocking. Listed below are the ones not unlocking so far:

    Witch Hunter - Completed this list night and no achievement

    Equine Attack - I've done this multiple times and nothing unlocks

  • EvieLeaf
    5 posts

    @oldtiki

    I really don't think it's fair to say this is a localised issue. This is clearly impacting a lot of people, you can see there is a lot of people complaining about this on TrueAchievements.

    I have enough games in my backlog to be patient, Assassin's Creed is one of those few games I play straight away but with the save corruption issue as well, there's no way I'm playing this game until it's fixed.

  • OldTiki
    5 posts

    I don’t mean ‘localised’ as in just yourself or others systems or by any means a fault on your end. I meant to communicate that there must be a disconnect between your profile/Ubisoft. Be it with Ubisoft connect or the information just not being sent.

    It would seem that a patch is your best course of action at this point if everything has been tried and tested.

  • xW4LMSL3Yx
    1 posts

    I've been sprint bashing my way through breakable objects like it's going out of fashion; I must have done it over 500 times by now, but the achievement has still not unlocked.

    Is this a known issue? any ways to try and resolve it?

    Thank You

  • Lythimer
    4 posts

    @oldtiki I have the digital version. I don’t really want to try to delete all my saves and restart because I doesn’t have the certitude that this problem will never occur again. Losing 18 hours of gameplay is no fun, losing another one will provoke a permanent delete do the game! 🙂

  • Moulsdale
    2 posts

    Same problem here

    I’m on series x and this is my first big game which is a disappointment. I love this game but the achievements not working is souring it for me. 24 hours game time I’m already and have some achievements but they all seem to have stopped unlocking.

    Anyone heard anything at all from ubi? I just got through on their live chat and he said he couldn’t sort it on chat but would follow up email me - this was some email about sorting connectivity issues on Xbox one which is not what I needed?!

  • Moulsdale
    2 posts

    Apologies for double post but it apparently only allows me to edit posts for up to ten minutes after making them.

    Just had another live chat with ubi who tell me it’s not their issue and is not within their influence to fix. Directed me to Xbox support.

    A little disappointed to say the least

  • Ubi-Spud
    Ubisoft Support Staff 702 posts

    Hey there! We are aware of issues with achievements unlocking and are looking into it at the moment. I do not have a workaround at the moment, however your patience is really appreciated.

    Official Response
  • EvieLeaf
    5 posts

    @moulsdale

    Seems like Ubisupport doesn't know what it's doing.

    They've messaged this tread saying they are aware of the issue and they're looking into it.

    https://discussions.ubisoft.com/topic/81596/achievements-still-not-unlocking-on-xbox?lang=en-US

  • BagsofFlavour
    6 posts

    "Witch Hunter" and "Equilibrium" not unlocking as well for me, even though I got the "Godly Reward" one, killed all three witches and did atleast 5 Cairn challenges by now. "Old School Treasure Hunt" doesn't seem to be progressing as well. Playing on Xbox One X

  • Killrog01
    15 posts

    @guest-zjbfizaj I've made the same observations as you.

  • Sp33dyKat
    8 posts

    Add me to the list. No achievements received after the prologue one.
    Playing digital standard edition game with season pass installed. Playing on an Xbox Series X.
    Really enjoying the game, but am wondering if I should stop until we receive an achievement fix. Decisions, decisions. 😕

  • NathanielG
    1 posts

    Achievements aren't popping for me...60+ hours into the game and didn't really notice as was enjoying so much but now that I have, super annoyed! Ubisoft please get this fixed ASAP...and not a fix that requires me going back over the last 60 hours

  • Shi00kami
    2 posts

    The Achievments "The Good Saxon" and "Equilibrium" do not unlock on Xbox Series X/S

Suggested Topics

Community Details

119
Online
191.4k
Users
32.1k
Topics
161.2k
Posts