ubisoft discussions

Quick Suggestions

  • NodeadVicky
    10 posts

    I had issues with other achievements (mostly story based) which were not unlocking like:

    • To England!
    • Rampage
    • Everyday Life

    and some more. But I got these while in a loading screen, one month after completing the requirements.
    Maybe after patch v1.1.1 (but I am not sure).

  • Dane_Wafer
    3 posts

    Playing on xbox series x
    So far face my might and tranquility aren't unlocking for me.

    Would it be possible to get an eta on fixes for all of the broken achievements thank you

  • xIFoxHound
    49 posts

    @nodeadvicky Yeah there’s been some instances where I’ve had that with some games but it’s only ever been a couple of days until they popped...this has been about 2 months now and I honestly don’t want to do another play through, it’s not my favourite Creed game and the bugs and issues like this have further exaggerated that. I will revisit when they have patched and hope that the issues are fixed

  • SDOT2009
    2 posts


    current 160+ hours in to the game and I have noticed I wasn’t getting achievements when complete the arch story’s or the secret achievements. I don’t really want to play the whole game again just to get these. When will this be fixed? Playing on the series’s X

    only just noticed I wasn’t getting any off the arc achievement or the secret achievements which are link to the story and I have only 2 members of the order left so pretty much almost finished with the story. When will this be fixed as I am 170+ hours in and don’t really want to start a fresh game. Playing on the series X

  • SDOT2009
    2 posts
    This post is deleted!
  • FirebirdUK3
    11 posts

    @sdot2009 glad it's not just me with that issue. I've raised an issue with support, I've had to send proof of my claim. Waiting to hear back.

    None of the arc achievements have popped, or the Witch Hunter one, or Tranquility.

  • Lok787
    2 posts


    The achievement unlocked when i entered the game after the latest patch 🙂

    Thank you

  • carterquincy
    4 posts

    As of 2/28/21 this achievement has still not unlocked for me. I have two standing stone puzzles left and this is the only thing keeping me from completing the game.

  • UbiExcellent
    756 posts

    @lok787 That's wonderful to hear! Thank you kindly for following up with us about this achievement unlocking successfully following TU 1.1.2. 😊

  • UbiExcellent
    756 posts

    Hey folks! I'm very sorry for the lateness of my reply here, but I appreciate you all keeping this thread updated. Are any of you missing additional achievements, or is "Tranquility" the only achievement impacted?

  • Dane_Wafer
    3 posts

    @Ubi-Woofer can you provide an update?

  • Ubi-Woofer
    1334 posts

    Hello everyone,

    To my knowledge, the issue whereby the "Disorder of the Ancients" achievement would not unlock on Xbox was fixed as part of the TU 1.1.2 update in February. I am happy to see that several players have reported back that this is indeed the case since then! If, however, you have continued to be unable to unlock this achievement since the patch, please let me know so that I can reopen the investigation and make the developers aware of this. I will need to pass forward current reports from players impacted since the deployment of TU 1.1.2 for their perusal.

    Currently, the team are investigating the "Ultimate Refinement" and "Caladfwlch" achievements, and we have also reported the following as not working correctly for some players:

    • To England!
    • Builder
    • Everyday Life
    • Face My Might!
    • Not The Norse You're Looking For
    • Home Sweet Home
    • Twinkle Twinkle
    • Full Mastery
    • Pioneer
    • Slam Master
    • Tranquility
    • Orlog Champion
    • Archeologist
    • The Hidden Truth
    • A Picture of Grace
    • Skadi's Hobby
    • Overdesign II

    If the achievement you are struggling to unlock is not listed above, please reply with a video demonstrating your eligibility to have unlocked the achievement, as well as it remaining locked on your Xbox profile, and we will gladly pass forward your report and look into the issue more closely with you.

    As before, please submit your reports in the following format in order to make them easy for us to pass forward and track:

    • Platform, including Xbox model (ie. specify if you play on an Xbox One X / S, or a Series X / S etc.)
    • Achievements not tracking / unlocking correctly
    • If you are playing on multiple platforms via cross-platform progression, which other platforms you play on

    Thank you. 🙂

    @Girish90M - Could you please clarify the platform you are experiencing these achievement issues on please? Additionally, the developers have been unable to reproduce the issue with Cola's portrait appearing as a scroll in the latest update. If you're still experiencing this issue, could you please open a separate thread for this and include a video showing the issue there? Thanks!

    @xIFoxHound - Story-based achievements should unlock after you complete your next quest or arc, while repeatable actions normally need to be done again on a new platform in order to be unlocked. My best advice would be to try and unlock these again manually on your Xbox console, and if issues still persist, let us know exactly which achievements are failing to unlock for you, despite you completing the required actions on that console itself. You previously provided me with a short list of missing achievements, but stated on February 13th that you're missing ten - can you clarify whether your latest post listing the eight is the most recent state of your missing achievements? Finally, regarding port-forwarding, you should contact your ISP (Internet Service Provider) if you're struggling with this. They should be able to help you get this set up and allow us to verify the issue is not local. 🙂 Thanks!

    @CaffeineJunkiee - Which specific achievement are you missing, and which Xbox generation are you playing on please?

    @Raedz - Please provide a full list of the achievements you are missing so that I can send an accurate report to the developers. 🙂 I've so passed on the achievements you mentioned in your previous post, but it would be appreciated to know the further ones you are missing. Thanks!

    @konzhuk - If your issue with the Beowulf questline is not resolved, please seek out an appropriate thread for the issue you are experiencing and reply there to report your experience of the issue. Thank you!

    @ptdheath - Which are the two story-based achievements you are struggling to unlock please? Regarding Twinkle Twinkle, are you releasing the fireflies in the correct location in your settlement near Valka's Hut?

    @FreakzHS - Can you please confirm the platform you play on, as well as provide images showing your settlement level / cairns completed if possible? Thanks!

    @NodeadVicky - For the Skadi's Hobby, Equine Attack and Twinkle Twinkle achievements, these are not linked to any particular part of the story and the requirements can be met at any time, so long as you fulfil the action itself. If you repeat attempts for these actions, and find that they do not unlock, a video demonstrating this would be much appreciated so that we can take a look.

    @Dane_Wafer - I am unable to provide any ETAs regarding fixes as these have not yet been confirmed. Additionally, as these achievements are unlocking for other players, they're taking a little while for the developers to investigate. Thank you for your understanding in the meantime.

    @SDOT2009 - Please can you clarify the exact achievements you are missing? I can then pass forward your report to the developers. Thank you.

    @carterquincy - Which achievement are you referring to please? Which platform do you play on as well? I checked in my previous list of reports however I could not find your name, so I just want to confirm the details with you. Thanks!

  • guest-UutlMFCq
    1 posts

    I raised a ticket with Ubisoft support over the achievements that won't unlock for me - ticket number 14121568. After about a week, I had a reply asking for me to send proof of the issue. I sent some screenshots from the game and from Ubisoft connect, to date I've heard nothing back. It's also disappeared in my list of cases...

    Witchhunter hasn't popped for me, despite killing all 3 (showing in Ubisoft connect). None of the arc achievements have popped (I've completed them all).

  • Blauman619
    6 posts

    I was going through my achievements today to try and finish them and noticed I had a "secret achievement" that had not popped yet. After ruling out all the other secret achievements "Godly Reward" is not popping for me despite having all of Thor's armor as well as already gotten Mjolnir and the accompanying achievement "Worthy"

  • Yrag86
    2 posts

    Finished the game last night, thankfully the only achievement that I cant unlock is "Not The Norse You're Looking For". Going to try speeding through the prologue to get to England, see if it unlocks in a new game.
    Once I was aware there was an issue with achievements I ended up creating a new save at the end of every chapter so I could go back and reload if necessary.
    I did have an issue with the "Witch Hunter" achievement but I spotted it reloaded a earlier save and beat the 1st witch and it unlocked no problem.
    Playing on the Xbox series X, and as I've said previously. At the time the 2 achievements didnt unlock my console was struggling to connect to the internet / ubisoft connect.

  • halder001
    7 posts

    completed everything in the game, spent all normal skill points and 60 mastery points.

    achievement has still not unlocked.

    tried reloading old saves and using mastery points again, saving/ reloading. still nothing.

    anyone else had an issue with this achievement or know of a fix?

  • Ubi-Keo
    Ubisoft Support Staff 4278 posts

    @halder001 I'm sorry to hear that this achievement has not unlocked for you. We have received several reports from other players who have experienced the same issue with this achievement.

    This has been reported to the dev team who are investigating.

    Official Response
  • halder001
    7 posts


    good to know I'm not on my own. hopefully patched in an update soon.

    thanks for the reply.

  • DrGlee
    3 posts

    Finished the storyline and played offline primarily - noticed that most of the achievements haven't triggered - really disappointed that I've invested 90+ hours in the game without gaining achievements.

    Those I can see that I should definitely have:

    We're in the Endgame Now - (I'm already well over level 280)
    Home Sweet Home - (settlement completed)
    Face My Might! - (equipped all abilities and all are unlocked)
    Ultimate Refinement - (upgraded several weapons to max)
    Calling in a Favor - Story, why hasn't this triggered?
    The enemy of my enemy - Story, why hasn't this triggered?
    As it was Foretold - as above
    England Subdued - as above
    Pioneer - as above

    There may be more, it's just not tracked properly.

    Playing on Xbox One X

  • guest-G9PJQ9Ge
    2 posts

    Anyone else have this happen? The legendary moose in Vineland is killed but at raventhorpe it never shows u found it or rewards you. And Iv noticed if u travel back to the location, you can see it from afar, and it floats in the air and then collapses again. The body just remains there. I never can finish killing all the legendary animals for the hunter in raventhorpe and get the reward. I play on the Xbox one so maybe it’s just for that system ?

Suggested Topics