Welcome to discussions

Quick Suggestions

  • EvieLeaf
    5 posts

    @moulsdale

    Seems like Ubisupport doesn't know what it's doing.

    They've messaged this tread saying they are aware of the issue and they're looking into it.

    https://discussions.ubisoft.com/topic/81596/achievements-still-not-unlocking-on-xbox?lang=en-US

  • BagsofFlavour
    6 posts

    "Witch Hunter" and "Equilibrium" not unlocking as well for me, even though I got the "Godly Reward" one, killed all three witches and did atleast 5 Cairn challenges by now. "Old School Treasure Hunt" doesn't seem to be progressing as well. Playing on Xbox One X

  • Killrog01
    15 posts

    @guest-zjbfizaj I've made the same observations as you.

  • Sp33dyKat
    8 posts

    Add me to the list. No achievements received after the prologue one.
    Playing digital standard edition game with season pass installed. Playing on an Xbox Series X.
    Really enjoying the game, but am wondering if I should stop until we receive an achievement fix. Decisions, decisions. 😕

  • NathanielG
    1 posts

    Achievements aren't popping for me...60+ hours into the game and didn't really notice as was enjoying so much but now that I have, super annoyed! Ubisoft please get this fixed ASAP...and not a fix that requires me going back over the last 60 hours

  • Shi00kami
    2 posts

    The Achievments "The Good Saxon" and "Equilibrium" do not unlock on Xbox Series X/S

  • Killrog01
    15 posts

    @moulsdale I do not believe that Microsoft's is to be blamed here. Not only there's no issue with any other game (save perhaps PoE but this game is bugfest), but this problem of achievement not unlocking isn't new, maybe you didn't encounter it, but I remember clearly facing an identical situation when the first episode of the second DLC for Odyssey released. The achievement for destroying all statues of Persephone was locked, exactly like what's happening now. So I wouldn't be surprised if the same erroneous line of code got copied / pasted a bit too hastily within this new game.

  • AlisonPrime
    2 posts

    I have now run into the issue of an achievement not unlocking and this one... makes me want to just give up on the game entirely for how long it took me to get. It is the Achievement "We're in the endgame now." which requires you to reach a power level of 280. This takes a VERY long time and unlike Skadi's Hobby, or other achievements, this one isn't so simple as uninstalling your game and restarting because it takes 50+ Hours to reach power 280 and it could glitch again on a new game without you knowing. I hope to god ubisoft is reading this and will fix the issue.

  • DemonI81
    16 posts

    @ubi-swaggins

    Really? Maybe check the achievement sites... they're riddled with people reporting issues with most achievements.

    Myself, so far, only Twinkle Twinkle has not unlocked after I released a firefly in my camp at the waterfall, but there's tons of reports out there of these issues on Series X (for me) and the One as well.

  • DemonI81
    16 posts

    @ubi-spud

    We'd be a lot more patient if the devs would speak and confirm they are working on the myriad of issues with this game. It's probably the worst AAA launch (bug wise) that I've experienced in years.

  • abale
    5 posts

    I have finished the game (main story and quests, just side missions/collectables to go)

    Achievements that should have popped but didn't (these need fixing for sure)

    1. Builder - Reach Settlement 3 - completed all settlements and not unlocked. My sister has this unlocked but she has an Xbox One not Series X and started playing later.
    2. Face My might - Equip 8 Abilities - Tried removing and adding 8 again and still not unlocking
    3. Twinkle Twinkle - As per mission with town's seer I did release one, if that's the one then it should be unlocked too? right?
    4. Hard Choices - I believe this is an automatic story one but failed to unlock. Also took a ride mission here at the end with that map woman where she kisses and runs back to village afterwards.


    Achievements I'm not sure of yet as not yet completed that part (could be fine but few might already be questionable)

    1. Dreamcatcher (30% at 3 done so should be fine)
    2. Orlog Champion (26% and some done so should be fine)
    3. Old School Treasure Hunt - 0% unknown
    4. Skadi's Hobby
    5. Equine Attack
    6. Overdesign II
    7. Completionist All the Way
    8. Flying Eivor
    9. Archaelogist - 0% still yet I have handed in the first amount of roman artifacts, might not be a good sign.
    10. Good Catch - 0% have caught a few different types but not all yet, should the percentage have gone up already?
    11. Full Mastery
    12. Is Anybody out There?
    13. Slam Master - 0% and level 5 Carisma so done quite a few, not all though.
    14. Master Hunter
    15. The Hidden Truth
    16. Caladfwlch
    17. A Picture of Grace


    Achievements that definitely worked for me and have unlocked fine.

    1. Worthy
    2. Disorder of the Ancients
    3. Home Decor
    4. England Subdued
    5. Equilibrium
    6. As it was foretold
    7. Home Sweet Home
    8. Row Rage
    9. Silent Viking
    10. Seahorse
    11. The Enemy of my Enemy
    12. We're in the End Game Now
    13. Godly reward
    14. Witch Hunter
    15. In the Footsteps of the Gods
    16. Calling in a Favor
    17. Ultimate Refinement
    18. Take My Hand
    19. It's Alive
    20. Tranquility
    21. Pioneer
    22. The Order is Revealed
    23. The Good Saxon
    24. It's not a bug its a feature
    25. Everyday Life
    26. Not the Norse you're looking for
    27. Rampage
    28. To England
    29. The Saga Begins



    Thanks will update as I achieve more or fail too..

  • AlisonPrime
    2 posts

    @alisonprime Update to my post - Endgame still did not unlock even after uninstalling the game, reinstalling the game, undoing all my skill points, and redistributing them to different points. I did however unlock Is there anybody out there? so achievements are not completely borked on my save. So far the only 3 I cannot unlock and have a modicium of difficulty unlocking is

    1. We're in the End Game Now - Reach power 280 (Foreeeeever)
    2. Skadi's Hobby - I have slid down a 180m mountain in norway 8 times now - Yes in the snow.
    3. Overdesign II - I have gone to Hamtunscire 5 times now, got 4 shield bearers to 1 arrow from death, stood IN THE FIRE, and killed all 5...nothing. Yes they have Skulls next to their name so they're considered hard difficulty.


    I have not progressed the story as I been focused on clearing the map, getting strong so I can just breeze through the story like I did in Odyssey. I Hope these 3 achievements are fixed in an update, in a way that does not require to restart the whole blasted game. Maybe add a trigger for End game that only requires you to reset you skills and redistribute them. I dunno how achievements work, but I do not want to spend 60+ hours grinding to this level of power again ; - ;

  • LazyMastodon
    1 posts

    I have played now over 10 hours on X series X and not a single achievement not even the prologue or first raid. Nothing at all. Ubisoft can you acknowledge this issue and when will you sort this out?

  • standoffjosh
    77 posts

    @lazymastodon I’m experiencing similar issues also 😔

  • standoffjosh
    77 posts
    This post is deleted!
  • young_russ
    3 posts

    Hi first of all fantastic game.
    I too are missing many achievements not had a progression achievement since the good saxon, and i am way past that
    Also missing rampge/ equinne attack/ home decor.
    Btw my power is 165 so you can see how far i am in the game.
    Hope to see a fix for this soon,or some some of answer from Ubisoft

  • young_russ
    3 posts

    It seems that the Achievements are just not tracking at all i have zero % of cairns when i have done one, just released the firefly my settlement nothing, missing also rampge/ equinne attack/ home decor i have had no progression achievements since east anglia one achievement dropped for me yesterday witch hunter but this is a very long game so completionist is now out of the question for me

  • Ubi-Raziel
    Ubisoft Support Staff 197 posts

    Hello everyone!

    We have recognised that this is an issue and our QA team are currently investigating why this affects some players. So far we have not experienced any issues in a testing environment, but testing will continue and we'll let you know if we have any questions!

    In the meantime, the following support article may help some of you: https://ubi.li/2Oq0I

    Official Response
  • DJ-NES
    2 posts

    Hi,

    More than a few achievements are refusing to unlock after completing the requirements in my save.

    "England Subdued" - All quests have been completed in game.
    "Disorder of the Ancients" - All order and zealot members are dead.
    "Equine Attack" - Refuses to unlock no matter how many enemies or type i assassinate off horseback.
    "Caladfwlch" - Currently wealding this item and the achi won't pop.
    "The Hidden Truth" - All fragments have been completed and the video played upon reaching the 10th with no unlock.

    Due to waiting on a patch to fix the unsummonable sister, i have no clue if i will have issues with the Thor and Full completionist achis but yeah, tad annoying.


  • Si_W
    29 posts

    @ubi-raziel

    I've been playing cross play, mainly on PC but then continuing on PS4 in another location.

    The Builder achievement just popped on the PS4 when I got Ravensthorpe to level 3 but nothing else, so clearly don't pop based on your saves.

Suggested Topics