Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • hallux_20
    2 posts

    Minor spoiler...... Can't interact with Tove the the girl that replace Svend. There was no issue with Svend but there is no icon over Tove's head... Very frustrating!

  • Ubi-Borealis
    Ubisoft Support Staff 2111 posts
    Best Answer

    It's great to see that this fix has helped so many of you! If anyone is still unable to interact with Tove, please ensure that you try these steps first:

    • Try to talk to Tove
    • Create a manual save
    • Shutdown the game and relaunch it (Desynchronizing, reloading a save, or returning to title screen is not enough)
    • Load the manual save created above and check that a cloud save has been created
    • Close the game again, then load up the cloud version of the manual save that was made previously.


    You should now be able to talk to Tove again! If you're still unable to interact with Tove after following these steps, please don't hesitate to update the thread so we can take a closer look. Thanks all! 😊

    Official Response
  • SirSitsWithTits
    6 posts

    I'm having the same issue. Unable to speak to Tove and the completed quest is missing. The issue has not resolved over time. I’m getting it on both Xbox one s and Xbox series x. Need a resolution ASAP since it sucks being stuck with a character configuration when you have bought tattoo and hair mods.

  • SkittyKitty21
    2 posts

    Building the tattoo hut before talking to tove about sveneds death bugs getting to talk to her after finishing her dialog at grave site

  • StigsLeftFoot
    1 posts

    @Ubi-Woofer I too am having issues talking to Tove after completing Carrying the Torch with 1.1.1 installed. Any assistance is greatly appreciated, customizing Eivor is one of my favorite parts of the game and without access to tattoos I feel a lot less desire to play the game.

  • guest-fApcfOWt
    2 posts

    I can’t even speak to Tove! And that just the beginning of these bugs! Uuuuuggghhhhaaa. And the frustrating thing is that is is a great game! Good story line, action, drama, and I want SO BADLY to love it! But the fu**ing BUGS! Ubisoft, holy crap, fix this [censored]!

    Ubisoft figure it out man! This game could be legendary if you guys had actually put the time and care into it that it needed. I get it, almost all games have bugs, but this... this is like an infestation. Someone call Orkin and get this crap handled. What so frustrating is, as someone who loves a good story, AC VALHALLA IS A GOOD STORY, but all these bugs and half-[censored] short cuts are fu*cking it up! I want this to be my favorite AC, I really do. It’a unique, and with all the Viking rage that has been building in the media the past five years this could and still can be a really big hit if you guys can just get your [censored] together!

  • RKO-Cutter
    1 posts

    And a +1 for me as well, really frustrating as I had a bit of a plan to change Eivor's appearance little by little as I progressed through the game

  • zullfiqar
    2 posts

    @munki909
    Got the same issue, cant interact with her now for days... The Torch quest cant be found in completed quests either.

    Anyone found a fix for this??
    Does Ubisoft know about this??

  • Forrest008
    1 posts

    I cannot fathom how an update breaks such a major component of the game. It's the same for me on PS4. I bought a sweet piece of hair...and would like to use it.

  • WhimsyxxWingsy
    1 posts

    Tova is bugged in new patch. I can't speak to her to change tats or hairstyles. Any ideas on how to fix? Because so far I am not impressed with how crazy bugged this game is so far.

    .

  • Aeric92
    2 posts

    @Ubi-Woofer it seems you're the person to reach out to. I, like MANY others it seems, cannot interact w/ Tove following the "Carrying the Torch" quest. Cant customize my appearance at all, which is a bummer seeing as how the patch notes specifically say you guys addressed this. Im well over 40 hours in and I want to be able to use all of the features I paid for when buying the game. My case # is 13882245

  • NBRuJa2
    4 posts

    Same here. Cannot talk to Tove after Svend's dead...

  • Joselfie
    3 posts

    I'm having the same issue. To provide more context, I had built the tattoo shop right after I finished talking with Tove at Svend's grave. I don't know if it would make a difference if the shop was built before that event or not.

  • Daddy2591
    1 posts

    I have the same problem on PC. I know that after completing the quest, it moved to the "Completed" section, but now after seeing your comments and searching for it, it's not there anymore.

  • NBRuJa2
    4 posts

    Another one here with the same bug. Its really annoying so many bugs in this game. Since Unity I don't remember such a broken assassins

  • LoezRnd
    7 posts
    This post is deleted!
  • roballmighty84
    1 posts

    I have the same problem on PC, I build tattoo shop after Svend died, finished the quest Carrying the Torch and now there is not possible to talk to Tove and get tattoos

  • LoezRnd
    7 posts
    Same problem on PS4, after the mission "passing the torch" I can't interact with Tove at the tattoo shop / barbershop.


  • skywalker550
    1 posts

    Same here on PS5, I guess this happens to everyone.

  • AceZim57
    7 posts

    I am having the same issue for days now. I built tye tattoo shop before his death, carrying the touch quest says complete, but i can not talk to her at all in the shop. No icon pops up to talk either.

  • Rodrilia
    1 posts

    After completing this side quest, Tevo doesn't give me the option to speak to her. This is actually really annoying, because now I'm unable to change my beard and tattoos. I've tried everything; reloading other saves, changing location, meditating, sleeping and yet nothing happens. It seems this is a common bug among EVERY CONSOLE/PC and since customizations are a huge part of the experience, I hope it gets solved soon.

    Btw, there's also another annoying bug that duplicated my huntsman armor on my storage, and now it takes two slots instead of one.

    I really love this game, but the fact that I can't change the look of my Eivor is frustrating since now I have tons of cosmetic I won't be able to try out. PLEASE FIX THIS


    (Playing on Ps5 but as I said this happens in every platform)

Suggested Topics

Community Details

64
Online
129.8k
Users
22.4k
Topics
116.4k
Posts