ubisoft discussions


  • locked topic_solved [RESOLVED] Unable to interact with Tove after completing "Carrying the Torch"; quest missing from log | POST HERE

    8 likes/280 replies/7442 views
    ubisoft:x-posts, 3

    Same here on PS5, I guess this happens to everyone.

  • AceZim57
    ubisoft:x-posts, 7

    I am having the same issue for days now. I built tye tattoo shop before his death, carrying the touch quest says complete, but i can not talk to her at all in the shop. No icon pops up to talk either.

  • Rodrilia
    ubisoft:x-posts, 1

    After completing this side quest, Tevo doesn't give me the option to speak to her. This is actually really annoying, because now I'm unable to change my beard and tattoos. I've tried everything; reloading other saves, changing location, meditating, sleeping and yet nothing happens. It seems this is a common bug among EVERY CONSOLE/PC and since customizations are a huge part of the experience, I hope it gets solved soon.

    Btw, there's also another annoying bug that duplicated my huntsman armor on my storage, and now it takes two slots instead of one.

    I really love this game, but the fact that I can't change the look of my Eivor is frustrating since now I have tons of cosmetic I won't be able to try out. PLEASE FIX THIS

    (Playing on Ps5 but as I said this happens in every platform)

  • Ripper2O3
    ubisoft:x-posts, 5

    For those of you with the issue with Tove, I've been on Live chat with support today and the issue is being investigated.

    Hopefully it doesn't take too long to fix, as @Makhnovtchina mentioned it's a much smaller scale issue than all NPCs being affected.

  • Jordxox
    ubisoft:x-posts, 2

    I can't interact with Tove in the hair/tattoo shop. I completed the quest with Sven, spoke to his grave. Went to sleep in the long house, restarted the game, shot her ij the head, smashed the shop up. Still nothing.

    The key for the Maximillian quest won't show up either. It comes up with the key symbol indicating it should be there, on the stool, but it's

  • Jordxox
    ubisoft:x-posts, 2


    I completed the quest where Sven dies, but I can't interact with Tove.
    I've spoken to his grave, slept in the longhouse, restarted, shot Tove in the head, smashed the place up...all recommendations lol, nothings worked.

    The key for the maximillian quest hasn't appeared either, even though there is a key symbol on the stool.

    Super buggy game. The update didn't do much for me, for some reason. Any advice

  • AceZim57
    ubisoft:x-posts, 7

    Completed carrying the torch quest, but can't interact with Tove at all. Ive slept in the long house, meditated, deleted and redownloaded the game, NOTHING. This game is still crashing on me also even after the update.

    ubisoft:x-posts, 2

    Same for me

  • Lajarai
    ubisoft:x-posts, 1

    So once you have spoken to tove at the burial ground. You can no longer talk to her so don't have access to be able to change your eivors appearance. Anyone else having this issue

  • Krofenss
    ubisoft:x-posts, 2

    @darkcat3 hey dude, any update on this? I hace the game bug

  • Sammarok
    ubisoft:x-posts, 177

    @lajarai Same here, she doesn't want to talk to me anymore.

  • Krofenss
    ubisoft:x-posts, 2

    @venatrixlupa me too

  • Zer0524
    ubisoft:x-posts, 10

    hello there since the latest update i cannot speak to tove. i have plenty of tattoo designs i want to try out and hairstyles i want to apply but i can't. she is sitting in the tattoo shop already after i finished the quest "carrying the torch" but there is no bubble above her head, i cannot interact with her in any way to customize my character. it's pretty frustrating, i've heard more people encountered this bug after the latest update was deployed. before the update it worked for everyone. any idea when some hotfix could be deployed for it? i want to continue my game but not like this.

  • Dannyo91
    ubisoft:x-posts, 1

    I can't or speak with Tove after completing the "Carrying the torch" quest. There's no interact button prompt. Tried bumping into her but she just gets up and then sits back down again.

  • Krisss31
    ubisoft:x-posts, 2

    I cannot speak to tovi to customize my character, it also does not apear at may completed quests that i finished the mission carrying the torch(wich i did actually) i hope this will be fixed.. Or an opinion would help

  • RogueDragon6476
    ubisoft:x-posts, 1

    After completing "carrying the torch" Tove's dialogue icon won't pop up and cannot change my hairstyle and tattoos

  • dan.may909
    ubisoft:x-posts, 2

    I have completed the small quest after Sven dies, and Tove is back in the tattoo shop, but I can't get a prompt to interact with her. How can this be fixed?

    ubisoft:x-posts, 2

    I have the same bug as many mentioned above. After finishing the "Carrying the Torch" quest. Tove is not responsive at all... I'm 80+ hrs in and a new save is NOT an option. Please patch 🙏

  • Xtopher16
    ubisoft:x-posts, 1

    @kakacsy Also seeing this on PC, and quest not showing up at all in quest log for me either. submitted case to Ubi. At least I know I'm not alone

  • vixangel
    ubisoft:x-posts, 2

    Good afternoon,

    Since the update in Jan 2021 I am no longer able to talk to Tove the tattooist. Can you please advise how to fix this. I have reloaded the game numerous times, going back to before the update is not an option as I have put many more hours into the game I do not wish to lose.


Suggested Topics