ubisoft discussions

Quick Suggestions

  • ildafkam
    12 posts


    Yes, join the club 😏

  • locoporkko
    27 posts

    I try in my savedata of 150 hours and the pig dont talk

  • Daimos11
    9 posts

    Bug still persists in the newest version of the game. Please see freshly recorded video after applying today's patch:

    Could you please send it to the dev team?

    Yes - the patch on PS5 is labelled as 1.011.000 and the bug is not resolved:(

  • pjmazurek
    6 posts

    @guest-m9drkxgg broken for me too

  • Hoggface
    6 posts


    Still not fixed after patch 1.1.1, maddening!

  • Dantoonfan24
    1 posts

    Still not patched pig bug what a joke!!

  • daryl9210
    7 posts

    @ildafkam well any chance for it being fixed next update?We've been waiting for 4 months

  • locoporkko
    27 posts
    @steveboy49 i have the same problem that you and the solution for me was play 100 hours more,in total 250 hours 150 hours in first game and 100 hours in second game,was a horrible nightmare repeat everything in the second game but the reward was the 450th platinum
    Are you saying I have to complete the game then do another playthrough?? Because that’s the definition on insanity right there fml

    Yes,sorry for answer you passed so many time but yes for now the only solution is make a new playthrough

  • Tha_Kev
    9 posts

    Can you guys FINALLY fix the bug in the mystery 'Pig of Prophecy'???!!!
    After drinking and hearing the pig speak, you need to talk to the Anglo Saxon Man again to complete it.
    However, this does NOT work!
    Talking to anyone nearby does Not do anything for the mystery in trying to completing it..

    Can you PLEASE fix this bug (that has been around since NOVEMBER!) so that people who need to do this last Mystery in order to get the Platinum trophy can Actually get it?!

    (trying to upload video for proof so you guys can see what's going on)

  • Tha_Kev
    9 posts


    Video link to see the bug

  • AngstyStark
    2 posts

    Unable to complete the "Prophecy Pig" quest in Cent. Eivor no longer gets drunk and can't talk to the pig. The only dialogue he has is "Hello Pig" and the pig just snorts and nothing else happens. I've tried everything I could think of to see if the quest can be completed. Nothing works. Please fix this.

  • davidosullivan9
    2 posts

    @daimos11 I just shared a screen recording to Twitter as well and tagged Ubisoft. I have been experiencing the exact same issue. Never had Matilda talk to me and unable to make this happen. Only mystery stopping me from platinum.

  • davidosullivan9
    2 posts

    @solid18snake I haven’t been able to get drunk the first time. 129 hours in and it’s all I need to platinum the game. Had enough of floating boats getting fixed etc, but a real problem has been put on hold.

  • Majere326
    22 posts

    After the update Pig of Prophecy is still bugged and STILL not added to either the mega thread or the known issues thread. Maybe next month...

  • Athanasius
    14 posts

    @daimos11 Yup, same for me. I tried again with taking the cloak off before, just in case, no different. Drinking 3 times in a row before talking to the pig, no different.

    It's the last thing I need to complete to have all areas completed in terms of Wealth/Mysteries/Artifacts.

  • FallenAngel0598
    1 posts

    I’ve attempted to drink and talk to the pig multiple times but the pig won’t talk to me. It’s the last thing I have to do in Cent and I have no older saves to revert to and neither leaving the area and coming back or meditating doesn’t seem to work. Has anyone else had this issue or maybe something I could try that I haven’t already??

  • whorphan
    21 posts

    Seriously, what are you doing Ubisoft?!?!

  • whorphan
    21 posts

    @tha_kev I've given up. I was hoping that the latest patch would've fixed it but nooo. I will never ever be a first day buyer again and I'll never recommend a ubisoft game unless it's older and fixed.

  • DopeScopenRoach
    2 posts

    The Pig Prophecy Mysteries in Cent, Canterbury is still bugged it won't let me finish the mission/quest....please fix because this is the only one I have left out of all in the game. It is keeping me from getting the 100%...I really don't want to have to start over. I'm on the xbox one version. It is really the only bad bug I have trouble with. I have over 156hrs played. I love this game that much and don't want to knock it over a simple bug fix. I know alot of people with the same issue and quit playing because of it. Please fix before new dlc come out. Your faithful consumer and die hard gamer DopeScopenRoach. I have played all Assassins Creed games from day 1, loved every one of them and I don't won't to end it here...

  • Derzalas
    19 posts

    STILL BUGGED as of 6AM on 01/15/2021 after the version 2.10 update on PS4. SERIOUSLY?! Huge update, but still not fixed. I can’t complete Cent or 100% the game.

Suggested Topics