Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • digger_973
    7 posts

    Update: So I received a response from Ubi, but it just echoed what is said in their "Known Issues" thread, by saying there's a workaround which is, "Fast traveling should reset the event". I messaged them back saying this does not work (at least not for me). Crossing my fingers that I'll get a response again soon. They did also say that issues with World Events not completing for players is under investigation. So hopefully, it will be fixed in the near future.

  • Ubi-Borealis
    Ubisoft Support Staff 2131 posts
    Best Answer

    Hello there!
     
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a fix for "Pig of Prophecy" in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET.
     
    If you are still encountering issues with "Pig of Prophecy" following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • That the issue continues to persists in-game following this update.

     
    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
     
    Thank you! 😊

    Official Response
  • Hallinskidi51
    3 posts
    This post is deleted!
  • Hallinskidi51
    3 posts

    @digger_973 Fast travelling dors not work for me too 😕 !!!

  • DeanPioc
    1 posts

    I can't get drunk a second time, I tried going back to an older save, fast traveling, closing the game and restarting. nothing seems to work. Any suggestions?

  • beerad916
    4 posts

    Another here. And appears this issue is platform agnostic, there's PS4 and Xbox complaints as well. Tried completing the zone, fast travel, ride the whole way there, progress in other areas and come back, meditate, get drunk first, set the whole GD place on fire...that was just frustration, nothing works.

  • Tim123tim2343
    1 posts

    @ubiwan I have similar issue. In my case I talked to a guy, then got drunk, got grey screen, talked to the pig ONCE... then I left (i thought I have to proceed with this quest underground).
    Now when I come back, I cant get drunk, I cant talk to the pig 😞

  • gentester
    64 posts

    Ok I've been trying to complete this quest for hours now over a period of a week or so interspersed with doing other things.
    I can speak to the pig in english once and that's it.
    When it first hit I did a reload but got the same bug (twice).
    I have tried fast travelling away, meditating, going off and doing a load of other things which also included fast travelling etc.
    Pig has the speech bar, his owner has the speech bar, the water doesn't induce hallucination and the pig doesn't speak (just makes pig noises) no matter what I do.
    This means i am completely unable to complete the world events for Cent so please fix this, its a well known bug that you can see simply be googling it but I can't even see it on the list of known issues.

  • moriatii
    30 posts

    Have the same issue, on an older save file I did this first time no issues, but after the update it stopped working.

  • gentester
    64 posts

    Not sure how much fast travel is supposed to fix this bug. I went back to Norway and nothing changed when I returned to the pig. I try every now and again after doing a ruck of other stuff which includes meditating, fast travelling, throwing rocks at it etc. Nada - pig just makes pig noises.
    Ubi need to fix this, it's so well known that if you google Pig of Prophecy a description of the bug is the first thing that comes up.

  • USSPrometheus
    6 posts

    Well I'm another one with this bug. It's the only thing in Cent I need to do. I've done everything as most people seem to have done, bar re-installing the game which I might try overnight. However a friend tried this and it didn't work for them with the bug.

    Only 20 manual saves doesn't help in check pointing progress. My last save is 70hrs ago from my current one. Ooops.

    Be a nice Christmas present Ubi if you fix this.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hi everyone! Firstly, please allow me to apologize for the inconvenience and frustration caused by this bug in "Pig of Prophecy". I completely understand how aggravating it must be to not be able to complete this World Event, and would be more than happy to get this looked into further. With that being said, if anyone is able to upload a video showing the pig no longer speaking to you, or that Eivor is no longer getting drunk, please submit those clips on this thread, so I can include the footage in my report.

    Official Response
  • USSPrometheus
    6 posts

    @ubiexcellent

    - there's my own example

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @ussprometheus Perfect, thank you so much! I've shared this clip with the appropriate teams, so we can get this issue looked into further.

    Official Response
  • jaybee693
    5 posts

    @gentester I have the same bug. Also PC.

  • Nico2000nl
    34 posts

    And Ubisoft just told me to go [Removed profanity] myself when I asked what was wrong...
    Gotta lave this company, right....?

  • Nico2000nl
    34 posts

    @xspenz
    Support doesn't give a [Removed profanity]. They already got yer money.

  • Nico2000nl
    34 posts

    @ubiexcellent
    Why do you need a video.. Literally nothing happens...?
    It would be a video of NOTHING HAPPENING...!!!

    I completed the quest by drinking twice and talking to the pig twice.
    A third time drinking nothing happens, NOTHING HAPPENS...!!!
    Talking tot the (the pig speaks for both of us) guy, NOTHING HAPPENS...!!!
    Talking to the pig, NOTHING HAPPENS...!!!

    The mystery simply won't Complete...!!!

  • Jobkung
    1 posts

    Me too, please fix this

  • Padre.Gabrielli
    2 posts

    I did everything in the game, all missions and completed all areas at 100% besides Cent, because I can't get drunk and speak with Matilda the pig, I only get the "Hello, pig!" line every time, I even got drunk in the drinking game near by and run there, but nothing I keep getting the same line.

  • gentester
    64 posts

    This issue has still not been added to the list of known issues so I don't think it will get fixed anytime soon
    I have this bug so can't complete the Cent mysteries,
    to add to a small list of other issues:
    a pet wolf that lives miles away from home,
    a pet fox I have never even seen once in my settlement,
    I still have to save and reload more or less every quest to get them to complete.

    I have managed to avoid some game breaking bugs by reading these forums but I shouldn't have to
    I understand the next update is in mid Dec, so presumably this week or next week.
    Might be too late to get it fixed for this update given it hasn't been added to either the 'to do' list or the list of stuff they are working on.
    This game has far too many bugs to have been released. It's basically an unfinished and unpolished product we all paid full price for and are acting as their beta testers
    Unacceptable guys, get yer act together, what on earth were you thinking releasing this buggy mess?.

Suggested Topics

Community Details

38
Online
130.5k
Users
22.6k
Topics
117.2k
Posts