Welcome to discussions

Quick Suggestions

  • rkemp1987
    1 posts

    @thejohancz same issue here

  • iSuckatLife12
    6 posts

    Still having this issue on PlayStation, no solutions yet. If it helps I believe I left the event area after the first drink/speech, came back and nothing triggers no matter which order I talk to the AI/drink in.

  • cmhoughton
    32 posts

    Yeah, I’m having the same issue. Xbox One X, most recent update. I drink and never get drunk. I tried to get drunk doing the drinking game which is kind of close, but Eivor sobered up on the walk over before trying to talk to the pig. It’s the last mystery for me in that area, so I would like to see this fixed.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hello everyone! While our teams have managed to reproduce this error, they are still working on a fix. Updates to this issue will be posted to the game's official website once we have new information to share. I sincerely appreciate everyone's continued patience and understanding.

    @Nico2000nl Please keep in mind that the use of profane words is not allowed on the forums, as per the Forum Rules. We are here to support players with the issues they're encountering, while also maintaining a respectful and welcoming environment. To address your question, the development team requests footage in order to help them reproduce the issue on their end, which in turn helps them find and implement fixes. I understand it can seem pointless to add screenshots and videos with nothing happening, but rest assured these do make a difference on the backend.

    @gentester I'm sorry for any worry caused by this bug not being addressed on the Known Issues thread. Since this list is non-exhaustive, it does not accurately represent all issues that have been reported to our teams, similar to our Megathreads post. With that being said, I'm pleased to let everyone know that our teams were able to reproduce this error, and are working on a fix.

    @locoporkko I'm sorry to hear you had to begin a save, but many congrats on having platinumed the game! 🎉

    Official Response
  • gentester
    65 posts


    Thank you for responding and letting us have an update. Much appreciated

  • Athanasius
    14 posts

    @thejohancz Same here.

    Originally I decided to check out this particular World Event whilst doing other things.

    I spoke to the man a little distance from the pig, and took that as a hint to talk to the pig. Talked to the pig, got advised I'd need to drink more (from what the other NPC was saying). So I drank.

    After that I spoked to the pig and got something NOT just "pig sounds". However at the time I couldn't make any sense of it, so went off and did other things.

    Then I came back later, drank, and the pig just makes "pig sounds". It's now weeks, many quests and much progress later, and the situation is the same. I even drank *three* times before talking to the pig just now, but only the same "pig sounds".

    I'm on PC.

  • daryl9210
    7 posts

    @athanasius Same here,I see so many people having this problem and stuck on this.Why hasn't it been fixed?It's been like a month.Are we paying for a beta or what?Seriously before releasing a game so bug ridden do a thorough testing.Befpre making festivals and new stuff fix your [censored] ubi!

  • KARNAC_119
    1 posts

    After 1.1.0 update, the bug still exists. [censored] Ubi, Do I really have to wait for another month and hope that the next patch will fix this (and feel fail again after found that this f**king bug still exists...)?

  • gentester
    65 posts


    Can confirm not fixed with 1.1

  • USSPrometheus
    6 posts

    @ubiexcellent I was hoping it would have been fixed today as it's the last thing I need for 100%. But thank you for coming back to the thread and updating us, hopefully the team can get the fix in for the first patch next year.

  • Athanasius
    14 posts

    @ussprometheus Yup, same here. Patch 1.1.0 has **not** fixed Pig of Prophechy for me.

    I even just tried getting totally drunk at the nearby drinking challenge first. No change. Then drinking again near the pig, no change.

  • Destiny334loca
    2 posts
    This post is deleted!
  • AegnorM1
    2 posts
    This post is deleted!
  • AegnorM1
    2 posts

    Same problem here.. the mead doesn't do anything. Went a couple save games back ( about 100h of gaming ) and then it worked. I drank the mead, the screen went in a trip and the pig talked.

    Went back to the current save game and it didn't work anymore..

    Maybe this helps fixing the problem.

  • Athanasius
    14 posts

    @gentester Yup, not fixed for me either.

    From what some others have said (elsewhere and here), what's meant to happen is Eivor commenting on what the pig says after you drink. I think perhaps that never happened for me.

    So it's stuck in a state where it's waiting for something to happen that can never happen because I can't trigger it again. I think it'll take a patch resetting this for anyone who's not finished it (by the sounds of it when it works this World Event is so short and quick that this shouldn't inconvenience anyone, unlike some longer and more involved events).

  • Derzalas
    19 posts

    I am playing AC:Valhalla digitally on PS4. Let me start by saying that the most recent update on 12/15/20 fixed many of my issues. So thank you, Ubisoft. There is only one bug left that I am experiencing at this time. I have one mystery remaining in the world. It is called “Pig of Prophecy” in Cent. You are supposed to drink from the barrel and the pig speaks to you. I heard the pig speak the first time, but the second time won’t initiate even after drinking. Any known fixes? I would like to 100% the game. Even though it’s a buggy mess, the gameplay is fun and the world is immersive.

    1 posts
    This post is deleted!
  • locoporkko
    27 posts

    @athanasius you must do the same that i do before and for that reason i got the platinum begin new game,i know that is many work and a lot of hours but at the moment is the only that guarantee the platinum and i look in my save of 150 hours and i cant talk with matilda after drink of the barrel

  • moriatii
    41 posts

    @locoporkko Still not working, but it is the only one I haven't managed, last week there were around 5-6 that I had bugged, so I think the update is a marked improvement, plus my map looks a lot better now I can collect the majority of the opals, still a few bugged but i can live with that as it doesn't have any effect on the game progress.

  • cetin.19
    81 posts

    I have the Same Problem and i find a News about this


    this was from ths 19.11.20 until to das the didn ˋt fix it.
    thats the Last Mission for me to get the Platinum trophy i ˋ m so disappointed from Ubisoft Really .
    so Many bugs in the Game .
    ubisoft Real Talk if you Addet some new content please please Check befor is the Game bug free than addet you content.

Suggested Topics