Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • thoffa22
    1 posts

    Well seems countless people are having the same problem whether it's not even getting drunk nor getting past the second part of the quest.

    I looked in the section where they have known bugs or glitches. This quest isn't even listed which is wrong if ubisoft know why have they not listed it there personally to me it should be as it's a well known problem as many of us have this problem.

    Hopefully they will fix it soon.

    If anyone is interested this is the section I am referring to in the "cannot proceed with certain quest's" area at the top of the page.

    https://discussions.ubisoft.com/topic/76980/assassin-s-creed-valhalla-known-issues-updated-jan-8?lang=en-US

  • trik68
    1 posts

    @ubiexcellent Both the pig prophecy bug and the fabric bug is keeping me from 100% this game. Fabric is not in shop or high level chests (spent 5 hours looking). Hopefully these get fixed soon. Really annoying that both these bugs have been in the game for months now.

  • moriatii
    30 posts

    @trik68 Can't say much on the pig issue, but fabric isn't bugged, you will find extra fabric, I have ran through the game 6x and in every case just where I think I don't have enough I get it from somewhere, sorry I can't say where, but I can say its in one of the higher power areas and either through the story or through a random chest, it will drop.

    good luck

  • Jan2015BCN
    1 posts

    I have tried everything... but it doesn't work. Last event to get the Platinum trophy... Quite disappointing I am afraid... to get there and not to be able to complete the game. Glad Ubisoft fixes it.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hi all! While I am still waiting on an update from the development team about this bug, I did want to reassure everyone that just because an issue hasn't been added to the Known Issues thread or to the Megathread list, it doesn't mean the bug isn't being looked into.

    @AlexSinnerman7 @trik68 We've made a Megathread for the issue with fabric no longer being lootable. Please add your experiences about this issue there, so we can address your concerns further.

    Official Response
  • SamD1812
    1 posts

    Same for me. 100% completed everything aside from this DAM PIG!!! Fix it please Ubisoft. This has been a horribly buggy game. Spent 2 hours trying to get my Vikingr to help me ‘Force Open’ a door on a raid with no joy. Ugh!!!!

    if anyone has a fix, please let me know! Feels like such a waste of time. Over 120hours sunk into a game just to be held bay by a ******** pig! Lol.

  • cetin.19
    80 posts

    I have the Same Problem i Need only this Mission to get the platinum for ps5

  • Hoggface
    6 posts

    @quirino_25
    Yup, and me. Bloody irritating. It's the last thing I need to do.

  • cetin.19
    80 posts

    I have a Problem with the Mission Pig of prophecy .... i cant Play the Mission ... if i Drink the water i Never See the white screen and if i Talk to the Pig he said always hello pig..... thats the Last Mission to get for me the platinum trophy

  • AlexSinnerman7
    11 posts

    @ubiexcellent I’ve checked the thread that is basically everyone complaining about the same as me. Can we expect both this issues fixed this year? I wanted to play Fenyx rising but I’ve decided to not buy as it must be full of unresolved bugs like this one and sincerely, when you say that the engineers have acknowledged this, I didn’t see anything in any of the patch notes or issues being worked on.

  • guest-vUEW0KiM
    1 posts

    Same glitch with me ! Reloaded an earlier save from about 48 hours in and it actually worked perfectly but now I’m 140 hours done there’s no way I’m going back lol. I reckon it glitches if you’ve completed some other event before attempting this one 🤔

  • Daimos11
    9 posts

    Same with my PS5 save.. I'm seriusly afraid that my tens of hours collecting stuff will go to waste:( The fact that it's not even officially acknowledged after almost two months from first reports is quite disheartening.

  • LPfaint12
    1 posts

    Hey! im another one of the lucky ones where this is glitched for me. This is the last thing i need to do for my 100%. Playing on Xbox Series X.

  • TFO5000
    11 posts

    Looks like this is not being fixed in patch 1.1.1. Sigh.

  • ildafkam
    12 posts

    Same problem - playing on pc. Updated to Latest patch (1.1.0).

  • ildafkam
    12 posts

    @ildafkam

    unfortunately fix not in list notes for patch 1.1.1 which is due to be released on January 14.

  • Skandranondm
    6 posts

    I can't believe this is not being fixed in the new 1.1.1 update, that is so unacceptable... I have played and 100% every Assassins Creed ever made and after admitting they know about the problem and being able to recreate it more than 2 months ago decided still not to add it to the master list of problems. I figured that since it was never put on the master list it was not going to be fixed in the next update, big surprise, I was right... Seems like Ubisoft does not care about their base and fixing their game within a reasonable time. So disappointing, idk what else to say...

  • xIFoxHound
    49 posts

    While I am quite happy that the achievement issue is being fixed (as I have various achievements not popping despite completing the actions sometimes more than twice) its is very disappointing to see this mystery not fixed with this new patch as I’ve seen so many people raise this issue and stopping many others, including myself, full completion of the game

  • cetin.19
    80 posts
    Ubisoft i m so disappointed on you Really disappointed thank you That you dont Fix this Mission 


  • Valhalla2015
    73 posts

    This is my final achievement remaining to get 100% as well. I didn’t see it in the notes for 1.1.1 either. I’m holding out hope that they forgot to add a note or reset the mission or something.

Suggested Topics

Community Details

42
Online
129.0k
Users
22.2k
Topics
115.1k
Posts