ubisoft discussions

Quick Suggestions

  • ashleysosa44
    34 posts

    So just tried to leave the shield. I did a manual save before I did. It killed me before I could reach a source of food. I reloaded last save and respawned with no arrows, yet the enemy has also respawned.

    I took video clips via xbox of what was happening before I ran through the shield. If its helpful I will download and try to upload them here maybe when they post. Takes a while for them to show up where I can download them from xbox app. Not entirely sure how I would share them here though maybe youtube first then link? Not sure.

    Anyways, I also cant fast travel, because enemy. I'm going to let myself die and then maybe if I fast travel immediately after respawning it will let me.

  • FreshByrze
    2 posts

    Even if you get trough that quest the next quest is also bugged. The wolf boss fight is impossible to complete because the wolf keeps going underground.

  • El-Diablo670
    2 posts

    When it gets to the survive the attack bit it just won’t progress. To start with most of the enemy’s won’t enter the circle. 2 when you leave the circle you take damage (don’t know if it’s meant to do that), so you can’t go and get the other enemies to fight as you dies before you can reach them. The voice dialogue doesn’t even play and to make it worse I can’t go back to try from the start again as the game deleted the past autosaves and the last major save was over 10 hours ago and I ain’t going back. I’ve enjoyed playing this game but I’ve come across multiple game breaking bugs and it has ruined the experience. This bug has been around since the game released and you haven’t fixed it. Come on ubi, please fix this soon so i can continue playing

  • MagnaCali
    1 posts

    @jiminatorx i'm getting really tired of this bug.. game is 7 weeks out

  • Kikotorres1975
    1 posts

    I can't progress from defending builder after shield turns red. Kill all attackers but there is never interaction dualogue and shield never turns green. Have left repeatedly and returned to Asgard and always stuck at same area

  • SkypherDZN
    27 posts

    State of defensive measures mission in 2021:

    I am at the part where I have to survive the attack. thats what it says as mission objective. circle is red and enemies are coming inside. I cant go outside or else I am losing health chunks. even after killing all enemies the mission wont finish. the circle is still red even tho it is supposed to turn green after a while. I noticed some enemies far outside the circle (unreachable from inside). I managed to not take any damage when leaving the circle by fast traveling to the nearest viewpoint.

    I then walked down that huge mountain, killed the enemies outside the circle only to find out the mission still wont complete even with all enemies killed.

    Is this mission behaviour being addressed with an upcoming patch? PLS - it's very frustrating because I cannot finnish the story ...

    Kind regards

    1 posts

    @riley0219 I'm have the same issue

  • A Former User
    0 posts

    I have an enormous bug in Valhalla in asgard in the quest defensive measures i went early as whem i had to drink the potion i didn't know I'll travel there, and when i started the quest i finished everything and at the end in the barrier i got no cutscene i left since nothing could be done finished main story, did many parts of England 100% i really don't wanna do these all over again, when i go back to asgard quest is still bugged please help! Enemies come in Nothing happens defensive measures is still open without telling me what to do! So frustrating 😞

  • Thomasvj03
    1 posts

    Keeps glitching

  • jacob-9147
    3 posts

    @el-diablo670 i can't even be arsed to play this game anymore this specific mission ruined my experience and the game itself since i can't get out of it. It's literally riddled with bugs and glitches, so bad that "defensive measures" has literally trapped my game and i can't return to England/ Norway. You'd think a proper gaming company would check the entire game for said bugs and glitches before the sale 🤣 ubisoft is literally just as bad EA #dontbuythegame #ubisoftdontcare

    6 posts

    Come on ubisoft. Still broken? This is affecting the game so bad for so many of us. Please fix this mission! I'm begging you.

  • Khayner11
    1 posts

    My jars did not explode but I have killed all the enemies and it just won't progress. I have came back several times and killed all enemies nearby. I am on ps4. I no longer have the save near when I did the quest and have put in many hours since then. I have had many other issues but this is the only one where I can't progress. If there is any more info you need from me I would be happy to help.

  • UbiKoality
    448 posts

    I sincerely apologize for the delayed response. All of our teams have been extremely busy as of late working to answer the copious amount of support inquiries that are coming in. If you're still having this bug with the Defensive Measures quest, please try to grab some video evidence of it for me. This would be incredibly helpful to include in my report to the team! I'd recommend uploading the video to a site such as YouTube, then commenting the link in your next reply. Your help would be greatly appreciated.

  • d24rohit
    13 posts

    @UbiKoality Here is the video which I have already uploaded.

    As you can see here, once I enter Asgard, I am already inside the Green Shield but Jotuns are spawning in infinite numbers, they can enter the Green Shield without any issues, Builder is not present in the shield and no matter how many jars I kept near the bar, nothing happens. The quest is stuck.

  • Juicyjugs3223
    2 posts

    So after all the updates I went back to valhalla and i still cannot complete the quest. The barrier is red and the builder does not speak enemies coming in do nothing for the quest paint jars do nothing and if i leave i die. Will this quest EVER be fixed it has been this way since bloody launch and I'm tired of it i do not want to have to restart the entire game for it to do this again FIX IT ALREADY

  • UbiKobold
    Ubisoft Support Staff 916 posts

    Hello! I am very sorry that you have been continuing to experience this issue and have not been able to complete the Defensive Measures quest! You mentioned the paint jars, just to be sure, when you bring the Builder the paint jars, is that when this issue started to occur? Also, would you mind creating a Support ticket and providing your save game files? Then just post your ticket here so I can send your files to the Game team. I understand your aggravation, but appreciate your continued patience as we investigate this matter.

    Official Response
  • eiswanderer92
    2 posts

    Hi, I'm experiencing the same bug (PC) that other users have stated here. I can't interact with the builder, and the Jotuns don't attack me anymore, even though the bubble is red. If I approach them a bit, some of them come, but not enough to continue the mission. I've already completed the main storyline and other big tasks, and I'd like to enjoy a bit of Asgard as well. It's been almost two months since we started this mission and still we're unable to continue :_

  • guest-8uuOmz0d
    1 posts

    I’m playing AC Valhalla on PS 4 and I can not progress through the Defensive Measures quest in Asgard.

    Every time I return to Asgard, I return within the shield, which is green, and cluster of approx 10 enemies are there to attack me. The builder is gone. I’ve tried luring every enemy in the area I to the shield to kill them... still I can’t progress. When will this be fixed?

    From what I’ve read, this quest has been bugged since November, it’s now January.

  • A Former User
    0 posts

    Still stuck on defensive measures on asgard the live chat said would post something here but no solution...20 days bugged in asgard can't progress to platinum the game or see the asgard storyline! Wow ubisoft thanks for not caring for your costumers! Last time I'm buying something from ubisoft at release.

  • SiiiinZ
    1 posts

    Still no fix. I kill all the enemies and nothing happens, I go out of the shield I dye, believe the last comment was almost a month ago. RIDICULOUS!!

Suggested Topics