ubisoft discussions

Quick Suggestions

  • Lucassousaal28
    6 posts

    I was doing the quest Defensive Measures, but was too weak, and decided to go back to England to get more experience.

    More strong... I went back to Asgard, and every time wake up inside the circle, but no orcs comes to attack me, to continue the quest.

    Even if I provoke and kill all the orcs outside the circle, nothing else happens.
    I applied the patch 1.1.1. and now I can’t finish Asgard quests.

  • Riddlestick22
    2 posts

    @batman128237 I'm also stuck on the same thing. Been there for same length of time too but also completed the game now also

  • L1K3N
    1 posts

    @youknomehdai same thing happneds to me

  • Ubi-Ginge
    257 posts

    Hey @lucassousaal28
    Would you be able to share video footage of this with us

  • burrfoot4
    2 posts

    Same here. Mission finished, dome is green again, but no builder to talk to so the quest doesn't end. Have done everything else in the game outside the Asgard arc, reeeeeally hoping for a fix for this.

  • Lucassousaal28
    6 posts
    This post is deleted!
  • rob1112666
    3 posts

    Been. Trying to complete this mission. For a while. I. Defeat all the Enemy's that come into the Shield more spawn. Defeat them. More spawn. Far outside the shield. To the point. I can't. Reach them or i would risk leaving. The perimeter which makes your. Health deplete. Honestly. Would be helpful. If missions. Could. Just. Be restarted. Fixing. These. Chain of glitches

  • wmmurphy000
    20 posts

    @elshots11 Same since Nov 2020

  • mwhyte89
    2 posts

    Exact same problem here, what a joke

  • B1gsack7
    2 posts

    @lubietwixa Same here on PS5 - completed everything else in the game but can't do Asgard due to this [censored] bug! It's bollocks that they've not fixed it after nearly 3 months

  • Lucassousaal28
    6 posts

    @ubi-ginge I could record, see below:

  • emtdpm
    2 posts

    PS4 - enemies never coming into the field; I cannot go outside of the red field, Builder just stands there and says nothing; Level 400+, no completion possible; Game shelved until this issue is fixed.

  • Jakeanddad
    1 posts

    same issue on my game. Enemies won’t spawn in, and the runes for the spell are missing from the pole?

  • silentnet2015
    4 posts

    Ubisoft staff, any updates / ETA on a fix here? The big axe boss doesn't spawn for me (or I killed him earlier, then left and came back, I don't remember) but the Builder never says the "painting as fast as I can" line, just stands there and does the same animation over and over. I cannot progress the game and am 60+ hours in, please offer a fix of some kind!

  • UbiExcellent
    756 posts
    This post is deleted!
  • Ubi-Borealis
    Ubisoft Support Staff 6078 posts

    Hey everyone!

    I've now merged all of your posts regarding this issue together into this megathread, so we can keep all information regarding the issue with the shield in one place. If you're unable to proceed with the quest after bringing the jars to the builder, please check out this megathread instead!

    Thank you all for sharing your videos and experiences with the issue. I can let you know that the development team is aware of the issue, and that they're currently investigating further. We've also noticed that, sometimes when encountering this issue, the Builder also disappears from the area and can no longer be interacted with. The development team believe that these two issues are linked, and hope to be able to resolve both issues in a future update. I'm afraid we cannot provide a definite ETA for this, and apologise for any inconvenience caused at this time.

    I've passed on all the videos shared within this thread to the team. At this moment in time, they no longer need any further save files, but thank you to everyone who opened a support ticket to submit one, or offered to send one here.

    If we need any further information, we will ask for it within this thread. In the meantime, please feel free to keep sharing your experiences here. We appreciate your patience as we look further into this. For further news and updates, please keep an eye out within the forums. Thanks! 😊

    Official Response
  • emtdpm
    2 posts

    @lucassousaal28 This is exactly what happens to me as well.

  • zgruven
    1 posts

    @silentnet2015 same here. Nothing happens, they come in I run around and the shield doesn’t kill them. I hope a fix is coming soon. I am not about to reset this game as I spent too much time on the main quest.

  • Nightstalkr81
    1 posts

    Stuck here too. Can't finish this part of the game. 100% done everywhere else. Killed and lured guys into the bubble for 2 hours straight with no progress.

    Some guy posted a workaround to get out and grab all the crystals and viewpoints, but Ubisoft patched that up rather quickly. The game gets stuck in limbo if you can pull it off or tells you that you can't change the language during this activity.

    It would be so much better to just let us reset Asgard entirely and let us go from there.

  • ReigningFlea
    1 posts

    In the defensive measures quest, which is by far one of the most glitched missions i have ever encountered, i seem to have discovered a new glitch to add to the collection. Once u place down the jars and talk to the builder, the waves of jotuns begin to attack you. After i killed them all... nothing happened. No more enemies came and the quest didnt progress. The objective under the quest disappeared and then nothing happened. I then used Synin to look for more Jotuns and found that they were sitting outside of the area doing nothing. I cant kill them because ovbiously leaving the dome kills you. I cant restart a save as i finished the rest of the game without completing it. This is a game breaking bug and i hope its gets fixed.

Suggested Topics