Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Daner725
    3 posts

    @guest-yi3qltdl
    I’m with you. If they can create all this new content... why can they not pause the new stuff and fix this huge storyline piece? I don’t even have a desire to play, even with the new features or add-ons. And I definitely won’t be purchasing any future DLC. I had pre-ordered this game and this has been a problem since basically the first few weeks of November. Ridiculous.

  • ukShane
    2 posts

    @daner725 It's so depressing. You can track back Ubisoft replies going back months saying they're looking into it and nothing has happened.

  • Ubi-Mark.
    Ubisoft Support Staff 400 posts

    Hello there,

    Please accept my apologies for the delayed reply.

    @phileeeeeeep930 - I'm really sorry to hear about your experience. As you mentioned that your case is resolved - it means that our support forwarded your case to the development team with your video and your save file. I checked it for you and I can see that your zip file attached to the case has been forwarded to the ongoing investigation. Once we have an update from the development team, we are going to let everyone know through these forums.

    @guest-yI3qLtDL - It looks like this issue is taking longer than usual to resolve, my apologies! I just checked the status of this reported issue and I can see that the development team are still working on it. Once we have more information from them, we are going to update everyone ASAP.

    Apologies for any inconvenience caused by this and if you have any other questions, please let us know.

    Official Response
  • SkypherDZN
    13 posts

    @ubi-viral are you kidding me? I have heard this same response months ago. This bug has been around since launch week and u fail to fix it almost 6 months later.

    Serious suggestion: Add a replay/restart mission button to every single mission out of the box. Should fix many future issues even in new games. In earlier games there was the DNA that let us restart or cancel memories. They way it is now, is not really great for people encountering bugs.

  • Ubi-Mark.
    Ubisoft Support Staff 400 posts

    Hello @SkypherDZN,

    Thank you for the update. I'm really sorry to hear about your experience. I went ahead and I checked the status of this issue and I can see that it's still being investigated. It seems that the resolution is taking longer than expected and I do apologize for that. Once we have an update, we are going to let everyone know through the patch notes.

    I'll also pass your suggestion on to the development team. Thank you for sharing!

    If you have any additional questions, please let us know.

    Official Response
  • wmmurphy000
    20 posts

    @ukshane I went through the Better Business Bureau and got the same type of answer. Then I rejected Ubisoft's answer and forwarded 3 months worth of complaints to them. SUDDENLY, I get a real response from Ubisoft.

  • wmmurphy000
    20 posts

    @cd_be The dev team has said it'll be in the next patch. Enough people have complained apparently

  • tj029955
    1 posts

    Finished the game except for Asgard, in the defensive measures quest the builder is gone, domes green, and everytime I come to Asgard I wake up in the dome. I can kill everyone and nothing happens. I've tried changing languages saving and reloading, nothing. I've tried alot and nothing. Any help would be greatly appreciated.

  • Ubi-Keo
    Ubisoft Support Staff 304 posts

    @tj029955 I'm sorry to hear you are experiencing this issue.

    Could you please confirm if you have the latest game update installed and can you also provide a video. In the video can you show you drinking the potion and travelling to Asgard and fighting the enemies. Can you also go to your quest log screen and show your active quests and press R3 to show your completed quests.

    Official Response
  • standoffjosh
    62 posts

    @wmmurphy000 I'm praying this is true that Defensive Measures finally gets patched

  • bournekillerz
    2 posts

    I cannot complete the quest defensive measures either. when ever i travel to asgard, i awake in the green shield, am greeted by a few of the blue guys, and after they approach me, through the green shield, i kill them and then that is it. nothing happens. the builder is no where to be seen. I am playing on xbox series x at this point. i am unsure how to upload a video of this. but if necessary i am sure that i can figure it out.

Suggested topics

Community details

19
Online
119.7k
Users
20.6k
Topics
105.8k
Posts