Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • HeilChu
    1 posts

    @ubi-borealis So, any news on this? This issue is flagged for at least 2 months, and still nothing. Is It incompetence or you guys Just don't Care? Im really enjoying this game, but this issue (among some smaller ones) is [censored] everything up. PLEASE DO SOMETHING! I'm not gonna throw my 200 hours nor the 350 of my countries currency (which is How much this game coasts) on the garbage!


































  • TheHiveHawkeye
    1 posts

    I am unable to proceed on Defensive Measures. Upon the shield activating, I lured enemy into the shield, then after a while it goes red and says to eliminate the enemy.

    If you step outside the shield it kills you, I killed all enemy in sight, either by arrow or by them running to the shield, but nothing happens. No further dialogue, just stuck inside the red shield. You also die if you try to fast travel elsewhere in Asgard.

    There is no option to restart the quest. The only option is to wake up. If you go back in, you are put back inside the red shield

  • RGracer74
    2 posts

    The Builder just split and there's no indication of what to do. The shield is green i keep pulling blue guys into it but they don't die. I'm not reloading because I've put in like 40 hours after this quest. I don't understand why they don't just put a patch in to put the builder back where he belongs people have been complaining about this issue for a while.

  • Hylcom
    1 posts

    Hello, I have the same problem. The mission won't end. I went further with the story in England and left Asgard for what it is. But now the game continuously report that i have to finish the Defensive Measures mission first. I saw the load and save trick but i am to far in the game already to do this. Is there a other solution?

  • nonchalance_kec
    7 posts

    @thehivehawkeye same problem here, it seems to be a known bug and it affect the whole game but they still dont do [censored] about it

  • LedoveeeKladivo
    64 posts

    Hi,

    is your in-game language english? If yes, change it to any other language and try it again.

    I had this problem too and this helped me to move on 🙂


  • GrndMstr-Kelso
    3 posts

    @ledoveeekladivo I've tried that, and I've tried repairing my game files, to no avail. It's awesome that the language trick is working for some people, but honestly ubi needs to just get their s**t together and fix this issue because the whole questline has been full of issues since game launch - especially now that I've finished most of the game and discovered that this story arc has some pretty important context for other major arcs. *sigh*

  • nonchalance_kec
    7 posts

    @thehivehawkeye yhe only difference is that i can fast travel somewhere else in asgard and i dont get the damage even if i get close to the red shield bubble

  • savardf
    1 posts

    @reigningflea Same for me, I'm on PS5. I do not have an objective for the mission.. It suck big time

  • FNCMystic
    1 posts

    @reigningflea Same bug here, now i can't advance the asgard missions because it's stuck on that mission

  • Fryyeee
    2 posts

    I think this issues has happened for almost more than 2 month, I keep killing this mob but the builder won't talk and thus i can't progress the game

    i had such a hope that this 1.1.2 patch fixed it but unfortunately it doesn't. pls fix it ASAPundefined

  • JAKEOMAC
    6 posts

    Cmon guys this has been broken for so long now this mission. At the very least turn off the stupid electricity killing you outside the bubble. Maybe killing the enemies that don't come to you might atleast finish the mission? But impossible with the health drain.

  • heithaus9599
    1 posts

    same here. was really hoping it would be fixed in the latest patch but it's not on the list of fixes associated with the notes... maybe someday.

  • iRoniiKz-Iv
    2 posts

    I bought ac valhalla when it came out am at lvl 285 and i can’t finished the mission defensive measure the builder is not doing nothing how can i fix this ?

  • jstock04
    2 posts

    Come on Ubisoft. This issue has been prevalent for over 2 months (going on three). Defensive measures isn’t working and your releasing bug fixes for very minor things. Can we please get a timeline for the fix? Many of us are unable to complete Asgard or the rest of the trophies for the game. It’s impossible to complete all the trophy objectives with this issue.

    I’ve started telling people not to purchase this game until this specific issue is resolved. 3 months for a fix to a widespread and well known issue isn’t acceptable for the prices you require we pay for your games. 

  • jstock04
    2 posts

    @jakeomac Exactly. In the mean time, can they just turn off the fact that anytime we leave the bubble it kills us? I mean how simple would that fix be?

  • iRoniiKz-Iv
    2 posts

    Defensive measure mission it still bug. When is this getting fix its been like 3 months

  • Yorgul17
    2 posts

    Same for me... And with new patch... Still bugged 😥

  • Lucassousaal28
    6 posts

    I was quite excited the new 1.1.2 patch would have fixed the issue... Naaah, only disappointment.

  • TheRealKhaliel
    5 posts


    Re: [AC:Valhalla](Asgard Defensive Measures bug) During the mission when the player is prompted to "survive the attack" only 1 wave of Jotnar attack you. After the first wave the player is prompted to "use Odins sight" when using the sight I can see all the jotnar standing being the surrounding hills and they do not attack you thus preventing the player from completing the mission and continuing the story arc. A bug fix for this mission would be great as I've beaten the game and only have this story arc left to complete


Suggested topics

Community details

20
Online
123.9k
Users
21.3k
Topics
109.9k
Posts