Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Reddevil4GUD
    3 posts

    The issue I'm currently having is the quest doesn't end. I've killed every enemy around me. I've drawn every enemy I possibly can to the circle by hitting them with an arrow. Currently nothing is happening and the mission wont end. I've tried restarting the mission, to no avail.

  • Chancellor740
    3 posts

    @reddevil4gud Same problem, doesn't seem like this latest patch fixed it.

  • julienfamscity
    1 posts

    hello everyone i need help i am stuck on the quest "defensive measures" the quest no longer wants to continue and the npc is no longer there and i no longer have the help me quest icon s 'please thank you everyone

  • jayster0369
    1 posts

    I am at the point in the defensive measures quest in Asgard where I should be able to speak to the builder after defending the barrier and the builder has disappeared. I am past the point of reloading my game and I’ve tried replaying the sequence many times, and the builder does not respawn. I am stuck.

  • FeintX
    Original poster 3 posts

    This quest bugs out in so many different ways. I'm in the same situation as you. I defended the barrier and it turned green again but the quest never continued. I left Asgard and now when I go back the builder is not there. I don't have a save that I can reload and I've played about 30 hours so I don't want to start over. I want to keep playing, but it feels pointless if I'll never be able to finish this.

  • AmonAmarv
    2 posts

    @feintx i have exactly the same problem! At least i'm happy i'm not the only one with this kind of bug. Hope they will fix it soon.

  • burrfoot4
    2 posts

    Hello-
    I've seen a number of threads regarding issues with the Defensive Measures quest, but none quite like what I have. I finished the quest- at least, fought off all the Jotun and they stopped coming- but I wasn't able to interact any further with The Builder (who is gone now) and the quest won't end. On top of that, as noted above the eye icon to wake up is missing, I can only leave Asgard by loading a previous save.

    The only save I have left from before the issue occurred is 1:57 into the game, so I'm really hoping I don't have to start over.

    Any advice?

  • Rock5tar77
    14 posts

    The bug in Asgard that I've run into is with the shield mission. The part where you have to survive the attack. I've killed all enemies in the area and nothing happens.. Even the barrier goes back to green from red and the enemies can still enter the green barrier. I woke Eivor up and returned to find the quest locked at the "Survive the Attack" sequence.. Very disheartening

    Also, a mystery quest where the little girl says her brother is swimming in the pond and I'm no help.. How many fish do I need to catch for this quest to be completed!? I've caught over 20 Bullhead and still she says I'm no help. At least I'm ready now for the Bullhead alter. Another glitch??
    Really enjoy this game and I'd like to finish it. Plz fix 🙏

  • BowenRiedy
    2 posts

    So every time I load into asgard I run back to the mission where I left off at the “survive the attack part” and the bubble is green and the enemies just stand outside of the bubble until I attack them and the builder doesnt talk or do anything even if I kill all the enemies, I tried the change to english and reload thing but it still does not work and it doesnt seem to be anything I can do, very upset I can’t continue the asgard arc 😕

  • Tyqal
    2 posts

    @reddevil4gud
    Just chiming in. Ran into the same issue.
    Patch 1.04 did not adress this.

    For me the circle doesnt even kill the Jotun anymore. The builder dude is gone as well.

  • riley0219
    2 posts

    I'm stuck on this mission, because the circle just stays green ;I've tried restarting the game, fast travelling within Asgard and out side in the normal world. Additionally, The enemies can walk through if I lead them to it, but don't come towards the circle otherwise. Also, the builder isn't there, and there is only the mission title in the top left without any other text/tasks.

  • riley0219
    2 posts
    This post is deleted!
  • bitebug2003
    84 posts

    @riley0219 This isn't the correct forum for gameplay issues

    Please use this forum for that https://discussions.ubisoft.com/category/549/player-support

  • AvArAt2
    2 posts

    Hello everyone
    I'm writing a new thread because I haven't seen this topic in the list of neither under investigation bugs nor the acknowledged bugs, and it seems lots of other player are experiencing this (quick search on the Net).

    First time I went to asgard everything went fine up until the mission defensive measures: left alone the part of jar misscounting (I needed 4 jars instead of 3), let's move onto the actual defensive part; the defensive field will return green after I'm done with pushing jotuns back, but I never had any end mission cutscene nor managed to complete it even tho I did everything I had to do to complete it. The builder simply wasn't there to speak, and I haven't been able to complete that quest ever since (now I'm at 60+h into the game) , even tho I tried multiple times the possible solutions I found on the Net: changing language, reloading from a save that didn't contain words "defensive measures", dying in the field and respawn there, going out and back to asgard multiple times.

    Please, many players and I need it to be fixed because it's impossible to complete the asgard arc

  • AvArAt2
    2 posts

    @FeintX same problem here. I've already posted a thread but doesn't seem like it got any attention, maybe you can find it and post your message there so it will be checked at some point. I'm playing on PS4, and never had a cutscene after defending the broken field from jotuns units; by looking at some YouTube videos, I also noticed that the amount and length of the "invasion" was much longer than it should be, not sure whether that's useful or not to find a solution. Once I was done and the builder fixed the field, the jotuns inside died, the builder spoke but nothing ever happened and the builder disappeared

  • toddaimpaon65
    1 posts

    So im stuck on same mission but my issue is the force field failed then I fought everyone and now ita back up but nothing happens he doesnt talk or anything it just says defensive measures in green, even left area and did all 30 of the ymir's tear stone and it still hasnt changed

  • creed7232015
    1 posts

    I can't get past the mission defensive measures will not let me do anything the builder's not even there just have a green shield and nothing's going on

  • Big_Cakes
    2 posts

    Defensive Measures BUG: After the battle when the enemies invade the green shield, the Builders dialogue never pops up, I quit the game and reload and he is gone, I can't fix it and therefore I can't progress. Would love some help, I can't go to an earlier save because I've progressed a little bit in the story by now.

  • WolandJunker
    16 posts

    @ubi-woofer Same as @FeintX here.
    I could have posted the same exact video.
    There is no builder to be found anywhere and in the Asgard map I do not have any mission icon of any kind since I've done everything else I could, Asgard is now completely stuck and useless. That's pretty annoying, since it's a level 90 scenario and I was forced to go on and I am currently like 240+.
    Also, I don't have any previous savegames either. I hope this will be fixed without making us go through those 29 crystals again, I might die of frustration.

  • youknomehdai
    5 posts

    So during the defensive measures quest in Asgard.. first the enemies stopped spawning so I woke up from the vision. I tried to go back but because I am no longer in the force field I die within a matter of seconds and can’t make it backs to the force field. I already spent over 100 hours. I don’t want to have to start over. What should I do??

Suggested topics

Community details

23
Online
124.0k
Users
21.3k
Topics
109.9k
Posts