Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • bournekillerz
    2 posts

    i too am having this issue. i am on xbox one x.

  • eugen1442014
    1 posts

    Hello,

    I have some issues with the quest Defensive Mesures in Asgard on PS4.
    Enemies would not stop spamming so i woke up during the quest.
    I tried doing it again but enemies were spamming over and over again.
    I finished the main storyline, but when i go back to continue that quest, enemies are spamming over and over, and also the NPC is missing.
    I cannot reload a save file from before the quest since i have 70+hours in-game. Is it possible to fix this in the upcoming update? I cannot progress anymore.

  • tommybrdn
    1 posts

    I am also on PS4 pro and for me it only says ''defensive measures'', nothing under, and the shield is green, but the monsters are still trying to kill me.

  • Rock5tar77
    14 posts

    @ubi-baron I'm not going to pretend that I know or understand coding, but why is the jar exploding so important for the glitch in this mission? I too am having a glitch with this mission, although it doesn't have anything to do with the jars. Im on PS4 and here's footage of my issue. I passed the jar part and entered the attack, hence "Survive the Attack." For me the barrier went from green to red to green again. However, the builder doesnt speak to me after I survive the attack. I have since moved on from Asgard arc and continued England till fix happens. This footage is me returning to Asgard to find the quest is still there, but not active. The blue guys can breach the green barrier as tho its not there.


  • jameshowe007
    4 posts

    @youknomehdai same thing has happened to me I can't believe they haven't fixed this yet

  • MercUranus
    1 posts

    Same thing for me on Xbox. I brought the jars and they worked, but once the builder started talking again, he disappeared. The shield doesn't hurt the enemies and being outside of the shield doesn't hurt me. I'm sweating off any Ubisoft games unless this gets addressed soon. Ridiculous to buy a single player campaign where the campaign is broken. [censored] Ubisoft for this terrible product. It had such potential until corporate rushed the game to be released.

  • d24rohit
    13 posts

    This quest is bugged big time. I am playing to PS4 and I went to Asgard around Level 120 and encountered the bug where Jotuns could enter the field even after field was green. I gave up and woke up and completed rest of the game. Now I am Level 400 plus 32 Mastery Points and back to Asgard to complete it and now I no longer see Builder, Field is Green, Jotuns are spawning infinitely and entering the field without any issue. What should I do next?

  • d24rohit
    13 posts

    @luciidaa i am having the same issue on PS4. I have completed entire game and only thing pending now is Asgard and cant go further because Jotuns keep spawning and enter through green field, Builder is nowhere to be found

  • RYANFENNESSEY
    3 posts

    I left Asgard to do another mission in england, if i reload the last save without defensive measures in it its just going to take me back to england and still half way through a mission i cant complete, i play in english, ive tried to change it to another language which never worked, i dont know what else i can try unless they bring out an update that fixes the glitch, i really dont want to restart the whole game as roughly about 50 hours will be wasted, very annoying!!!

  • RYANFENNESSEY
    3 posts

    @riley0219 I have the exact same issue, nothing seems to be working

  • birdeh89
    3 posts

    @UbiT00n
    Todays patch addressed the fact that you spawn outside of the damage protection dome, however the enemies still wont spawn, the quest still wont progress and you cant leave the dome... so asgard is as off limits as it was when i was dying every time i arrived!

  • AllianceStuck
    156 posts
    This post is deleted!
  • WolandJunker
    16 posts

    Guys, is this a joke?

    You set up a patch specifying that it also fixes Defensive Measures' bugs, the I go back to Asgard just to find that yes, I'm automatically back inside the green dome, sure, but the mission is still stuck, there is no builder whatsoever and the jotuns go back and forth like dummies. No improvement. No fix.

    Seriously?

    I'm sorry, but this is gettin embarrassing. There is a whole sub-universe with its own plot within the game and we cannot play it.

    C'mon

  • thornh
    15 posts

    I still have the opposite problem. The patch allowed me to spawn inside the shield, mine is still red, and no matter how many Jotun I kill the mission will not progress. I too am level 400+ and have nothing else to do but Asgard. I really want a NG+ but not until all of this stuff is actually fixed.

  • Andemann93
    3 posts

    Pre patch, I had the issue where I would just spawn in Asgard and instantly die due to being outside the shield of Defensive Measures.

    Much to my joy did I launch the game today, venture into Asgard and see myself being spawned within the shield again - great stuff.

    However, after the initial wave of enemies, nothing happens. The Builder still stands there painting away, and no enemies appear. I have tried some of the things that was suggested by other players (reloading save, change ingame language, leave Asgard and spawn in again), but nothing seems to work.

    I have recorded a clip of my experience, please let me know if there's anything I can do to fix this! Asgard is the only part of the game I have left and it would be a shame to miss!

  • Rufwood2020
    4 posts

    I have tried to complete defensive measures. Im now back in the bubble however there is no quest directive and the enemies will not come. There is no way to progress this mission. I wish i could start the mission from the beginning

  • Jufee121
    1 posts

    So I'm stuck in Asgard; this quest bugged for me at the moment the builder fixed the red shield. After that the enemies just ignore the shield, and The Builder is unresponsive. The shield just stays green. Reloading the quest puts me inside the green shield, but there's no Builder anywhere, enemies spawn outside the shield and start attacking (ignoring the shield), and there's no quest objective. Killing all the enemies does not help.

    I tried looking for solutions, but the only one that seems to work is to load a save before the quest, which is not possible for me anymore. I had hoped that 1.1.0 patch would fix this, but it hasn't. This bug happened a few weeks ago.

    Platform is PS4

    Really hoping that this gets fixed next patch 😕

  • youknomehdai
    5 posts

    @jameshowe007 well they fixed it to we’re you don’t die. But i defeated all the enemies in the circle. But know the builder just paints and doesn’t do anything

  • reyrod01
    4 posts

    The only thing they improved on the new update is that when I go to Asgard, I start inside the shield, but half my health is gone, but I still die when I venture out of the area, so it's not much of an improvment. I've been stuck at this point for at least 2 weeks (maybe more). I've promised myself if they don't fix this issue by the end of the year, I'm going to put this game away and forget it even exists.

  • Seej86
    6 posts

    @rufwood2020 I’m the same. Finally in the bubble, but even after I kill everyone nothing happens =(

Suggested topics

Community details

5
Online
123.9k
Users
21.3k
Topics
109.8k
Posts