ubisoft discussions

Quick Suggestions

  • anxietycrossing
    1334 posts

    I appreciate that this issue occurs at random, @SpirantCrayon22, however as the investigation is currently considered closed as the issue is thought to be resolved, we're unable to reopen it without evidence that the issue remains in-game.

    Please do correct me if I'm wrong, but I believe you're in Xbox One? To my knowledge, you can select to "record that" from the system menu if the issue should occur. To capture a longer clip than the default 30 seconds, I believe you can visit the capture settings, which you can read about in this Microsoft article. If the issue should reoccur after you have upgraded the gear in any manner, you can use this to capture a clip for us as evidence of the issue occurring.

    If you are able to capture a video showing the requested information, including an overview of each Berserker item that has been downgraded and your full inventory, that would be ideal. I appreciate that the resources you have accessible may not be enough to upgrade the full gearset again, and seeing that will also be very useful to the team to evaluate the issue and the extent of it.

    Thank you. 🙂

    @Ozone83 - As a quick heads-up, I merged your thread with this megathread, as it discusses the exact issue you were describing. In the future, please check for an existing thread dedicated to your issue and reply to it if one is available, so that we can keep all of the relevant information together for further investigation and reference. Thank you! 🙂

  • SpirantCrayon22
    1907 posts


    Time to be blunt again. That is a disappointing response. Yes, if it happens again I'll try and remember to record a longer video but I am seriously irritated that you do not consider what I have already posted as sufficient proof. Effectively you are stating you do not believe me. Yes, you are, you wrote that you (still) require evidence of this occurring - therefore you do not believe me. Is this an appropriate way to treat customers? I own all AC main games. Complete versions of most of them, too. I post pretty consistently here and try to be helpful and constructive where I can, from what I can tell I am one of the better contributors in this forum. It should be apparent by now that I am not going to mess you guys around - but I AM more than prepared to tell it like it is if I feel messed around. Look at the other items in the video I already posted. They're ALL maxed out. Why would I leave the Berserker item out? Why would I downgrade it in order to post such a video? Come on, give me credit.

    To be fair, if you are not going to reopen the investigation as there's very limited evidence then I am perfectly happy with that. One instance rather than lots of people. That's fine, understandable. But do not treat it as if there isn't proof - there is.

  • Ubi-Viral
    2366 posts

    @spirantcrayon22 Apologies for any inconvenience caused. We would greatly appreciate a longer video, please.

    Rest assured we are not treating this like there is not proof, we do appreciate you being helpful and constructive, it is a process that we have to follow in order to reopen this for investigation.

    Thank you.

  • SpirantCrayon22
    1907 posts


    I still fail to see how the video I provided does not do what you need. It clearly shows a downgraded Berserker item compared with all other items being fully upgraded, that I have "new" items in the inventory (which I have explained are the other Berserker items) and the amount of titanium (along with the sum that shows it's not returned all the titanium used in the upgrades). Please explain how what I have done does not provide the information required.

  • SpirantCrayon22
    1907 posts

    Okay, it happened again. This time I believe I got all the resources back and I recorded the aftermath as per your unnecessary request. I had clicked on the "imperial gear has arrived" link in the main menu to see if it had actually arrived (as an aside, no it hasn't although I am not really interested anyway) then gone to get a quick snack. When I came back and went back into the game (in Winchester) I had a message on screen about stuff being added to the inventory - leather, iron ore and so on. I checked my inventory and those were present but the Berserker items were not there at all. A minute or two later I got the messages about ship items and such being given to me.

    Here's that video proving (again - so it adds nothing to this report as it's already proven) that there's still a problem. It shows me looking at armour items, seeing there are no Berserker items there. Then they start appearing and as the appear it is clear that they are all downgraded. The Xbox decided to crash so I've not yet done a video showing (for no reason as it's already shown) all the individual items in the menu system at their lower level of upgrading.

  • SpirantCrayon22
    1907 posts


    Here's the unnecessary video showing all Berserker items on Eivor at their lowest upgrade level.

  • SpirantCrayon22
    1907 posts


    In case you guys read this thread again and think of commenting on one aspect of it . . .

    The crash was not related to AC Valhalla and the resetting of the gear, it was later on and happened while I did something else while waiting for the video to upload. I had, incidentally, checked the network shortly before the crash and it was open NAT.

  • Ubi-Froggard
    Ubisoft Support Staff 2774 posts

    Hey @spirantcrayon22

    I apologise for the inconvenience of having to upgrade the armour again, but from what I understand, it looks like we are aware the gear may still reset in some instances unfortunately, however, the fix that the resources are returned was deployed so you can always re-upgrade it. If you ever didn't receive the resources and have this on video showing the gear downgraded and nothing delivered back to you, that is something the game team will be able to look into further.

    Official Response
  • SpirantCrayon22
    1907 posts


    I'm angry now. That is the point of the last few videos. The last event, yes, I got the resources, but the previous one I did not. Please check my posts and videos, you'll see what I'm talking about.

    If you actually do believe me and do treat what I write as proof, why the request for videos that do not show anything new?

    Or even, "We believe you but the development team does not so we need to pass a video to them." That would be fine.

  • Ubi-Froggard
    Ubisoft Support Staff 2774 posts

    My apologies @spirantcrayon22. We have still forwarded your video's on to the dev team to report that you had some instances of not getting all the resources back, but I was just saying that we wouldn't need any video's showing the last occurrence of it where you mentioned you did get all the resources back. Sorry that wasn't clear from the previous reply. I have also forwarded your save file on to the dev team as well as the steps you took recently when it happened, in case they are able to reproduce it on a copy of your save to find the issue.

    Official Response
  • SpirantCrayon22
    1907 posts
  • khr119
    1 posts

    Hello I was just contacting you because my bezerker gear keeps getting reset and it is a gear set I've used from the day of release. I sence switched and almost got it upgraded and it just reset again. Plz figure this out it's pretty frustrating too keep fixing the gear. Thank you,
    Keith Huntley

  • Ubi-TheBerry
    Ubisoft Support Staff 3384 posts

    Thanks for reaching out to us @khr119 , sorry to see you've been inconvenienced by this issue.

    This is still bring investigated by the team, with no news to share at the moment but we'll keep you all in the loop here when any new information is made available.

    Thank you for your continued patience while investigations are still ongoing and if there's anything we can help with in the meantime, please don't hesitate to let us know!

    Official Response
  • PhilyG213
    80 posts

    @ubi-borealis Actually it just happened to me a few days ago. I was away from the screen and when I came back all the items reappeared in my inventory and the same old "Bonus Content unlocked" message appeared. So it wasn't really possible to capture a video or something because idk what caused it.
    If it helps, I think what caused the berserker gear downgrading and reappearing again, for me at least, was when I got the pack with the Ezio or the Altair cloak that was paired with the Berserker Gear a few moths back. I already owned the Berserker Gear at that point so maybe getting a pack for items I already own is what caused it?

  • Lnhzz
    21 posts

    Why is this thread given as Resolved when it's clearly not?

  • PhilyG213
    80 posts

    @Ubi-Borealis Maybe I should specify that not only the gear disappears and reappears but also some runes, 1 mount skin and 1 raven skin.

  • PhilyG213
    80 posts

    Any updates on this? I would like to be able to finally upgrade my berserker gear without being afraid that it might lose its upgrades again. It's supposed to be fixed but as I already said it happened to me even though it shouldn't.

    198 posts

    Just happened to me again, and personally speaking from playing an xbox series x, I think it has something to do with

    a) owning the berserker content as dlc rather than through reda or helix
    b) at least for series x something do with quick resume or pressing the xbox guide/home

    The only times i’ve had it reset are when I press the xbox guide button, just to even look at it makes the gear reset (however just reload a save rather than reupgrade).

    If ubi is unable to fix it then to other players, I’d recommend using as few quick resume or whatever features as possible, and try to just play the game straight in playthroughs and save/quit the game properly.

    1 posts

    I just logged on and my berserker gear disappeared. My Eivor is in her undies.
    I have logged over 192 hours. I recently upgraded from Xbox one to Series X. I've been playing in the Series X with no problem until today. I had the berserker gear as part of my original purchase with my game edition. I loaded the game and she had her clothes, then they disappeared.
    I had all the berserker gear, now I have none. I still have my axes and I don't know if anything else is missing. I tried reloading and restarting... Nothing worked. I'm turning it off because I'm upset.

  • Ubi-Borealis
    Ubisoft Support Staff 6078 posts

    Hello there,

    I apologise for the delayed update. I'm sorry to hear that your Berserker Gear has reset in-game, causing you to lose all updates. Thank you for taking the time to share your reports with us.

    The investigation into this issue has been reopened, and the development team are taking a closer look at what could potentially be causing this issue to persist in-game. If you have been affected by this issue, please can you provide us with a video showing the following information:

    • That you have the latest Title Update installed on your platform. You can check this in the bottom right-hand corner of the main game menu.
    • The Berserker Gear resetting in-game. If you can show us what triggers the reset to occur, that would be very helpful to the investigation.

    I'd recommend uploading the video to a sharing platform, such as YouTube or Google Drive, as this will allow you to post a shareable link within this thread. Additionally, can you also provide us with the following information:

    • Do you own the physical or digital version of the game?
    • Which edition of the game do you own (Standard / Gold / Ultimate)?
    • How did you acquire the Berserker Gear (by owning the season pass or purchased in-game)?

    These details could be helpful as the team investigates this issue further.

    Please note that when this reset occurs, any resources used to upgrade your gear should be automatically returned to your inventory. This will allow you to upgrade the gear again if you chose to do so.

    @PhilyG213, @Lnhzz & @HIDDEN1NE - Are you still experiencing issues with your Berserker Gear resetting in-game? If so, please can you provide us with as much of the information requested above as possible? We can then forward these reports to the development team for use in the reopened investigation.

    @PMHNP - I'm sorry to hear that your Berserker Gear has gone missing after migrating from Xbox One to Xbox Series X. If the content is still missing in-game, I would recommend that you ensure all additional content has been installed on your new console. This support article by Microsoft can help you to check this. If all additional content has been installed and you're still missing your Berserker Gear, please don't hesitate to update us so we can take a closer look at this.

    Thanks! 😊

    Official Response

Suggested Topics