ubisoft discussions

Quick Suggestions

  • MrSmiilee
    1 posts

    @merrilyweplay Same thing has happened to me all of my dlc armor has been reset and I've spent alot of materials upgrading it. I wasn't as far in the story but it still is sad how much of my time is wasted now.

  • cliisemon
    2 posts

    Yeah this happened to me as well. But only the berserker kit is affected. Only now four weeks since I started playing, but now the whole berserker kit highlighted like it was the very first time I got it. Sure, the carbon ingot upgrade is intact, but annoyed over the fact that I have to harvest alot of Iron ore again. And it seems I have lost some runes too.

  • RahulVyas97
    5 posts

    The Reda Bug of not being able to solve was solved Randomly. I was walking through Ravensthrope when I heard Reda speaking the Story of Bayek and then After the story was over, I was able to speak to him, But after I spoke to him and completed the mission, I got The Berserker set again which I had already received before and it showed me all additional content now unlocked which I already had unlocked before. My entire Berserker Set has been Downgraded from Mythical To Superior. so the amount of Tungsten Ingot I had used to evolve it from superior to Mythical was wasted, plus it didn't return in my inventory nor the world. Basically the Tungsten Ingot used to Evolve Berserker gear vanished from the game as it is not in the place where I farmed it from nor in my Inventory. PLEASE FIX THIS OR RETURN THE TUNGSTON INGOT USED FOR EVOLVING THE ARMOR SET. AND PLEASE Reply. As I had Reported the Bug before but Ubisoft ignored it.

  • DaZleeper
    3 posts


    I’m playing on Xbox One X

    i bought the Ultimate version of Assassin’s Creed Valhalla, and I’m using the berserker gear set, but every time I go to the Helix Store in menus and back I loose all equipment except weapons in hand and bow. Gear set with max stats and Runes inserted are gone. If I don’t manual save before entering shop I have to go back many hours as the Auto Save don’t give me back my things. That works sometimes, I have lost 8 hours play by this 2 times now,

    In store when I go to Addons ONLY season pass is available no other choice. I have this included in my version of the game anyway, but looks to me as if the game don’t recognize the addons given to me with Ultimate version and removes them completely(not for hdd).

    I have quit the game, deleted the addons and re-downloaded them to no avail.

    I don’t need to use Helix store, but I thought I should give others a heads up and hopefully Ubisoft makes a patch fixing this.

    Best regards


  • NicWitch
    4 posts


    All saves are back but my gear upgrades aren't and the materials still aren't in my inventory.

  • Machinegaming
    3 posts


    Same thing happened to me when I connected my twitch prime account to Ubisoft app...

    I did not get the free armor set for connecting the app like I was supposed to and then it re-unlocked my Beserker armor that I had upgraded and rune slotted already like I had just unlocked it for the first time. My Beserker armor was downgraded and the materials I used to upgrade the pieces AND the runes I had slotted were all deleted ;(

  • Machinegaming
    3 posts

    Long story short - I bought the "ultimate edition" (which gives you the bear beserker armor set). I am about 40 hours in and I have my entire beserker armor set upgraded from superior to flawless (used nickel ingots). I took a break and was watching some youtube videos and saw that there was a free carolingian armor set if you connected your twitch prime account to your ubisoft account...so I went through the process and did it.

    I fired up my game and my character had no armor on at all (he was basically naked)...and then it flashed "new armor" on my screen and "re-unlocked" my beserker armor that I already had from the ultimate edition and did NOT give me the carolingian set from connecting my account to Twitch prime. 

    Worse yet...my beserker armor is now downgraded from "flawless" to superior...I lost all of the ingots that I used to upgrade my beserker armor from superior to flawless AND all the rune enhancements that were on each piece were basically deleted from my game entirely. They are not in my inventory.

    The rune enhancements that I had were not minor runes...they were all higher grade. 

    I then restarted my game and the carolingian set now unlocked but my beserker armor is still downgraded and I lost the ingots and runes entirely.

  • TopGunner1305
    1 posts

    @ntkoa Hello,

    I just encountered the same issue with the exception that it happened after purchasing something on unistore with helix credits.
    Same level of armor I had achieved, but it's all back to basics now.

    After a chat session with the help desk, it's all about waiting until a solution has been found. If they will give us our level of gear back is stil a big question mark....

    Anyhow, I'm also stuck in game, as there are in the area not enough ignots to get back to this level of armor. I'm also not going to spend bought helix credits to buy commidities to regain my original levels ...

    very frustrating indeed...

  • GriffinAD
    1 posts

    This happened to me this morning on PS5. All upgraded Beserker gear completely reset and placed back in inventory with all runes lost. I had purchased 6000 credits last night, which I didn't even get, despite being charged.

    This really needs fixing. Don't know what to do now either - I'd rather not start again. This is pretty poor all round but at least it isn't just me I guess - thought I was going mad.

  • thedevilcomes
    41 posts

    @ntkoa just had the same bloody thing happen to me.. wth!!!

  • thedevilcomes
    41 posts

    oh and it seems i cant even submit a bloody ticket about it!!!

  • thedevilcomes
    41 posts

    had the same thing happen to my berserker and raven sets
    picture spam incomingundefinedundefinedundefinedundefinedundefinedundefinedundefinedundefinedundefined

  • thedevilcomes
    41 posts

    also stole a ton of runes i'd collected!

  • karlmet
    1 posts

    @machinegaming Same problem here on my XBox One. My Ursine shield downgraded to it's original values. Sad to lose the lingots and runes...

  • SnappyCow4508
    1 posts

    Berserker armor was reset to default level and all runes that came with the ultimate edition are gone. Tried reloading an earlier save and it did not fix the issue.

  • nash_trickster
    48 posts

    I just had the same issie exept I had upgraded it to Mythical quality and boosted the stats to the max...

    It's actually the thousands of iron i've spent for nothing that are really [censored] me off!

    Since I've already cleared the map of all (small) chests, iron is becoming a rarer commodity than anything else (I have to rely on the 200iron/hour from the shop and the iron found "in the wild" now)... So I'll never be able to re-upgrade it without grinding for days.

    It's the Bear Claw axe reseting that is bugging me the most since I've been using it from the start as my off-hand weapon and now I have to make do with another one which is far less powerful since I haven't finished upgrading it (it's at mythical but there's still 3 empty "slots" in it's power bar)...

  • DaQuiknezz
    1 posts

    I fast travelled from England to Norway, and my fully upgraded mythical berserker armour disappeared from my inventory. Gone. When i returned to England the armour was in my inventory at BASE LEVEL! I lost all my runes that were attached to my armour, and all mats used to upgrade the armour. Any fixes for this, or is it tough [censored]? I went and killed all the legendary creatures so really not wanting to reload if I can avoid it.

    2 posts

    I have finished Valhalla on 94.49% completion so far, however I have noticed I have never received the Way of the Berserker Mission from the Settlement and today the Berserker Pack and other items that came with my ultimate edition disappeared and then reappeared, this means that all the upgrades for my gear which was already nearly fully upgraded has disappeared entirely. I would appreciate any troubleshooting options. Thank you.

  • nash_trickster
    48 posts

    Could we get some feedback and the insurance that the issue will be looked into?

    Because, I know from googling the issue that although we're only 2 to have reported it on these forums (so far) there's been many more hit with this glitch...

    I won't bother with the actual maths but to upgrade each piece it takes over 1000 iron, multiply this by 6 (each armor piece + the axe) and in this "small" glitch one can loose over 6000 iron!

    And since, thanks to the store, we know that to get 6000 iron I'd have to buy either the big pack of ressources or the big pack of silver, which are both priced at 2000H, it means this glitch "robbed" me of 19,90€ worth of iron.

Suggested Topics