ubisoft discussions

Quick Suggestions

  • Tijmenvdheuvel
    1 posts

    I spoke to Halfdan before starting the quest lost glory, now I can’t proceed. Please fix it, because more people are facing the same issue.

  • pub_bloke
    4 posts

    Still not fixed after new patch 16.03.21
    No point playing the game until this is fixed.

  • NecromanticLove
    2 posts

    Having the same issue

  • bawrey2123
    1 posts

    Even after the update 1.1.2 the "Lost Glory" mission still not fixed, i still cant talk to halfdan and can't continue the quest

  • Jshcaira
    2 posts

    Nothing change, still bugged

  • Maddox64
    27 posts
    Even after the update 1.1.2 the "Lost Glory" mission still not fixed, i still cant talk to halfdan and can't continue the quest

    I didn't expect it to be. It is obvious that their priorities are focused elsewhere.

    Have you seen the known issues thread? They have supposedly fixed about 13 quests that had bugs where you could not progress due to some issue. That is an average of 3 fixed quests a month. The problem is that the same thread lists over 30 other quest progression bugs, including this one, that are still unresolved.

    Shoot, even the Washington Post had an article yesterday about a Valhalla game breaking bug that was reported 4 months ago that has still not been fixed.
    https://www.washingtonpost.com/video-games/2021/03/16/ac-valhalla-bug/: (https://washingtonpost.com/video-games/2021/03/16/ac-valhalla-bug)

    Sure glad they are spending their time adding a gear transmog system and River Raids while so many of us would simply like to complete the quests that shipped with the game and are still bugged .

  • OGinMiami
    4 posts

    @tijmenvdheuvel me too and this bug had been around for sometime . I have completed every quest except this one all because I spoke to him early. Now he just sits there and won’t respond to me. 124h and I’m not starting over again

  • Ubi-Borealis
    Ubisoft Support Staff 6075 posts

    Hello all!

    The development team are still investigating "Lost Glory," and being unable to interact with Halfdan after first speaking to him in Picheringa. I would like to let you all know that they plan to fix this issue in a future update! We currently cannot provide an ETA for this update. Once we have more confirmed information, we will share it with you all within this thread and in the News & Announcements forum.

    @Xven00 - I'm sorry to hear you're unable to interact with Moira in "Lost Glory." Would you be able to post about this in a separate thread, as it will require a separate investigation to being unable to interact with Halfdan.

    Thanks! 😊

    Official Response
  • BalooTimon
    2 posts

    Ubisoft Dev team are just like your Headless Saxon.

    Patch 1.2.0 and STILL no fix.

    435 hours gameplay

  • Bumble-Bee281
    1 posts

    Any idea when this bug will be fixed?
    Still can't interact with halfdan.

  • rfalcades
    1 posts

    Same problem !!

  • Maddox64
    27 posts

    @bumble-bee281 My guess is that they don't have a clue or don't care. They have been telling us that it is under investigation since Dec and we are now entering April and we are getting the same response. Shoot, this is not even the worst of the bugged quests. A Brewing Storm bug is far worse.

    Look at the known issues mega thread and look at how many unable to progress quest bugs that they have listed there. Almost all of them were reported within weeks of the game release. But Ubisoft, instead of fixing these are releasing the River Raids, and I believe two different festivals, and transmog. Then, they patch the game with bug fixes for these new items while ignoring the bugs in the base game.

  • KinseyAS
    1 posts

    I was able to speak with Halfdan in Picheringa prior to starting the Lost Glory mission. Now that the mission is started it will not let me speak with him again to complete the mission.

    1 posts

    This story line has been down since day one and still nothing is done about it. It is mentioned on every forum and millions of Google hits and still 110 days later still nothing. The forum system is Complete rubbish as noone replies anyway so why bother. No wonder people are stopping playing this game why bother showing loyalty to the brand when the brand doesn't do the same. As long as Unisoft get their money screw those that spend it.

  • UbiExcellent
    756 posts

    @firstnitroheart Hello and welcome to the forums. I'm extremely sorry to hear about the negative experiences you've had with this specific bug within Assassin's Creed Valhalla so far. Would you be able to go into more detail about what is preventing you from progressing in "Lost Glory" please? Once I have a better understanding of the issue you're facing, I'll be happy to check on if this has been reported to our teams yet.

  • kenjirokitamura
    1 posts

    Okay so it’s April 2021 and I’m still having this issue!!
    Halfdan won’t speak to me in Picheringa. I can’t complete Lost Glory quest!

  • Maddox64
    27 posts

    Out of all of the quest bugs reported this has to be one of the easiest to reproduce but we still wait.

  • aVX_ceSAo
    2 posts

    @UbiExcellent Hi there, I'm stuck with Lost Glory quest. Experienced the same problem as others. I have found Halfdan earlier in the game and spoke to him, and now he won't talk to me at the right time to find his hammer and save his dog. It's simply stuck, he has a quest mark on him but won't interact with me no matter what I do. How do I solve this?? Have done the whole game and can't finish the storyline now because of this bug.

  • Ubi-Mark.
    Ubisoft Support Staff 2974 posts

    Hello @avx_cesao,

    Sorry to hear that you are unable to progress.

    This particular issue has been already reported to the development team and it's currently being investigated. Once it's resolved, we are going to let everyone know through the patch notes and the dedicated megathread.

    Apologies for any inconvenience caused by this and if you have any other questions, please let us know.

    PS: I didn't merge this thread to the megathread yet, as we're still awaiting for the confirmation from @FirstNITROHEART to double-check if it's the same issue.

    Official Response
  • Th3Randy
    Original poster 18 posts

    HOW is this still a bug FOUR MONTHS after first report?

Suggested Topics